nosek1969
Contributor
Contributor

połączenie Worstation 12 pro do ESXi 6.5

ESXi 6.5.0 - trial (bez klucza licencyjnego) build 4564106

Workstation 12 Pro licencjonowany 12.5.7 build-5813279

podczas próby połączenia do serwera ESXi

Failed to connect to 192.168.0.x. Cannot complete login due to an incorrect user name or password.

upgrade ESXI 6.5.0 do build 5310538

również

Failed to connect to 192.168.0.x. Cannot complete login due to an incorrect user name or password.

czy w ESXi należy ustawi dostęp?

czy też Workstation 12 Pro nie może się łączy z ESXi (ale może z ESX) - tylko błędny komunikat podaje?

czy to jakiś bug?

0 Kudos
4 Replies
bluefirestorm
Virtuoso
Virtuoso

Workstation Pro can connect to ESXi 5.x/6.x servers.

Assuming that the user ID/password you entered is correct or that the user ID is not locked, one possible problem I can think of is whether your user ID or password contain Polish accented characters such as ł or ą that require AltGr+key combination. I don't know for sure whether it causes a problem but that is a possible cause if either user ID or password or both contain characters that require AltGr+Key and AltGr+key combinations are not captured correctly or not sent to the ESXi server properly.

Are you using Windows as a host for the Workstation Pro? If using Windows, try using the PLP (Polish Programmer's Keyboard) keyboard instead of POL 214 keyboard (or vice-versa) if your user ID and/or password require AltGr+key combination.

Be careful though if there is indeed a problem with AltGr combinations, the ID might be locked out with the multiple attempts.

0 Kudos
nosek1969
Contributor
Contributor

user root

password is ok  (login www, login SSH)

one digit

one upper case

more lower case (not ąśźż.... alt+...)

one spejal      (  

write pass or ctrl + v

AND

install new system win7 64bit (virtual)

install Workstation 12 (trial)

and connect to host - work ok.

why not connect from win 10 prof 64bit?

I'm looking for why not

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

I am able to connect to ESXi 6.5 using Workstation Pro 12.5.7 from Windows 10 x64.

It is implied the "why not" is sought after whether by the person asking or by the person replying. In order to find fixes/solutions/workarounds, the "why it is not working" has to have some explanation. That is why I was suggesting a possible "why not" is the presence of Polish accented characters in either user ID or password. But since you have replied back that it doesn't that potential cause can be ruled out for now.

Is the account a domain account?

From %TEMP%\VMware-%USERNAME% folder, there should be a vmware-ui-nnnn.log file where nnnn is some 4 digit number. If you sort by date, you will see the latest attempt to connect to ESXi from that log file.

write pass or ctrl + v

Do you mean you copy and paste the user ID and password? What if you typed both in? The concern that I have with copy/paste is because AltGr and Ctrl key have the same keycode. If you copied using Ctrl+C, it might be interpreted as AltGr+C instead of Ctrl+C and the paste might be pasting some other thing that you didn't expect.

0 Kudos
nosek1969
Contributor
Contributor

two way

write password

or paste to field

win 10 - tested on new VM, and Workstation pro - work ok.

---------------

SOLVED

where is log?

here (TX 😞

From %TEMP%\VMware-%USERNAME% folder, there should be a vmware-ui-nnnn.log file where nnnn is some 4 digit number. If you sort by date, you will see the latest attempt to connect to ESXi from that log file.

inside log:   Crypto_EncryptPassword: CryptProtectData failed: 0x80090345

generally

Add      ProtectionPolicy=1

to registry HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb

source: [SOLVED] Can't start Dropbox - permission error - ... - Dropbox Community - 140310

Need to do this to fix the problem:

Create or set a new registry DWORD value, named ProtectionPolicy, value 1, to enable local backup of the MasterKey instead of requiring a RWDC in the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb

1. Hit Windows + R

2. Type regedit and hit enter

3. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb

4. In the folder, right click and hit New > DWORD (32 Bit) Value

5. Name it 'ProtectionPolicy'

6. Right click 'Protection Policy'

7. Hit Modify and change the value to 1 and select Base: Hexadecimal

0 Kudos