Contributor
Contributor

mouse get "locked" inside VM (quick question)

Hi! I am new user of VMware Workstation, and I have encounetered a problem.

Now when I move mouse and click on VM desktop, the mouse get "trapped" inside VM and I can get it to move back to my main computer.Offcourse the mouse is released pressing alt+ctrl, but I move mouse a lot between main computer and VM while I'm working, so it's annoying to press these buttons all the time. I am using Win XP on both machines. And this problem is only on one virtual machine, others are working fine.

Please help me, I have tried to read all the help files, but haven't found answer.

0 Kudos
12 Replies
Contributor
Contributor

"the mouse get "trapped" inside VM and I can get it to move back to my main computer."

Can not I meant :smileygrin:

0 Kudos
Immortal
Immortal

installing the VMware Guest Tools will allow as seamless auto-"unlock" of your mouse when going in between windows.

0 Kudos
Contributor
Contributor

It worked before without any extra programs. I think I pressed accidentaly something wrong on my keyboard, and solution is to press those buttons again. But what those buttons are?

0 Kudos
Immortal
Immortal

If you have the VMware Guest Tools installed it will allow for seamless mouse movements between host and guest. Without them as you've noticed to release your mouse you need to hit <ctrl> <alt>.

Check Edit--Preferences, I believe there are some mouse options there, other then that, I don't know of any special buttons that will allow this to work consistently. Like I said installing the VMware Guest Tools is your best bet for resolution.

0 Kudos
Leadership
Leadership

As Troy says, without VMtools being installed the default behaviour is to capture the mouse. verify that you have the three squares in the icon bar of the running XP Guest.

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth VCP / vExpert

VMware Communities User Moderator

Blog: www.planetvm.net

Contributing author for the upcoming book "[VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment|http://my.safaribooksonline.com/9780136083214]”. Currently available on roughcuts

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
Contributor
Contributor

Prblem solved itself when I restarted the VM, LOL :smileylaugh:

0 Kudos
Contributor
Contributor

A late response however I had the same issue today but only with one vm machine win7 here is how you can lock and unlock the mouse using windows settings:

Found it!

Control panel, Mouse, Pointer options, Display pointer trail, Click box to lock and unclick to release.

I hope this helps someone else.

0 Kudos
Leadership
Leadership

another is to use the key combinations Ctrl & Alt

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
Contributor
Contributor

I am sitting here crying with utter joy out of pent up frustration..

To release the Mouse Cursor, go to "Control Panel" -> "Mouse" -> "Pointer Options" and uncheck (turn-off) "Display Pointer Trails".

Finally, the agony is over!

rob_oli, YOU are a GENIUS!.. I can NOT thank you enough!

0 Kudos
Contributor
Contributor

Wsh2,

You are very welcome. I know your pain. Addittionally I thought I should put the instructions up for two other purposes. 1. because these blogs have helped me in the past and 2. in case I needed the ansewer in two years time when I forgot how I fixed it!

CTRL + Alt + A was definately not an acceptable answer.

Glad I could help.

0 Kudos
Contributor
Contributor

Good points rob_oli.. {smile}

Let's add some search words to try and assist in the future:

Windows Mouse Cursor Grab Ungrab Lock Unlock Integration

"Cursor Integration" "Cursor Grab" "Cursor Ungrab" "Cursor Lock" "Cursor Unlock"

"Mouse Integration" "Mouse Grab" "Mouse Ungrab" "Mouse Lock" "Mouse Unlock"

Solution Above

0 Kudos
Contributor
Contributor

Wow.  I have searched over and over again for a solution for this over the past two years and just read this and fixed the problem on the VM machine I use the MOST.  Thanks so simple.

0 Kudos