Enthusiast
Enthusiast

how to configure host OS so that virtual machine keeps running in background

I am facing some problems in my Gmail that I am discussing here

due to space and other complexities like viruses etc may come I do not want to install outlook etc on my current laptop.

My current laptop from which I am posting this question has been giving me troubles for performance inspite of having 12 Gb Ram it is not

giving good performance.  You can see this question

I want to download all my emails so I I prefer to install vmware and run Ubuntu 19.10 inside that virtual machine
I configured thunderbird and I am trying to download emails etc. If anyone wants to see problems in downloading email I am facing  they can refer

here and here

I configured Thunderbird on my Ubuntu virtual machine and tried to download all emails but since 13 Gb is too much to download obviously it created problems. So someone suggested me to download mbox format data which can be downloaded from takeout service of Gmail.

I tried that. I have a bit slow internet connection and intermittently it keeps disconnecting.

Now I tried using wget -c Url to download however since it keeps disconnecting so I got problems here also and later in a couple of retries I saw a message in the browser  

I get a message mentioning I exceeded the download limit screenshot that can be seen here.

Now the current problem I am facing is that this Windows 10 laptop goes to sleep

or hibernate or something happens due to which black screen comes I don't know what

is a technical word for this after a certain period of inactivity it happens and when this happens
my virtual machines also are suspended in the background.

I am downloading 13 Gb of my emails in virtual machines which in background download should keep running.

So how do I configure Windows 10 home edition laptop in a way that virtual machine keeps running in the background

and this laptop at the same time is sleeping after a certain amount of inactivity.

My virtual machine also sleeps after some time if I am not active.

winver shows version 1903 OS build 18362.535 for host OS.

Tags (2)
0 Kudos
3 Replies
Expert
Expert

Edit -> Preferences -> Keep VMs running aftere Workstation closes.   This is a global setting not sure if you apply it to a specific VM,

0 Kudos
Enthusiast
Enthusiast

In Windows Settings, search for Power & Sleep. Set "When plugged in, PC goes to sleep after" to Never.

0 Kudos
Enthusiast
Enthusiast

I think this setting is alread there see the screenshot

Annotation 2019-12-16 034756.jpg

I think I may need to check this setting also

https://kb.vmware.com/s/article/2056501

0 Kudos