Enthusiast
Enthusiast

how to boot with USB a vmware virtual machine

I want to try a lot of tutorials as given here

windows tutorials (tutorial index)

https://www.tenforums.com/tutorials/1977-windows-10-tutorial-index.html

I want to create USB installations I created one from media creation tool.

Now when I look to boot in vmware workstation settings inside BIOS of virtual machine I do not see

any setting by which I can enable boot via USB

add a boot option.jpg

Annotation 2019-12-23 210212.jpg

configure boot options.jpg

enable or disable boot options.jpg

enable or disable boot options2.jpg

0 Kudos
12 Replies
Enthusiast
Enthusiast

Once I've used a tool which creates a bootable CD so that it can be used to boot a computer and then tries to loading a connected bootable usb device. Useful for the old machine which can't support booting from usb. I don't remember its name and I don't have a backup of it right now, maybe you can search for it on your own.

0 Kudos
Leadership
Leadership

0 Kudos
Enthusiast
Enthusiast

No that did not help.

The virtual machine setting option looks as follows

Annotation 2019-12-25 093042.jpg

I tried what your blog mentions the screenshots I took again but I found them all to be same as the ones I posted above.

The boot options when I click inside the boot manager does not show me any option to boot from USB.

Annotation 2019-12-25 093734.jpg

Configure boot options

Annotation 2019-12-25 093735.jpg

Add boot options

Annotation 2019-12-25 093736.jpg

No option to enable USB boot

Annotation 2019-12-25 093737.jpg

Some PCI devices being shown to boot do not know which one is USB

Annotation 2019-12-25 093738.jpg

I am using

Vmware Workstation 15 Pro 15.1.0 build-13591040

0 Kudos
Leadership
Leadership

Your screenshots don't show an USB device connected to the VM. Please review the blog post (steps 7 & 8).

André

0 Kudos
Enthusiast
Enthusiast

Annotation 2019-12-25 102055.jpg

Annotation 2019-12-26 040715.jpg

0 Kudos
Virtuoso
Virtuoso

Some time back, I used a boot manager name Plop to enable booting from USB. It worked fine although it was a little old. The down load was plpbt-5.0.15.zip and the iso inside is plpbt.iso. When you use it as your iso install device, it brings up a menu with a choice for USB.

Lou

0 Kudos
Enthusiast
Enthusiast

I downloaded

from this page

https://www.plop.at/en/bootmanager/download.html

I downloaded  This package

https://download.plop.at/files/bootmngr/plpbt-5.0.15.zip

               tried putting plpt  ISO to boot

Annotation 2019-12-26 092757.jpg

Annotation 2019-12-26 092758.jpg

Annotation 2019-12-26 092759.jpg

I selected the plpt iso (which is probably plop boot manager ISO)

Annotation 2019-12-26 092760.jpg

There was no effect of using plpt boot ISO. What next can I try?

0 Kudos
Virtuoso
Virtuoso

Well, I just tested it and it worked. Probably not really oranges to apples but:
(I am not sure that all of is necessary)

I am running WS 14 on Linux Mint.
I created a new VM, minimal disk space, 5 GB
I told it the OS type was Linux 64
I told it I would install the software later.
I told it to use the plop iso for the CDROM, making sure that enable during power on was checked.
I let it complete the VM
I edited the vmx file to add BIOS.bootdelay="5000"
to add 5 seconds delay to let me easily hit esc.
During the boot process, hit esc and got a menu with USB as the only choice.
Edit: make sure the USB stick is in your system and recognized.

Edit 2: Make sure your USB stick is connected. Either VM removable devices or the icon in the lower right. You may have to power on and then connect it.


Messy but worked.
If something like that doesn't work for you, I have no clue.

Lou

-- 
Give a man a fish; you have fed him for today. Teach a man to use the Internet and he won't bother you for weeks,
or even months unless you give him your email address.
  ¯\_(ツ)_/¯
0 Kudos
Leadership
Leadership

You are looking at the wrong place top connect the USB device. Look at the screenshot at step 7 of the blog post that youv'e mentioned. Once the VM is powered on, you will see the icons below the guest screen. Click on the USB device that you want to connect to the VM.

You can either follow louyo​'s hint regarding the boot delay to pause the boot process until you've connected the USB device, or simply warm-boot the VM - pressing CTRL-ALT-INS - after connecting it.

André

0 Kudos
Enthusiast
Enthusiast

@

I edited the vmx file to add BIOS.bootdelay="5000"

I followed up to here boot delay was introduced but no USB boot option came.

I watched a video here How to Boot a VMware Virtual Machine from a USB Drive? - YouTube

enabled USB 2.0 compatibility instead of USB 3.0

still no success.

Annotation 2019-12-27 135206.jpg

No option to add USB while booting even after a start I power on and connect USB in VM when VM is powered on and reboot.

The USB, in this case, is connected but there is no success to boot from USB.

Annotation 2019-12-27 140837.jpg

0 Kudos
Leadership
Leadership

Ok, lets go through the steps again, to ensure that we are talking about the same things:

  1. attach the bootable USB device to your host PC
  2. create a VM, and add the bootdelay to it's configuration (already done)
  3. power on the VM, and press "Pause" while the bootdelay counts down to temporarily stop the countdown
  4. click on the USB icon in VMware Workstations status bar to connect the USB device
  5. resume booting the VM into the boot manager

André

0 Kudos
Virtuoso
Virtuoso

Hi Andre.

I should thank this thread for making me realize that I could not attach any USB devices to a VM. I don't normally do that. It seems that I lost that capability when I updated the host, Mint (mate), from 19.2 to 19.3. No matter what I did, I could not connect a device. I reinstalled Workstation (14) and that fixed it so I could retest booting to USB. I did use Plop though. I have no problems running all VM's on version 14, so have delayed going to 15.

Happy New Year

Lou

0 Kudos