stalag2005
Contributor
Contributor

found bug in 15.5.1 build-15018445 of Vmware Workstation pro

Jump to solution

I have 3 DVD devices in my system.  Whenever I enable them VM the guest OS does not like it and hangs for multiple minutes at a time.  I have had to revert the CD/DVD drives to an .iso file on my host to keep the guest from hanging.  I don't know how to fix this, but I can replicate this easily if I attempt to allow one of my drives to interact with the guest.

1 Solution

Accepted Solutions
stalag2005
Contributor
Contributor

I have repointed the CDROM device to a .iso file and the minutes of unresponsiveness have disappeared.  The way VMware polls CDROMS is the root of the problem and as such should be fixed.  There is no other work around.  If you have to use a CDROM make sure you are ready for the OS to freeze in the guest.  IMHO this is a severe bug and is worthy of a bug report.  Thanks to continuum for helping me to diagnose this.

The following URL sent to me by continuum lists why this is and the various settings that can be tried.

sanbarrow.com

View solution in original post

0 Kudos
6 Replies
continuum
Immortal
Immortal

CD / DVD drives can be connected in 2 modes: legacy emulation and raw.

Raw mode allows the use of CD/DVD writers but is problematic as the VM queries  the device very often - which results in the hangs you reported.

I would suggest to configure the physical devices in legacy emulation mode.

As far as I know that option is no longer exposed in the UI so use

*.deviceType = "atapi-cdrom " for legacy emulation and

*.deviceType = "cdrom-raw" for raw-mode.

Using 3 devices in "cdrom-raw" is a very exotic use-type and it does not surprise me at all that performance suffers significantly.

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
stalag2005
Contributor
Contributor

To be honest, all I need to use is one on rare occasion.  The hardware on the host is required for other purposes.  I am not certain how to use just one drive and force it to behave properly.  The continuous polling is a big problem for me as the guest is used for RDP/VPN sessions with my place of employment.  Honestly I am looking at this as a bug.  As long as the CD ROM is pointed at a .iso file, the problems go away.  How do I fix this permanently.  I am on Windows 10.

0 Kudos
continuum
Immortal
Immortal

All my VMs use Isos unless a special reason to use raw devices occurs.

Thats a good approach to get performant VMs.

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
stalag2005
Contributor
Contributor

I have repointed the CDROM device to a .iso file and the minutes of unresponsiveness have disappeared.  The way VMware polls CDROMS is the root of the problem and as such should be fixed.  There is no other work around.  If you have to use a CDROM make sure you are ready for the OS to freeze in the guest.  IMHO this is a severe bug and is worthy of a bug report.  Thanks to continuum for helping me to diagnose this.

The following URL sent to me by continuum lists why this is and the various settings that can be tried.

sanbarrow.com

View solution in original post

0 Kudos
scott28tt
VMware Employee
VMware Employee

Configuring the Autorun Feature on Windows Hosts

Or, just don’t leave the VM with the CD drive “connected” unless you need it.


-------------------------------------------------------------------------------------------------------------------------------------------------------------
VMware Training & Certification blog
0 Kudos
stalag2005
Contributor
Contributor

scott28tt, your answer is already implemented and does nothing in my case.  Problem is actually with vmware and the way it handles the transactions between host and guest.  Until that is fixed, the work around is as I gave above.  In fact, the box checked did not improve anything for me in the article cited.

0 Kudos