extrashot
Enthusiast
Enthusiast

configure vmware workstation so that virtual machines get IP from wifi access point bridging a workstation with wifi access point

Hi,

I am using Vmware workstation 15 on a laptop which is connected to Wifi network.

I am having Debian and Ubuntu instances running as virtual machines.

The host OS (Windows 10) is having following IP

Connection-specific DNS Suffix  . : xyz.cyd.com

   Link-local IPv6 Address . . . . . : de80::706b:4222:6799:f404%23

   IPv4 Address. . . . . . . . . . . : 10.1.1.31

   Subnet Mask . . . . . . . . . . . : 255.255.224.0

   Default Gateway . . . . . . . . . : 10.1.0.1

Now my vmware network settings are as in box below

vmware network serttings2.png

Now on my virual machines the IP I am getting are in the range

Debian Virtual machine shows

debian@debian:~$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

       valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

       valid_lft forever preferred_lft forever

2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:0c:29:6c:78:50 brd ff:ff:ff:ff:ff:ff

    inet 192.168.20.132/24 brd 192.168.20.255 scope global dynamic noprefixroute ens33

       valid_lft 1304sec preferred_lft 1304sec

    inet6 fe80::20c:29ff:fe6c:7850/64 scope link noprefixroute

       valid_lft forever preferred_lft forever

and Ubuntu Virtual machine shows

osboxes@osboxes:~$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

       valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

       valid_lft forever preferred_lft forever

2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000

    link/ether 00:0c:29:a9:92:d6 brd ff:ff:ff:ff:ff:ff

    inet 192.168.20.130/24 brd 192.168.20.255 scope global dynamic noprefixroute ens33

       valid_lft 1368sec preferred_lft 1368sec

    inet6 fe80::ac1e:acaf:d2fb:b59/64 scope link noprefixroute

       valid_lft forever preferred_lft forever

The situation is like this

                                                                                             |------Debian Guest OS (virtual machine) IP 192.168.20.132/24

                                                                                             |

Wifi Router--------------------------Windows 10--(vmware)-----|

(10.1.0.1)                                    IP (10.1.1.31)                     |

                                                                                             |-----Ubuntu Guest  OS (virtual machine)192.168.20.130/24

Other machines which are connected on network

are having IP ranges in 10.1.0.1 to 10.1.0.255 I want to be able to do an SSH from Debian Guest OS or Ubuntu Guest

OS to machines in my network. So what should be my network settings at vmware workstation to be able to do so.

Where as I want the guest OS is to get IP address in range of host OS ,i.e. the Virtual machines get the IP from Wifi router of network.

There are multiple virtual machines I am having how do I achieve in all these virtual machines. Because I need to ssh into

other machine and if IP are not in same ranges I can not do an SSH from virtual machines to other machines on network.

I want IP of virtual machines to be in ranges 10.1.1.X which is also the IP address of host OS windows 10.

How do I achieve this?

Thanks in advance.

0 Kudos
6 Replies
a_p_
Leadership
Leadership

With the current network configuration (NAT), your VMs should be able to reach other systems on the network, but not vice versa.

If that's all you need, I'd let the settings as they are.

Anyway, to answer your question. To have your VMs in the physical network range, you need to configure them for "Bridged" ("vmnet0" by default) networking.

Please click the "Change settings" button to run the Virtual Network Editor in elevated mode. This should allow you to see "vmnet0".

If you have multiple network adapters in your host system, you may also want to add a second "Bridged" network in order to distinguish between e.g. wired, and wireless networking. To make this work, change "Bridged to" on "vmnet0" to one of the physical network adapters, and create the second Bridged network using the other adapter. The select the desired  vmnet in the VMs' configuration.

André

0 Kudos
extrashot
Enthusiast
Enthusiast

I tried doing so what you mentioned.

I had a vmnet0 adapater in vmware settings I made it to bridged

see in image below vmnet0 is type bridged external connection is D-Link DWA 131 Wireless N

vmnet0 showing dlink wifi.jpg

after rebooting etc the guest OS did not show IP that should have come from wifi router in range of 10.1.0.1

see the screenshot below

Screenshot from 2019-09-08 14-33-58.png

However when I open virtual network editor

Edit--->Virtual Network Editor there it does not show me my new bridge vmnet0

vmnet0 not showing.jpg

but it is showing when I click on change settings then I can see vmnet0.

The Guest OS is not getting IP from wifi router instead it is getting IP from VMware DHCP which I do not want it to.

0 Kudos
a_p_
Leadership
Leadership

Did you also change the VM's settings, to use the bridge network (i.e. from NAT to Bridged)?

André

0 Kudos
extrashot
Enthusiast
Enthusiast

Yes I tried while doing all this I came across some knowledge gap which I have described in this thread how to know which vmnet is connected to virtual machines this thread is very much connected to question I posted here because when I originally posted question I was in an environment where I had wifi access via captive portal login mechanism and now I am in an environment where I have access to internet via plain WEP2 handshakes.

So I tried configuring in both environments the same thing some how I failed to do so there seems to be some knowledge gap in my understanding.

That environment will be available to me after 1 month.

Also see an answer here

You can't bridge to a WiFi client connection to an access point. If you could, we wouldn't need WDS.

The problem is that the WiFi specification prohibits an access point from putting traffic on the air unless that traffic is bound for one of its clients. Either the VM can be the client or the machine can be the client. But they can't both be because there's only one client connection to the access point.

This rule is a relic of times long ago when WiFi was very slow (11 Mbps or less) and just bridging traffic to the WiFi would have lead to horrible congestion. Unfortunately, WiFi is just enough like Ethernet to make people think it's the same, but it's not. You can't bridge to a client connection.

You could use a wired connection. You could use some form of NAT (it doesn't have to be IP NAT, MAC NAT will usually mostly work). You could use routing instead of bridging.

https://superuser.com/questions/1495476/internet-disconnects-after-switching-on-virtual-machine-in-b...

What is your view on this answer.

0 Kudos
Photubias
Enthusiast
Enthusiast

Hi,

Bridging to Wi-Fi works, as long as the Wi-Fi security is not WPA2 Enterprise.

All other forms of Wi-Fi security (open/portal/WEP/WPA2-PSK) should work.

Although the MAC address presented on the Wi-Fi network will be the physical one from your host.

Your VM's will get an IP address from the physical Wi-Fi network.

Regards

0 Kudos
extrashot
Enthusiast
Enthusiast

Ok I do want to know more about this if you can share any link or tutorial let me know.

I will get the opportunity to test the thing you told after 18 days when I go back to that place where WiFi is by portal I myself wanted my Virtual machines to be bridged and get wifi connectivity in portal based login but my experience was when I powered on virtual machine the host will loose internet connectivity. Unfortunately due to tutorials assignments lab presentations and all other circus I never had time that I could discuss on forums in detail. Right now the university is closed so I am reading about this stuff and doing experiments about Vmware on my own.

0 Kudos