adrianrt
Enthusiast
Enthusiast

cant boot the vm anymore

Hi,

 

So I had a lot of work to do today and all of a sudden my vm doesn't boot anymore. I've attached the log here.

It just hangs with "Waiting for connection".

Any help is greatly appreciated, this has already cost me a day of work 😞

 

Thanks,

A

 

 

10 Replies
adrianrt
Enthusiast
Enthusiast

somhow the situation slightly improved, but not sure how or why.

 

the vm, booted but it's not usable 😞 

it looks like in the attached screenshot

Tags (1)
0 Kudos
heath140
Contributor
Contributor

I have something very similar today as well, seems like what I can see in the logs is a panic when mksSandbox process crashed. I've added logs as well so hopefully someone can diagnose it.

0 Kudos
heath140
Contributor
Contributor

Found a solution in another thread:

Disable the "Accelerate 3D Graphics" 

Some have said that you might be able to leave it on and extend the timeout of mks.sandbox, but that didn't work for me. If you want to try you can alter the *.vmx file and create a line with:

mks.sandbox.socketTimeoutMS = "200000"

0 Kudos
adrianrt
Enthusiast
Enthusiast

disabling the 3D graphics kind of worked, now I can't boot but the GUI inside the VM doesn't work anymore 😞

0 Kudos
randyrob
Contributor
Contributor

I had the same exact symptoms.  Disabling "Accelerate 3D Graphics" got me limping again, but still had other weird stuff like problems with input focus.

 

I don't actually use this VM that often, but I had upgraded to 16.2.1-18811642.  I reverted back to 16.2.0-18760230 and everything seems to be working fine again.  It seems to me that something must have been broken in the new 16.2.1 version (note: I am running the Unix version of VM WS Pro on Linux/Mint with a Windows10 VM - my WinXP VM was not affected).

 

Thanks,

-randy

0 Kudos
randyrob
Contributor
Contributor

Just tried 16.2.3-19376536 and it is still broken.  Back to 16.2.0-18760230...

Thanks,

-randy

0 Kudos
randyrob
Contributor
Contributor

Tried 16.2.4-20089737, still broken...

0 Kudos
randyrob
Contributor
Contributor

Found this post and it worked for me:

https://communities.vmware.com/t5/VMware-Workstation-Pro/VMware-16-2-1-Display-3D-acceleration-not-w...

I added these options to ~/.vmware/config (this file did not exist for me, so I created it) and restarted vmware.

mks.enableX11Presentation=TRUE
mks.enableVulkanPresentation=FALSE

0 Kudos
andrewreid91
Enthusiast
Enthusiast

What is the current version of VMware workstation that you are using ?

0 Kudos
randyrob
Contributor
Contributor

With the changes noted above in my ~/.vmware/config file, I am running the latest: 16.2.4-20089737.

Thanks, -randy

0 Kudos