Contributor
Contributor

You have an incorrect version of driver "vmci.sys"

When i start the virtual machine in VMware Workstation 8 i receive the following error:

You have an incorrect version of driver "vmci.sys". Try reinstalling VMware Workstation.

I unistall and reinstall VMware Workstation but still receive this error.

Any ideas?

vm.png

Thank you.

0 Kudos
7 Replies
VMware Employee
VMware Employee

I've just hit this problem too when using windows 7 64 bit edition with workstation 7.0, I upgraded to workstation 8.0 to see if it fixed also tried repairing the install but no joy. “You have an incorrect version of driver vmci.sys”

Then I stumbled across some notes on someones blog which suggested the following

1. Open the vmx file related to the vm

2. Locate and change the following line to vmci0.present = “false”

Doing this allows me to power on my VMs but does not fix the issue fully. Not worked out how to do that yet.

0 Kudos
Immortal
Immortal

the new buggy installer of version 8 has several problems with VMCI - on many systems the whole setup fails just because VMCI-install fails.

The situation gets worse because all default VMs have
vmci0.present = "true"
in the vmx - although only a very small number of users ever use it.

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Contributor
Contributor

I've just encountered the same issue after accepting the 8.0.1 update yesterday.  Is changing that vmx setting the only fix available for this?

Thanks!

0 Kudos
Immortal
Immortal

Workstation 8 installer can not really handle the installation or removal of the vmci driver.
Which one do you have ?

Anyway - disable it in the vmx for now if you are not interested in getting your hands dirty with registry and command line hacking

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Contributor
Contributor

Thanks Ulli –

Actually I’m not very familiar with what driver that is. How would I determine that and or disable it?

Thanks!

Nick

0 Kudos
Immortal
Immortal

find c:\windows\system32\drivers\vmci.sys
right click it and check version number

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Contributor
Contributor

Step-1 Go to Virtual Machine folder where all VM stored, generally under "Document" folder

Step-2 Open each VM folder

Step-3 Open .vmx file with notepad++ editor

Step-4 Search "vmci"

Step-5 You will get a line: vmci0.present = "TRUE"

Step-6 Change TRUE to FALSE

Step-7 Save the file: Ctrl + S

Step-8 Repeat same steps for all the VMs

now you done!!

0 Kudos