pingu2k4
Contributor
Contributor

Workstation GPU performance issue

I have a system which has a Threadripper 3970x, 256GB RAM and a 2080 ti. I run Windows 10 as host, and run multiple Windows 10 VM's through Workstation 15.

I have peers who run VM's for the same purposes as me, and the difference between our GPU load is quite significant. I can't find any setting difference that would negatively effect me to such an extent. Host has latest drivers for GPU installed.

To measure GPU load, temps, etc I was using GPU-Z.

When all VM's are idle (Chrome browser open, single tab open, with gmail loaded), GPU load ranges from ~ 0-3%, so its effectively nothing.

Loading a website which has a html5 canvas application, on a single VM, whilst that VM tab is within view takes my GPU load up to ~ 30% constantly. This is with no interaction with the html5 canvas, Just having it loaded and it plays some basic animations in its own "idle" form.

Loading the same thing on a second VM takes me up to ~ 40% load (whilst both tabs are in view on my screen). It increases onwards from here, the more I load.

I regularly have ~ 15 VMs running, and at times I need to load and interact with this html5 canvas app on each VM simultaneously.

Now, one of my peers who has the exact same usage, is running on a GTX 970 (compared to my 2080 ti). He has to load that exact same canvas app on 5 of his VM's before he reaches 30% GPU load, whereas I reach that after just 1...

He runs his VMs at a slightly smaller res than I do, mine are 1280x960 whereas his are 1024x768, so not a major difference. But a major difference in performance.

in each of my VM settings, Accelerate 3D graphics is ticked on, and VMWare tools is installed on each VM.

Each of my VMs are identical in setup - 6GB RAM, 4 processor cores, 1280x960 res. Max graphics memory setting is set to 1Gb, the recommended option.

In terms of what I have done to better the performance so far, before I was forcing OpenGL, by adding the following to the VMX:

mks.enableDX11Renderer = "FALSE"

mks.enableGLRenderer = "TRUE"

mks.enableD3DRenderer = "FALSE"

mks.enableGLBasicRenderer = "FALSE"

I have removed this and noticed slightly better perf - that better perf is what I am listing above.

When GPU reaches 2 or more VM's with the canvas application loaded, it is throttled  by VRel - its clocks are at their maximum for the voltage its recieving. This is 1935mhz and 1700 mhz for mem clock.

Anything you think I could to to improve this, or just to test out etc would be much appreciated! Been doing my head in...

0 Kudos
4 Replies
Mits2020
Hot Shot
Hot Shot

Welcome to the Workstation Community!

In order to help narrow down the problem, since there are too many parameters involved (including a CPU that is just 6 months old), please clarify which precise versions or Win10 are you using in the host and the guests, which WS version you are using, which version of VMTools are installed and whether Hyper-V features on the host are enabled or disabled.

Also, if you have tried it, please describe whether your experience with non chrome-based browsers in your context is the same.

0 Kudos
pingu2k4
Contributor
Contributor

Apologies on not being thorough enough.

VMware version is WorkStation Pro 15.5.2 build-15785246

Host OS version is Win 10 64-Bit, 10.0.18363

Guest OS versions are also the same.

VM Tools version is not the latest, its the one before the April 7th release. 11.0.5

Have tried a few browsers and GPU load is similar on all of them.

Hyper v settings not turned on on host. Should they be? (All Hyper V options turned off in Windows features panel)

0 Kudos
Mits2020
Hot Shot
Hot Shot

Thanks for the details, soon some more experienced users with modern hardware will step in. My guess is they'd advise to update to the latest versions of everything but I understand this is not always desirable of feasible on a production system.

Disabling Hyper-v surely helps avoiding unnecessary complications.

0 Kudos
pingu2k4
Contributor
Contributor

Thanks.

I have been doing more troubleshooting etc, during which time I have already updated workstation to 15.5.6, and updated to the latest vmware tools in guests. I also updated GPU drivers which weren't too far behind, but they are now on 451.48 which is the latest.

On NV Control panel, I've set all settings in manage 3d settings tab to performance pretty much, and I have gained a little extra performance here, but its still not where I would expect in comparison to my peers benchmarks.

I also ran another test switching openGL force back on in one VM, I wanted to see if I could go back to that since updating drivers etc with no penalty. I observed that GPU load was a tiny amount higher on average with openGL force on, but the GPU clocks were FAR higher, which indicated that it scaled far worse. So I am sticking to no OpenGL force in the VMX config.

(this was my only fix I had found for a seperate issue, where chrome popups and dialogs such as those from extensions were transparent in guest VMs)

0 Kudos