Highlighted
Contributor
Contributor

Workstation 9 - Slow network performance between host and guest

Jump to solution

I am running windows 8 on the host and installed Workstaion 9 trial. Then installed windows 8.1 as a guest system.

I am getting slow, really slow network between the two.

If i send files to and from the guest with another computer, transfers are normal, but if I try same files between host and guest they are really slow.

I am using a Bridge connection.

I have read elseware to disable the following on the host adapter:

Large Send Offload v2 (IPv4)

Large Send Offload v2 (IPv6)

But that did not help.

Thoughts?

1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

Try then Hyper-v maybe it help you better.

report this incident to Vmware if you can

Regards


View solution in original post

11 Replies
Highlighted
Contributor
Contributor

Ok I just notice if I grab a file from the guest to host i get about 8-10mb speed but if i send a file from host to guest it is like 100kb speed

Also it does not matter if the trasfer it from with in the guest or the host. Same results!

VM --> Host = works

VM --> Any networked computer except host = works

Any networked computer except host --> VM = works

Any networked computer --> Host = works

Host --> Any networked computer = works

Host --> VM = Slow, slow, slow, slow..... SLOW

I see this has been an issue going back as far as 2003. Really? Still no fix for this. This is one heck of a bug to last 10 years. I have been reading things to try all over the net and nothing works.

How ever I did install VirtualBox and created the same setup and transfer speeds are like 50+mb each direction, so this is a bug related to vmware.

And no I dont like virtual box, that's why I am trying vmware and i love all the features of it and if I can get this bug fixed I plan on buying it after my trial is over.

Please I need your help. (And so does 1,000,000+ other users)

- Almulder

0 Kudos
Highlighted
Contributor
Contributor

Really, Nobody?, Maybe I should have offered a BS $1000 reward like the other guy did. You would help or read it then right?

Sorry, Just flaming as I can't believe that the worlds leading in VM has this kind of issue. There has to be a simple solution.

0 Kudos
Highlighted
Contributor
Contributor

Hi almuder,

Try to install another VM on your host and see if you meet the same problem?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Have you copied this vm from other machine?

0 Kudos
Highlighted
Contributor
Contributor

I have installed several other VM on the host. XP, Vista, 7, 8, 8.1 - Same result

Host machine was a fresh install of windows 8 and then a fresh install of VM. and then installed the fresh guest on the host.

Same issue when tried on other 2 computers. So this is not related to just the PC hardware.

I have done hundreds of searches on line and there are people everywhere with this same issue. Dating back to 2003 to 2013 having this very same issue. Some have had lick chnaging setting on the HOST network adapter. I have made the same changes and still no change in speed.

0 Kudos
Highlighted
Contributor
Contributor

Try then Hyper-v maybe it help you better.

report this incident to Vmware if you can

Regards


View solution in original post

Highlighted
Contributor
Contributor

Aw thanks, Just found out Hyper-V is part of Windows 8 Pro (Free). Just installed it an tested. Working great. even handles things better than VMware would have. Thanks so much. Network speeds are what they should be. Working great. You saved me buying VMware. YAY!

Highlighted
Enthusiast
Enthusiast

I have a Windows 7 host workstation, and I'm seeing the same problem as the OP here with both Windows 8.1 Pro Preview and Enterprise Preview guests.  Networking works great with all other guests, including XP, Vista, Windows 7, Windows 8.

It's as though after a while a resource gets used up or packets start being hopelessly corrupted.  Likely the protocol is retrying, and somehow getting things through once in a blue moon.  Transfer speeds can drop to as little as a few bytes per second.

I have Bridged networking, and know a thing or two about setting up Windows and networking.  It's not a basic configuration issue.

I suspect what is needed is a VMware Tools update.  Perhaps the networking driver just isn't compatible with Windows 8.1.

Reading the above thread, it's very depressing.  Basically the help received on the VMware forum was "don't bother using VMware".  Look, if you're tempted, please don't suggest "use another virtualization solution".  I need VMware to work.  Come on, folks, the Windows 8.1 previews are no longer new news.  There must be a solution or workaround to this.  Maybe a beta VMware Tools version or something in development?

Help please.

-Noel

0 Kudos
Highlighted
Contributor
Contributor

This is marked as answered, but it looks like the "answer" is to use another product.

Has anyone seen a real answer?

I am using workstation 10 under Win7/64 with Ubuntu and WinXP guests. I have this slow network issues (30KB/s) when accessing the guest via the host (SMB/CIS and FTP). In NAT mode, I don't see it -- it works at about 15MB/s. The problem also happened with Workstation 6.5 (one of the reasons I upgraded to 10 -- so don't upgrade just to fix this).

VMware says if it is fast using NAT and slow using bridged, then it's your router or ISP -- go fix it (paraphrase):

VMware KB: Troubleshooting a slow network connection in VMware Workstation

But given the symptoms and the fact that other VM software doesn't have this issue, I am having trouble seeing how it could be the router (the ISP is out because I sometimes use this without one). Does anyone have an explanation for how this could be?

The symptoms are exactly as described by the OP (good job) in that it is only the Host->Guest that is slow. Other machines one the network are not slow to this guest and neither the guest nor the host are slow to anything else.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes, I finally got an answer with little downside.  It involves editing the network adapter in the .vmx file.  Replace the occurrences of "e1000e" with "e1000" or "vmxnet3".

Example:

ethernet0.virtualDev = "e1000"

See this thread for a long discussion on the subject:

https://communities.vmware.com/thread/455134

-Noel


0 Kudos
Highlighted
Contributor
Contributor

I know this is an older issue, but I had the same problem, but the resolution is different and as this seems to be the first search result, would post an alternative resolution.

My VMs already had the ethernet0.virtualDev  = "e1000".  changing it to vmxnet3 did not resolve the issue. 

I found this link:

Re: Very slow network throughput Host->Guest but not Guest<-Host

Which states on page 3:

I don't have a TCP Segment OffLoading option on my Server 2008 Standard x64 system's Intel 82566DM gigabit card, but disabling Large Send Offload v2 seemed to work for me.

I disabled it and immediately networking is working fine for me as well.

Thought I'd post this to help others.

0 Kudos