Highlighted
Contributor
Contributor

Workstation 9 - No 3D Acceleration to Guest - Ubuntu 12.04 Host - Nvidia Card

Ok, I've been going at this for some time.

Current Installation: Fresh install of Ubuntu 12.04

Video card: Nvidia Optimus GT540M

VMware: Workstation 9. (Unbuntu 12.04 is the HOST)

(Brief history: tried to get 3D support working under Workstation 8, using numerous nvidia drivers (every step you can find online), upgraded to Workstation 9 and retried all the steps. Reinstalled Ubuntu.);

Current status: Currently using Bumblebee. 3D WORKS on Ubuntu. I have glxinfo returning YES for 3D support and glxspheres working.

Since No nvidia drivers are installed, Vmware Workstation WILL NOT recognize the video card, and thus will not enable 3D support for the Windows 7 VM. - This is the problem we need to solve.

I have tried to uninstall Bumblebee and install Nvidia drivers and suffered from the 640x480 issue, with the Nvidia Settings not detecting a proper x configuration.

So the issue is currently: VMware will not recognize the video card properly since Bumblebee is installed. The 3D support will ONLY (so far) work using Bumblebee.

Let the delimma begin. This is currently a Vmware issue, although could quickly become another Ubuntu 12.04 issue if I have to go down the path of many drivers.

(Yes, I spent 9 hours trying to install every version of the Nvidia drivers everyone "suggested" with zero luck and many issues.)

112 Replies
Highlighted
Contributor
Contributor

I've got the same situation with a similar environment: a NVidia card (Nouveau driver) on Fedora 16 / x86_64.

Fedora 16 is explicitly listed as a supported platform.  I do have 3D capacilities (per glxinfo, and the KDE desktop), yet VMware Workstation complains.

0 Kudos
Highlighted
Contributor
Contributor

Yeah no I know that. We're not installing Nvidia in the VM. We're installing them in the Ubuntu Host.

0 Kudos
Highlighted
Enthusiast
Enthusiast

The 3D acceleration doesn't work for me also in the guest. Host: CentOS 6.3 x64, NVidia GT440 (with a driver from nvidia website), guest CentOS 6.3 x64.

vmware-tools installed in the guest, but the tools installer doesn't install any driver for xorg (version 1.10.6):

Distribution provided drivers for Xorg X server are used.

Skipping X configuration because X drivers are not included.

--clobber-xorg-modules option also ineffective. xorg using the vmwlegacy driver after a warning:

[    31.808] (II) LoadModule: "vmwgfx"
[    31.808] (WW) Warning, couldn't open module vmwgfx
[    31.808] (II) UnloadModule: "vmwgfx"
[    31.808] (II) Unloading vmwgfx
[    31.808] (EE) Failed to load module "vmwgfx" (module does not exist, 0)
[    31.808] (EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
[    31.808] (II) vmware: Using vmwlegacy driver everything is fine.
[    31.808] (II) LoadModule: "vmwlegacy"

0 Kudos
Highlighted
Contributor
Contributor

I actually got 3D working in VMware Workstation 8.x and Player 4.x...but not with WS9/Player5.

I have almost the same harware as you:

- Optimus Intel HD3000/NVidia combo.

- Ubuntu 12.04 x64

To get 3D support with WS8...I had ti install the following:

- nvidia-current driver

- bumblebee

- driconf

Was able achive 3D support...including Aero working in a Windows 7 VM.

BUT....this combo does not work with WS9...... 😠

Anyone know how to get 3D back in WS9 for my VM's???

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

Hi. I have got:

- The infamous Combo nVIDIA Optimus / Intel cards (in a ASUS N55SF S1284V)

- Ubuntu 12.04

- VMware Workstation 9

- Bumblebee (and, as Bumblebee installer says, I do "sudo apt-get purge nvidia-current" and "sudo add-apt-repository ppa:ubuntu-x-swat/x-updates". This use newer nVIDIA drivers)

I think if Bumblebee is installed or not does not matter to VMware. But the nVIDIA drivers that Bumblebee install are important for VMware Workstation 9. Anyway you can install these drivers from Synaptic...

The following works for me and, sooner or later... crash:

1.- Add the following to the .vmx file:

mks.gl.allowBlacklistedDrivers = TRUE

(this tells VMware: yes, my card is actually good)

2.- Install from Synaptic::

libtxc-dxtn-s2tc-bin

libtxc-dxtn-s2tc0

This is a free S3 implementation of texture compression library for Mesa

3.- Open VMware Workstation 9 and run a Windows 7 VM, for example.

This works fine... until it breaks with the message:

"VMware Workstation unrecoverable error (svga):

Unexpected signal: 11.

A log file is available in blah, blah, blah..."

Smiley Sad

0 Kudos
Highlighted
Contributor
Contributor

I correct myself:

I had forgotten to run VMware with optirum option (i.e. Bublebee):  :smileysilly:

optirun /usr/bin/vmware

Now, runing VMware and Bumblebee, it seems to work. At least takes several minutes without breaking.

If this works, I may have found a solution! :smileygrin: We will touch wood... Smiley Wink

UPDATE:

Update: It also breaks running with optirun option :smileycry:

The "unrecoverable error" is now: (vcpu-2)

0 Kudos
Highlighted
Contributor
Contributor

I'm on the same boat. Well technically not the same, but pretty close.

I'm running Debian on an optimus laptop, and 3d acceleration worked fine on workstation 8, but now it's broken.

I tried the

mks.gl.allowBlacklistedDrivers = "TRUE"

trick, but it failed. Workstation crashes.

I then (removed that non-working "fix" and) tried to run vmware using optirun, assuming it would then use the nvidia card and work fine.

That is still not the case. I still complains and disables 3d acceleration.

Log file attached.

Revelant messages:

2012-09-09T17:29:43.913Z| vmx| I120: DICT              mks.enable3d = TRUE

2012-09-09T17:29:44.227Z| vmx| I120: VMIOP: unable to find plugin "svga3d"

2012-09-09T17:29:44.234Z| mks| I120: Disabling 3D on this host due to presence of Mesa DRI driver.  Set mks.gl.allowBlacklistedDrivers = TRUE to override.
2012-09-09T17:29:44.462Z| mks| I120: GLXCreateContext Couldn't find a suitable FBConfig while creating context.
2012-09-09T17:29:44.465Z| mks| I120: Disabling 3D on this host due to presence of Mesa DRI driver.  Set mks.gl.allowBlacklistedDrivers = TRUE to override.
2012-09-09T17:29:44.466Z| mks| W110: GL-Backend: Failed to start GLBackend's screen compositor, GLBackend will stop working!
2012-09-09T17:29:44.466Z| mks| W110: MKS-RenderMux: Backend GLBackend<7F3D4C05C940> failed to start. Disabling.
2012-09-09T17:29:44.466Z| mks| I120: MKS-SLC: failed to start svga3d vmiop to render 3d.

2012-09-09T17:29:44.790Z| vmx| I120: Msg_Post: Warning
2012-09-09T17:29:44.790Z| vmx| I120: [msg.glX.noHardwareAccel] Hardware graphics acceleration is not available. As a result, this virtual machine may experience very low graphics performance. Follow the instructions provided by your graphics card vendor or Linux distribution in order to update your computer's OpenGL drivers.
2012-09-09T17:29:44.790Z| vmx| I120: ----------------------------------------
2012-09-09T17:29:44.841Z| vmx| I120: Msg_Post: Warning
2012-09-09T17:29:44.841Z| vmx| I120: [msg.mks.no3D] No 3D support is available from the host. The 3D features of the virtual machine will be disabled.
2012-09-09T17:29:44.842Z| vmx| I120: ----------------------------------------

2012-09-09T17:29:45.396Z| mks| I120: Disabling 3D on this host due to presence of Mesa DRI driver.  Set mks.gl.allowBlacklistedDrivers = TRUE to override.

2012-09-09T17:29:53.247Z| vcpu-0| I120: SVGA: Unregistering IOSpace at 0x10f0
2012-09-09T17:29:53.247Z| vcpu-0| I120: SVGA: Unregistering MemSpace at 0xd0000000(0xd0000000) and 0xc8800000(0xc8800000)
2012-09-09T17:29:53.248Z| vcpu-0| I120: SVGA: Registering IOSpace at 0x10f0
2012-09-09T17:29:53.248Z| vcpu-0| I120: SVGA: Registering MemSpace at 0xd0000000(0xd0000000) and 0xc8800000(0xc8800000)
2012-09-09T17:29:53.249Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA Driver Version: 11.09.01.0000 - build-745082
2012-09-09T17:29:53.249Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA Caps: 0x007fc3e2 (3D, EXTENDED FIFO, GMR, GMR2)
2012-09-09T17:29:53.249Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA VRAM: 134217728, FIFO: 2097152
2012-09-09T17:29:53.249Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA Using GMR2, max pages=196608
2012-09-09T17:29:53.250Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA GMR: max IDs=64, max desc length=4096
2012-09-09T17:29:53.251Z| vcpu-0| I120: Guest: SVGA_MINI: MULTIMON: Pitch lock set to 15360

2012-09-09T17:29:54.320Z| vcpu-0| I120: Guest: SVGA_MINI: VMXInitialize
2012-09-09T17:29:54.321Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA FIFO Caps: 0x00000000
2012-09-09T17:29:54.321Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA FIFO HW Version: host 0x00000000, guest 0x00020001
2012-09-09T17:29:55.192Z| vcpu-0| I120: Guest: SVGA_MINI: IOCTL_VIDEO_SWITCH_DUALVIEW: id=0, enable=1, numDisplays=2
2012-09-09T17:29:55.192Z| vcpu-0| I120: Guest: SVGA_MINI: IOCTL_VIDEO_SWITCH_DUALVIEW: id=1, enable=0, numDisplays=2
2012-09-09T17:29:55.192Z| vcpu-0| I120: Guest: SVGA_MINI:    SECONDARY MONITOR enabled=0
2012-09-09T17:29:55.246Z| vcpu-0| I120: Guest: vmx_fb: tap: init
2012-09-09T17:29:55.254Z| vcpu-0| I120: Guest display topology changed: numDisplays 1
2012-09-09T17:29:55.254Z| vcpu-0| I120: SVGA enabling SVGA
2012-09-09T17:29:55.307Z| vcpu-0| I120: Guest: SVGA_MINI: SVGA Display Topology: SVGA enabled, FB size=12288000, topology=TRUE
2012-09-09T17:29:55.307Z| vcpu-0| I120: Guest: SVGA_MINI: numDisplayActive=1, Max: wxh=1280x800, pitchlock=15360
2012-09-09T17:29:55.307Z| vcpu-0| I120: Guest: SVGA_MINI: Offscreen: offset=0xbb8000, size=121929728
2012-09-09T17:29:55.307Z| vcpu-0| I120: Guest: SVGA_MINI:    DisplayId=0, primary=TRUE, screen object=UNUSABLE
2012-09-09T17:29:55.308Z| vcpu-0| I120: Guest: SVGA_MINI:    Display: offset=0x0, size=12288000, pitch=15360
2012-09-09T17:29:55.308Z| vcpu-0| I120: Guest: SVGA_MINI:    Backing Store: offset=0x0, size=0
2012-09-09T17:29:55.308Z| vcpu-0| I120: Guest: SVGA_MINI:       xy=0, 0
2012-09-09T17:29:55.309Z| vcpu-0| I120: Guest: SVGA_MINI:       wxhxd=1280x800x32
2012-09-09T17:29:55.310Z| vcpu-0| I120: Guest: vmx_fb: This is the primary surface: PPDEV e1883010
2012-09-09T17:29:55.310Z| vcpu-0| I120: Guest: vmx_fb: Display driver is out of sync with virtual hardware.  Disabling 3d.
2012-09-09T17:29:55.310Z| vcpu-0| I120: Guest: vmx_fb:   Current hardware revision: 0.0.
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb:   Driver compiled against:   2.1.
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb: Display Acceleration: DirectDraw:ok, Direct3D:disabled.
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb:   Current hardware revision: 0.0.
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb:   Driver compiled against:   2.1.
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb: DrvGetDirectDrawInfo: Overlay flags set
2012-09-09T17:29:55.311Z| vcpu-0| I120: Guest: vmx_fb: DrvGetDirectDrawInfo: offset=0x0, wxh=1280x800, bpp=32, pitch=15360
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb: This is the primary surface: PPDEV e1883010
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb: Display driver is out of sync with virtual hardware.  Disabling 3d.
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb:   Current hardware revision: 0.0.
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb:   Driver compiled against:   2.1.
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb: Display Acceleration: DirectDraw:ok, Direct3D:disabled.
2012-09-09T17:29:55.312Z| vcpu-0| I120: Guest: vmx_fb:   Current hardware revision: 0.0.
2012-09-09T17:29:55.313Z| vcpu-0| I120: Guest: vmx_fb:   Driver compiled against:   2.1.
2012-09-09T17:29:55.313Z| vcpu-0| I120: Guest: vmx_fb: DrvGetDirectDrawInfo: GMR DX heap disabled, size 0, available memory 805306368
2012-09-09T17:29:55.313Z| vcpu-0| I120: Guest: vmx_fb: DrvGetDirectDrawInfo: Overlay flags set
2012-09-09T17:29:55.313Z| vcpu-0| I120: Guest: vmx_fb: DrvGetDirectDrawInfo: offset=0x0, wxh=1280x800, bpp=32, pitch=15360
2012-09-09T17:29:55.314Z| vcpu-0| I120: Guest: vmx_fb: Caps_GetDeviceD3DCaps: CANAUTOGENMIPMAP off (0, HW v0 131073)
2012-09-09T17:29:55.314Z| vcpu-0| I120: Guest: vmx_fb: Caps_GetDeviceD3DCaps: MaxActiveLights=8
2012-09-09T17:29:55.314Z| vcpu-0| I120: Guest: vmx_fb: Caps_GetDeviceD3DCaps: MaxActiveLights=8
2012-09-09T17:29:57.624Z| vcpu-0| I120: HgfsChannelVmciConnectInternal: VMCI HGFS server session init complete and opened.

I don't understand why it still mentions the mesa driver. It should be using nvidia gl driver.

Any way to fix this and get 3D working?!

I guess I should have bought workstation 8. At least that one worked. Now I'm stuck.

0 Kudos
Highlighted
Contributor
Contributor

bumping for a solution

0 Kudos
Highlighted
Contributor
Contributor

Found a bit more info, but still no working solution for me

http://askubuntu.com/questions/181829/how-to-fix-opengl-error-for-vmware-workstation-9

mks.gl.allowBlacklistedDrivers = TRUE

And then also install the Mesa-libtxc_dxtn1 (aka the S3 texture compression)

(tried it and it didn't work for me)

http://unixblogger.wordpress.com/2012/09/06/vmware-workstation-9-is-out-and-it-doesnt-work-for-me/

I’ve downloaded the kernel packages for the latest Ubuntu 12.10 development release and installed it. [that has kernel 3.5]

Well, now I’m able to use my Fn keys and even my NVidia graphic card without any problems. But now, while I’m useing a 3.5 kernel, VMWare Workstation 9 refuses to starting up. I’m able to install, compile the modules and enter the licence key, but shortly after trying to work or to start a VM, I get a “stack trace flood” which causes my X Server to freeze.

I’ve tested the new submitted patch for kernel 3.5 and Workstation 9 on myself, but it doesn’t help for me, too. I always get the “stack trace flood” recently, after I started a virtual machine.

(I haven't tried this one)

It's very frustrating that I had WS 8 working but now WS 9 is completely foobared in Linux.

0 Kudos
Highlighted
Contributor
Contributor

And still another problem:

I do not know if this is caused also by Optimus issue, but now (unlike with Workstation 😎 constantly asks me to install the VMware Tools (well. .. I can't install something that is already installed, I simply "Repair" the previous VMWare Tools installation). This is quite annoying, and it happens in all the guests.

Are you this happens to you too?

0 Kudos
Highlighted
Contributor
Contributor

Yes, that happens too.

But you can simply ignore it.

If the vmtools weren't working, then you would be limited to 640x480, but you don't (well at least I don't.  I can use any resolution I want in the windows xp guest).

0 Kudos
Highlighted
Contributor
Contributor

The reply by ninjacoding, includes my reply on the ubuntu forum, i was hoping to get 3d acceleration in windows guest on a linux host.

I'm not sure what the issue is but mac os have had 3d acceleration in vmware for windows guests for quite sometime.

Anyone come across a solution for this? I'm tryin to get this working but it doesn't appear vmware gives a sh!t. They are happy to take from the open soucre community but don't give much back.

i've added the log file

0 Kudos
Highlighted
Contributor
Contributor

rashm2k wrote:

The reply by ninjacoding, includes my reply on the ubuntu forum, i was hoping to get 3d acceleration in windows guest on a linux host.


I would suggest you install Workstation 8.x then...the Guest 3D support works fine with version 8.x on a Linux host.

The issues with 3D Guest support is with Workstation 9....

Good Luck. :smileyplain:

0 Kudos
Highlighted
Contributor
Contributor

I would suggest you install Workstation 8.x then...the Guest 3D support works fine with version 8.x on a Linux host.

The issues with 3D Guest support is with Workstation 9....

Good Luck. :smileyplain:

Install Vmware Workstation 8 may be the solution, yes... but after paying over 100 € for the update, gives very bad feeling.

Anyway, by registering a new updated VMware Workstation, you lose the previos license (I understand...)

I hope (I want to believe, in other words...) there will soon be a patch that fixes the problem. There are many new laptops with nVIDIA Optimus + Linux: This is a significant percentage of the immediate future (this is not a "rare" configuration). Anyway... does anyone know if there is any way to know if the VMware team is working on a solution? It would be interesting to know.

Hopefully VMware does not delay the new patch, waiting for the hypothetical nVIDIA driver for Optimus/Linux. Where once worked Workstation 8 (i.e. Intel integrated graphics), now Workstation 9 should do it. The problem is that Workstation 8 on Linux worked best in the graphic field than Workstation 9 on Linux.

I dislike the feeling of having paid to have problems I did not have before. :smileyangry:

0 Kudos
Highlighted
Enthusiast
Enthusiast

This might not be an Nvidia issue but with the Intel open source graphics drivers. To test out  Workstation 9 I just installed Ubuntu 12.04 on my Thinkpad T420s that only has an Intel HD3000 GPU. I installed the S2TC package that acts as an open source replacement for S3TC. For previous Ubuntu releases, the workaround was to just enable reporting of S3TC support. I get the same message in the log file for a Windows 7 guest:

Disabling 3D on this host due to presence of Mesa DRI driver.  Set mks.gl.allowBlacklistedDrivers = TRUE to override.

The  Mesa DRI driver is used for Intel graphics so I guess Workstation detects this for some reason (ie. a known issue with 3D and Intel graphics on Linux hosts) and disables 3D support.

I added mks.gl.allowBlacklistedDrivers = TRUE in my .vmx file which stopped the messages about not having 3D support. I power on the VM and get a popup message saying:

The GPU driver on this host might cause issues with VMware products. If you experience problems, disable 3D  support in the affected virtual machines.

This isn't a good sign but I click OK. When I try to run the Windows Experience Index test,  workstation crashes during the "Running the Direct3D 9 Aero Assessment" part with a popup message saying:

VMware Workstation unrecoverable error: (vcpu-0) Unexpected signal: 11

The guest is then forcibly powered off when I click OK.

Since Workstation wasn't working for me on my notebook, I removed it and installed it on my desktop running an Ubuntu 12.04 host. It doesn't  have any Intel graphics but an old Nvidia GeForce GTX 260 using the Nvidia proprietary drivers. I was able to run the WEI test for the Windows 7 guest and enable Aero just fine.

Maybe Optimus users might be able to replicate this by going into their BIOS and setting it to use Intel graphics only or Nvidia graphics only. To me, it seems like Workstation 9 has something that 8 didn't have that causes issues with Intel graphics on Linux hosts.

0 Kudos
Highlighted
Contributor
Contributor

Not all Optimus laptops have the option to choose one video card over another in the BIOS.

Hence, we still need to find a solution to this since I'm sure there are "many" Dell laptop owners out there.

Bump for more info....Smiley Sad

:smileylaugh:Smiley Happy

0 Kudos
Highlighted
Enthusiast
Enthusiast

From what I've seen so far there seems to be something broken with Workstation 9 and Intel graphics on Linux hosts. So if VMware can fix what broke between Workstation 8 and 9 then the Optimus issues might be fixed as well. I'm sure there are even more users out there using Intel graphics (combined Optimus and Intel GPU users).

I don't know much about Bumblebee but are there options to completely disable the Intel graphics for specific applications? Maybe a away to make Workstation not see the Intel GPU at all?

I want to enable 3D support to get the better UI experience of Aero and Unity 3D in guests and have the UI rendered by the host GPU rather than CPU. Hopefully, this gets fixed soon.

0 Kudos
Highlighted
Contributor
Contributor

Well, I'm confused that some people writeing, that they was able to use their nvidia card with the help of optimus under VMWare Workstation 8. Under WS8, I have the issue that it reports me (at a start of the VM) that my GPU driver isn't compatible with VMWare, but the VM itself is starting.

After the startup I can see that the VM was started without Optimus, what means that it is useing the Intel HD card. How did the people managed to get it working with WS8? (I already tried the parameter in the vmx configuration (force blacklisted drivers)).

Under WS9 nothing works at all for me. The reason is, that I have a 3.5 kernel which is totally incompatible to WS9. I just get a stack trace and the system freezes. I already tried the patch for WS9 but that didn't helped. Well, the patch for WS8 and kernel 3.4 and kernel 3.5 works very nice therefor.

Greetings

0 Kudos
Highlighted
Contributor
Contributor

Ah!...ok......

Here is what I did to get Workstation 8.0.x to run 3D in Ubuntu 12.04.

First off....if you have installed the nVidia proprietary driver from the nVidia site....bad bad bad!!!...un-install it.

Now...proceed below:

1.) You don't have to blacklist anything in /etc/modprobe.d/blacklist.conf...so remove anything you blacklisted to try and get 3D to work.

2.) Install the nVidia-current drivers from the dedicated PPA

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Reboot to ensure all is working.

3.) Install bumblebee

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

Reboot to ensure all is working.

4,) Install driconf

sudo apt-get install driconf

Run the driconf gui in your applications list

When the gui open's up, go to the "Image Quality" tab

Ensure the first option "Enable S3TC texture compression even if software support is not available" is set to Yes

That's it!!

The next time you run your WIndow 7 VM, you can enable Aero or enable 3D in your Ubuntu VM running Unity or Gnome shell.

Just ensure that you enable 3D support in your VM configuration.

This enables 3D support in BOTH the Intel HD card and nVidia card.

When you run Workstation 8 from the icon....you will be running 3D on the Intel card.

If you want to run "any" application on the nVidia card...you MUST type optirun <application_name> in a terminal...where <application_name> is the exectable you want to run (i.e. optirun vmplayer, optirun vmware, optirun glxsphere, etc.....)

Unfortunately...this doesn't work with Workstation 9 for some reason....Smiley Sad

Hope this helps.....Good Luck Smiley Happy