VMware Communities
Arneo75
Contributor
Contributor
Jump to solution

Workstation 8 and bridged connection - don't work at all

When I upgraded my VMware Workstation from 7.1 to 8, I can't use bridged connection at all in any VM, I just don't have any internet connection then.

I always need to use NAT. Even when I installed Windows 8, I still can't bridge it, only NAT is working.

Before on 7.1 everything was working fine. How I can solve it?

Host - Win 7 64-bit SP1

VM- Xp Sp3, Win 7-64-bit SP1, Win 8 64-bit

Reply
0 Kudos
1 Solution

Accepted Solutions
jodur
Contributor
Contributor
Jump to solution

Exactly the same problem over here! After upgrade to Workstation 8 the bridged connections are not working for me!!

I solved the problem by choosing restore to default in virtual network editor. It removed all the VMNet adapters that were present from Version 7.x and left met with only 3 VMNetAdapters. I never understood why there were so many adapters in the editor. Anyhow this worked for me!

View solution in original post

Reply
0 Kudos
14 Replies
PShahood
Contributor
Contributor
Jump to solution

I am having very similar issues on my local network.  When I used Bridged on the guest, I can no longer access my local net.

When I switch it to NAT, I now can see my local network, but the [XP] guest no longer will VPN into work!!!   Not good to have to keep switching!!

Seem to be some issues here - or something I am unaware of!   There were no such issues with 7.1 or previous.

Any suggestions?

Thanks

Window 7 Ultimate 64 bit Host

Windows XP 32 bit Guest

openSUSE 11.4 64 bit Guest

Reply
0 Kudos
kneighbour
Contributor
Contributor
Jump to solution

Exactly the same problem here too. It is very serious for me. I would LOVE to revert to V7, and if any one knows of such a tool/process, then I would like to hear about it. There are also so many other problems I do not know where to start. How this version got out of testing beats me.

Reply
0 Kudos
adispy
Contributor
Contributor
Jump to solution

try reconfigure your network settings Edit > Virtual network editor. When I upgraded to v.8 all my briged network adapters war gone and I had to reconfigure them.

Reply
0 Kudos
PShahood
Contributor
Contributor
Jump to solution

Nothing was "gone" after the conversion to V8 - otherwise they wouldn't be working at all!!

It's just broken!

Reply
0 Kudos
continuum
Immortal
Immortal
Jump to solution

open a cmd by right-click "run as admin"

then enter
net start vmnetbridge

does that work ?
did you disable automatic bridging in virtual network editor or is that option not available ?


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
PShahood
Contributor
Contributor
Jump to solution

I am not at the machine until later today.

What exactly will this indicate?

As I said, both Bridged and NAT work, Bridged just breaks the local net.

Reply
0 Kudos
continuum
Immortal
Immortal
Jump to solution

I just try to find out what exactly is going wrong.
"does not work at all" or "just breaks the local net" is nothing I can work with 😉


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
jodur
Contributor
Contributor
Jump to solution

Exactly the same problem over here! After upgrade to Workstation 8 the bridged connections are not working for me!!

I solved the problem by choosing restore to default in virtual network editor. It removed all the VMNet adapters that were present from Version 7.x and left met with only 3 VMNetAdapters. I never understood why there were so many adapters in the editor. Anyhow this worked for me!

Reply
0 Kudos
PShahood
Contributor
Contributor
Jump to solution

Jodur,

GOOD CALL!!!

I did exactly what you described as your solution and it appears to have solved my issues.  I am back on Bridged, VPN is open and active, and I can still access my local net.

Thanks!   Smiley Wink

Reply
0 Kudos
Felix-The-Cat
Enthusiast
Enthusiast
Jump to solution

OK, here's my 2 cents -- Fortunately, I can not reproduce this in my environment!

I got WS 7.1.4 on Win2008 R2 sp1 Host (Server set as Workstation), created 2 VMs:

     - Xp Sp3,

     - Win 7-64-bit SP1

Tools installed, Network connections -Bridged: Internet, VPN - all OK

XP.jpg

Win7.jpg

I UPGRADED to WS 8.0:

     - WS UI was open

     - VMs running.

  Installer:

     - suspended VMs,

     - shuts WS UI,

     - uninstalled  WS 7.1.4,

     - Reboot

     - continue with 'Typical' installation.

     - Finished.

I opened WS UI, resume both VMs:

     NETWORK OK

Installed NEW TOOLS, reboot

     NETWORK OK

XP_8.0.jpg

Win7_8.0.jpg

*******************

Thanks for posting, we allways checking Forum and trying to help.

Reply
0 Kudos
Arneo75
Contributor
Contributor
Jump to solution

That woked, thank you!

Reply
0 Kudos
PeterWi
Contributor
Contributor
Jump to solution

I had the same problem (on two different hosts!). Bridged networks that worked fine in version 7.x would not work. I could ping 127.0.0.1 fine, but could not ping my router (transmit failure) so obviously the vm couldn't get an IP address (and thus /release /renew etc. were useless since I wasn't even getting that far!

I fixed the problem on both my hosts by going into the Virtual Network Editor and changing the "Bridged To:" drop down box to point to my network card ("Realtek PCIe FE Family Controller" on my current host) instead of saying "Automatic".  I also have the Hamachi client on this host and I suspect it was trying to bridge to that, which, not surprisingly, doesn't work.

Note: I had already tried "Restore Defaults" twice to no avail, I think that simply set it back to "Automatic" with all adapters still selected in the "Automatic Settings"

Alternatively (as a second test)  I left it set on "Automatic" and then went into ""Automatic Settings..." and unchecked all but my network card I wanted it to use and that worked fine too.

Anyhow, I hope this helps. Check your "Bridged" settings in the Virtual Network Editor ( Edit >> Virtual Network Editor). This fixed the problem for me.

Good luck!

Peter

Reply
0 Kudos
Rawad
Contributor
Contributor
Jump to solution

VMWS.png

VirtualNetwork.png

I have a simillar issue. i followed your step but for some reason it didnt work for me. I will post some images.

Reply
0 Kudos
PeterWi
Contributor
Contributor
Jump to solution

Rawad,

Can you ping 127.0.0.1? Can you ping your router? I was getting transmit failures (not just no reply) trying to ping my router before I changed the bridged settings. (I also had to reset the networking settings on one of my VM's because I had been playing with the configuration trying to get a connection and I forget to return it to normal.)

The only difference I can see in your configuration is that I didn't check "Replicate physical network connection state" (To be honest, I'm not sure what that does and I've never checked it and never had problems.)

Finally, I assume the Marvell Yukon that you selected is the correct adapter. If you have more than one you may want to try the others.

Other than that I'm out of advice. I can now fix and break my network on demand by changing The Automatic Binding setting back and forth, so I know it was what was blocking me, but I'm sure there are many other possible causes...

Reply
0 Kudos