HarrisonIS
Contributor
Contributor

Workstation 7.1 on Ubuntu 10.04 - clicking inside Guest doesn't bring Workstation window to front

With VMWare tools installed my app focus changes appropriately but the full workstation window is not brought to the front. For instance, right now I am running Google Chrome in less-than full screen in the Host. Behind Chrome I can see my Windows Server 2003 Guest running. I can click into the Guest and work in the open applications but Chrome remains in front of the Guest. The only way I can bring the Guest to the front is to click on the Workstation window header. The guests were originally used through a Windows 7 host but I've recently changed over to Ubuntu. I have removed and re-installed VMWare tools in the guest. Otherwise no changes have been made to the guests other than whatever suggestions Workstation gave when I first opened them.

Host: Ubuntu 10.04

Host Video: ATI (ATI drivers)

Guest: Windows 2003 (but happens with all guests Windows and non-Windows) - VMWare tools are installed and running.

0 Kudos
2 Replies
louyo
Virtuoso
Virtuoso

WAD (working as designed)?

I am running on Ubuntu 9.10 and, AFAIK, it has always worked that way here. I run WS on a separate monitor so I don't notice it much.

Lou

0 Kudos
HarrisonIS
Contributor
Contributor

Thanks louyo. This is my first time running Workstation on a Linux

host. Sometimes the "feature" is actually useful but I assumed

something was wrong since it doesn't work that way in Windows host.

0 Kudos