vm_dude123
Enthusiast
Enthusiast

Workstation 6.5 on Ubuntu 8.10 Host keymap problem

Jump to solution

I recently upgraded from 8.04 to 8.10 of Ubuntu. I was running Workstation 6.5 just fine on 8.04, but now on 8.10 some of the keymappings are screwed up.

For example, to get a "delete" key I need to hit my keyboard's "Print Screen" key. Everything is mapped just fine on the host....it somehow got screwed up in the guest (WInXP).

Any idea how to fix this or what happened?

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Noel
Expert
Expert

Did you not get the memo? Smiley Wink Add:

xkeymap.keycode.108 = 0x138 # Alt_R

xkeymap.keycode.106 = 0x135 # KP_Divide

xkeymap.keycode.104 = 0x11c # KP_Enter

xkeymap.keycode.111 = 0x148 # Up

xkeymap.keycode.116 = 0x150 # Down

xkeymap.keycode.113 = 0x14b # Left

xkeymap.keycode.114 = 0x14d # Right

xkeymap.keycode.105 = 0x11d # Control_R

xkeymap.keycode.118 = 0x152 # Insert

xkeymap.keycode.119 = 0x153 # Delete

xkeymap.keycode.110 = 0x147 # Home

xkeymap.keycode.115 = 0x14f # End

xkeymap.keycode.112 = 0x149 # Prior

xkeymap.keycode.117 = 0x151 # Next

xkeymap.keycode.78 = 0x46 # Scroll_Lock

xkeymap.keycode.127 = 0x100 # Pause

xkeymap.keycode.133 = 0x15b # Meta_L

xkeymap.keycode.134 = 0x15c # Meta_R

xkeymap.keycode.135 = 0x15d # Menu

to /etc/vmware/config.

View solution in original post

0 Kudos
18 Replies
darrenw
Contributor
Contributor

Same problem here. Here are the incorrect mappings I've found (windows key codes in parenthesis):

Right

Right Alt (0x12)

Up

Nothing

Down

Right Windows (0x5c)

Right

Pause (0x13)

Print Screen

Del (0x2e)

Insert

Nothing

Pause

Unknown (0xff)

Windows

Unknown (0xff)

R Alt

Enter (0xd)

R. Windos

Unknown (0xff)

Control

Pg. Dn (0x22)

Home

Pause

End

Windows (0x5b)

Delete

Nothing

Pg. Up

/ (0x6f)

Pg. Down

Menu (0x5d)

/

Ins (0x2d)

Enter

Down (0x28)

Please note that this is not the same problem as the host keys being lost - (of course it could be related)

VMWorkstation v6.5.0 build 118166 (x64)

VMPlayer v2.5.0 build 118166 (x64)

Ubuntu 8.10 desktop x64 (released today)

xorg v1.7.4

0 Kudos
Noel
Expert
Expert

Did you not get the memo? Smiley Wink Add:

xkeymap.keycode.108 = 0x138 # Alt_R

xkeymap.keycode.106 = 0x135 # KP_Divide

xkeymap.keycode.104 = 0x11c # KP_Enter

xkeymap.keycode.111 = 0x148 # Up

xkeymap.keycode.116 = 0x150 # Down

xkeymap.keycode.113 = 0x14b # Left

xkeymap.keycode.114 = 0x14d # Right

xkeymap.keycode.105 = 0x11d # Control_R

xkeymap.keycode.118 = 0x152 # Insert

xkeymap.keycode.119 = 0x153 # Delete

xkeymap.keycode.110 = 0x147 # Home

xkeymap.keycode.115 = 0x14f # End

xkeymap.keycode.112 = 0x149 # Prior

xkeymap.keycode.117 = 0x151 # Next

xkeymap.keycode.78 = 0x46 # Scroll_Lock

xkeymap.keycode.127 = 0x100 # Pause

xkeymap.keycode.133 = 0x15b # Meta_L

xkeymap.keycode.134 = 0x15c # Meta_R

xkeymap.keycode.135 = 0x15d # Menu

to /etc/vmware/config.

0 Kudos
vm_dude123
Enthusiast
Enthusiast

Noel -- thank you very much....worked like a charm.

0 Kudos
jrglines
Contributor
Contributor

Yes, worked like a charm. Smiley Happy

Thankyou!!!

0 Kudos
chemical
Contributor
Contributor

Thanks! Works perfectly.

Anyway, what did you mean by "Did you not get the memo?" Which memo?

0 Kudos
another_sam
Contributor
Contributor

tttttttthank you!

this bug is also issued in https://bugs.launchpad.net/ubuntu/intrepid/+bug/289098

0 Kudos
BrettBlackham
Contributor
Contributor

What is the xkeymap.keycode for print screen. (This fixed everything else)

0 Kudos
Fabrice77
Contributor
Contributor

Hello,

I have the same problem with the printscr and ....

xkeymap.keycode.107 = 0x54 # PrintScr

now it is ok Smiley Happy

0 Kudos
Noel
Expert
Expert

what did you mean by "Did you not get the memo?" Which memo?

It was a joke. One of the VMware engineers had posted the same information a month or so earlier. This has been a bit of an FAQ item.

Not sure why people keep opening VMware-related defects on Launchpad, though, since no one supports VMware there.

0 Kudos
joelukkelis
Contributor
Contributor

Hi.. I have Ubuntu 8.10 and vmware player 2.5.1 Bundle installed. I also have lost my @ sign first + many others. I get them back inserting those xkeymap strings into that config file. Now everything else is working but my keyboard is Finnish and my keyboard scandic buttons wont work (ä, ö). Also I found that some keys are wrong places. Is there any language related list of ALL XKEYMAP.KEYCODE values, or do I have to calculate them all with my self I really do not know what to do. Help Please..

0 Kudos
jonttu
Contributor
Contributor

I'm also finnish and I'm struggling with the same issue. Arrow keys, del, ins etc are fine now, thanks to the "ALL XKEYMAP.KEYCODE" -fix. But for example "ö ä å - _ ' ? +" -keys are not working on the guest. I'm running vmware player 2.5.0 build-118166 on Ubuntu 8.10 64bit with 2.6.27-11 kernel. A virtual beer for anyone who can solve it!

0 Kudos
Fabrice77
Contributor
Contributor

Bonjour,

Je suis absent du bureau depuis le 26 janvier 2009 et ne prendrai connaissance de votre email que dès mon retour, le 2 février 2009.

Avec mes meilleures salutations

Fabrice Bavaud

0 Kudos
jonttu
Contributor
Contributor

Hello frenchman,

Care to translate?

merci!

-Jonttu

0 Kudos
joelukkelis
Contributor
Contributor

Solution for Finland layout is to change only Finland while install new fresh OS, no Finland Classic keyboard layout. I have no found solution without installing Ubuntu again.... But now it works. This was tested both 32 & 64 b Ubuntu. With same strange behavior in VMWare Player 2.5.0 and 2.5.1

0 Kudos
CeasarSK
Contributor
Contributor

Hi

I have the same problem as the Finland layout for the Swedish keyboard layout, all arrow and ins del problems are solved by the solution above.

But not the special åäö Swedish letters, they are still not working,

anyone that have a clue to solve it ? I really don't want to reinstall for this 3 keys Smiley Wink

Ubuntu 8.10, vmware player 2.5.1 build-126130 running Windows XP SP2.

/Brgds Stefan

0 Kudos
kjohansen
Contributor
Contributor

I have the same issues with the danish keyboard layout, could this be related to extended character sets?

Br.

Kennet

0 Kudos
CeasarSK
Contributor
Contributor

Hi

I managed to get it working with Swedish letters åäö and all arrows ctrl, AltGr etc....

I added into /etc/vmware/config

xkeymap.language = se104

xkeymap.keycode.108 = 0x138 # Alt_R

xkeymap.keycode.106 = 0x135 # KP_Divide

xkeymap.keycode.104 = 0x11c # KP_Enter

xkeymap.keycode.111 = 0x148 # Up

xkeymap.keycode.116 = 0x150 # Down

xkeymap.keycode.113 = 0x14b # Left

xkeymap.keycode.114 = 0x14d # Right

xkeymap.keycode.105 = 0x11d # Control_R

xkeymap.keycode.118 = 0x152 # Insert

xkeymap.keycode.119 = 0x153 # Delete

xkeymap.keycode.110 = 0x147 # Home

xkeymap.keycode.115 = 0x14f # End

xkeymap.keycode.112 = 0x149 # Prior

xkeymap.keycode.117 = 0x151 # Next

xkeymap.keycode.78 = 0x46 # Scroll_Lock

xkeymap.keycode.127 = 0x100 # Pause

xkeymap.keycode.133 = 0x15b # Meta_L

xkeymap.keycode.134 = 0x15c # Meta_R

xkeymap.keycode.135 = 0x15d # Menu

Also I remarked this line again.

#xkeymap.nokeycodeMap = true

/Hope it works similar with Danish keys also.

/Brgds Stefan

**********************************'

Running Ubuntu 8.10 on a Lenovo W500 using Vmware player

0 Kudos
jonttu
Contributor
Contributor

Yes!! I got it!!

I think it was the "xkeymap.language = se104" because I had the other xkeymap.keycode...-lines there already.

Although in XP guest login screen I apparently had us layout but after the login everything was fine.

thanks!!

0 Kudos