VMware Communities
gregeeh
Contributor
Contributor
Jump to solution

Workstation 17 very slow on new PC

Hello Everyone,

VMware Workstation 17 | ASUS PN64-E1 with i5 13500H CPU | Windows 11 Host

Been using vmware for many years now and something is not right with my new PC. I have several small Linux variant guests that should run fine on this PC. But things are really slow with only 3% CPU, 1% Disk and 51% memory usage showing on the host.

For example, most guests boot into GRUB first with a menu that times out after 5 seconds. This 5 secs is well over 1 minute. Booting to post boot takes well over a minute too. Happens on old and newly created guests too.

Can someone tell me what might be happening?

TIA

EDIT: Seen some mention that one should disable Hyper-V but I had this enabled on my old Ryzen 7 3700X PC and would run both Sandbox and VMware at the same time, so don't understand why I should disable Hyper-V.

Also seen others say you should disable Memory Integrity in the Host.

So what is the general consensus as I'm now confused?

Reply
0 Kudos
1 Solution

Accepted Solutions
Br_Silva
Enthusiast
Enthusiast
Jump to solution

Use the commands below, it solved the problem for me!

 

Open CMD with administrator and use the command below

 

powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe"

 

powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\vmware.exe"

View solution in original post

2 Replies
gregeeh
Contributor
Contributor
Jump to solution

Hello Everyone,

Over 130 views and no one can answer this question?

TIA

 

Reply
0 Kudos
Br_Silva
Enthusiast
Enthusiast
Jump to solution

Use the commands below, it solved the problem for me!

 

Open CMD with administrator and use the command below

 

powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe"

 

powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\vmware.exe"