VMware Communities
kasper
Enthusiast
Enthusiast

Workstation 17 Windows Host Sound / Video issue

Environment: AMD 4800U / ALC233 Audio / Either Windows 10/11/Server 2022 as host OS.

Workstation 17 host.   Various Windows guests.   On 16 host guest had seamless

video / audio playback.    Upgraded to 17 host.   Now guest playback has occasional pauses / stutter.

Anybody else having same issue?    Anyone have a recommendation on how to proceed?

 

Thank you.

 

 

 

7 Replies
nceee
Contributor
Contributor

Same issue here upgraded from Workstation 16 to 17 Pro running two VM's and both randomly stutter or pause audio.

Only way to get sound back to normal is to restart host and vm's

kasper
Enthusiast
Enthusiast

Also, if you keep the guest at 16.2.x the issue is not as bad.

If you upgrade the guest to 17 the issue is very noticeable.

Reply
0 Kudos
jrsweb05
Contributor
Contributor

Thanks for your post.

Been having a lot of issues with some Linux distributions on Workstation 17. Most had video/audio issues like you mentioned you had on Windows VM's so I started setting up VM's under Workstation 17 for Hardware compatibility of Workstation 16.2.x. I have same VM's running fine on another system running Workstation 16.  This seems to have solved most of the Linux VM issues except for Linux VM's running Arch based Linux but Arch Linux is a special animal that requires lots of manual tweaking even outside of VMware.

I was suspecting issue and your confirmation of issues was enough to push me to try same on Linux side and this solved most of problems I was running into. So proceed with caution upgrading VM hardware compatibility until tested first for  Windows or Linux VM's.

Reply
0 Kudos
kasper
Enthusiast
Enthusiast

Have found that on the host changing the 'power options' to high helps alleviate this issue.

Reply
0 Kudos
TPAGeek
Contributor
Contributor

For me, disabling Power Throttling immediately resolved the issue. Run the following from an elevated command prompt:

 

powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe"

 

Reply
0 Kudos
kasper
Enthusiast
Enthusiast

Nice solution.   This helps.    Unforutnately I am finding there are multiple issues causing the problem.   The AMD mobile chipset drivers and device drivers for audio seem to have an issue interacting with VMWare Workstation and audio/video.    I find the latest Win11 22h2 V2 does not play well.    Win10 and Server 2022 insider work better.

Waiting for the dust to clear and hoping AMD interacts better with Workstation.

 

Reply
0 Kudos
Eurisko69
Contributor
Contributor

This issue is still plaguing me. No matter what I do, it's horrific chopping and popping with the sound. I tried a different sound cards, all kinds of config options. I may have to move away from VMWare Workstation that I have used for the last 10 years. 

Reply
0 Kudos