PGalbraith
Contributor
Contributor

Workstation 17.0: Cannot create a Win9x guest VM with Workstation 5 Compatibility

Workstation 17.0 does not honor the hardware compatibility setting that I specify when I create a new VM for a Win9x guest.  I want the compatibility to be "Workstation 5.x", but when I create a new custom VM and specify that, my specification is ignored and the VM is created with "Workstation 17.x" compatibility.  Worse, after the VM is created (prior to any installation), the compatibility cannot be changed.  Trying the change the compatibility to the setting I want yields the attached error, with non-working HTTP link.

Is there any way to create a VM with appropriate compatibility setting for Win9x or do I need to downgrade?

0 Kudos
2 Replies
RDPetruska
Leadership
Leadership

Interesting.  I just tried this myself, on two different computers. 

One with Workstation 16.1.2 - selected Workstation 5.x compatibility, Win98.  Created VM shows "Workstation 16.x compatibility".  VMX file shows config.version = "8", but virtualHW.version = "18".

Other with Workstation 17.0.0 - selected Workstation 5.x compatibility, Win98.  Created VM shows "Workstation 17.x compatibility".  VMX file shows config.version = "8", but virtualHW.version = "20".

You should be able to manually edit the vmx file and change virtualHW.version = "4" (that's what my one existing 5.x compatibility XP VM shows).  When I did that and re-opened the VM in Workstation, it *did* properly show "Workstation 5.x compatibility".

PGalbraith
Contributor
Contributor

Ah that's interesting, so this problem has been around awhile!  Thanks for the info.

0 Kudos