dhimes
Contributor
Contributor

Workstation 16 Pro Error "Virtualized Intel VT-x/EPT is not supported on this platform

I just upgraded to Workstation 16 Pro as it said it would work with Hyper-V, and I want to run docker desktop.

However I am getting the error:  "Error "Virtualized Intel VT-x/EPT is not supported on this platform".  Every time I search it I get the result of "disable hyper-v", but I just spent a bunch of money to be able to run this with hyper v.

The thing I am trying to run is Cisco Modeling Labs (CML): a VM that spins up VMs of routers/switches/etc.

0 Kudos
5 Replies
wila
Immortal
Immortal

Hi,

As you're mentioning Hyper-V, your host OS must be windows.

Not all versions of Windows however are supported for this to work and this might be what you are running into.
AFAIK, this only works on Windows 10 and the minimum version of Windows 10 is 20H1 build 19041.264 or newer.

The exact system requirements can be found here:
https://docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-177F1E77-BFFD-48...

edit: Wait.. oh dear. I now realize that I might to be misreading it.

The above requirements are for being able to run a guest OS in VMware Workstation while Hyper-V is enabled at the host OS.
This does NOT allow you to run a guest OS in your VM itself. The only way to run a nested VM is to disable the Hyper-V role on the host OS where you run VMware Workstation. In that scenario nested VMs work fine and you can even run Hyper-V in your guest OS.


Hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
wila
Immortal
Immortal

moderator: Moved the thread to VMware Workstation Pro discussions. Your question is indeed about nested virtualization, but the discussion area where it was posted was specific for vSphere. You're likely to get better answers here.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
ender_
Hot Shot
Hot Shot

Unfortunately, Hyper-V API does not allow for nested virtualisation – the only way to use that is to disable Hyper-V on the host and let Workstation use its own virt.

Dmoneywise
Contributor
Contributor

This host supports Intel VT-x, but Intel VT-x is disabled.

Intel VT-x might be disabled if it has been disabled in the BIOS/firmware settings or the host has not been power-cycled since changing this setting.

(1) Verify that the BIOS/firmware settings enable Intel VT-x and disable 'trusted execution.'

(2) Power-cycle the host if either of these BIOS/firmware settings have been changed.

(3) Power-cycle the host if you have not done so since installing VMware Workstation.

(4) Update the host's BIOS/firmware to the latest version.

This host does not support "Intel EPT" hardware assisted MMU virtualization.

VMware Workstation does not support the user level monitor on this host.

Module 'MonitorMode' power on failed.

Failed to start the virtual machine.

 

 

 

 

i enabled the v tech in my bios, but it still say the same thing,  before it was not enabled, it was still saying the same thing as well

 

how can i overcome and win, 

 

0 Kudos
milindng
Enthusiast
Enthusiast

This problem starts in case you update your existing windows 10 version to 20H1, 21H2 or later version.

For me it was working with old Windows 10 Version. Windows 10 was automatically updated and problems starts for me and I was unable to work with VMware Workstation Pro 16. Even I replace workstation version with 12 & 14 but same issue. The higher version of Windows 10 is coming with Hyper-V which can't allow to work VMware workstation together.

After a lots of struggle I was able to resolve this issue with below changes:-

1. Go to windows services with type services.msc in RUN 

2. Stop all Hyper-V services.

3. Go to control panel ---- program and features---Turn windows feature ON/OFF---Untick Hyper-V---Ok---to remove from Windows 10.

4. Run below PowerShell command for  VMware Nested Virtualization issues:-

    If u want use vmware : use this command in powershell and reboot system:

   To disable Hyper-V use this command:- bcdedit /set hypervisorlaunchtype off

    ( If u want use hyper-v: use this command :  bcdedit /set hypervisorlaunchtype auto)

 5.  Hyper-v and Vmware still don't work together so make below changes in windows Registry:-

      To disable Device Guard or Credential Guard :--

Disable the group policy setting that was used to enable Credential Guard.

  1. On the host operating system, click Start > Run, type gpedit.msc, and click Ok. The Local group Policy Editor opens.
  2. Go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security.
  3. Select Disabled.

Restart desktop and try to check ....

I hope this can work for all of you as this working for me now.