finsandbub
Contributor
Contributor

Workstation 16.2.0 cannot use paste.

Before upgrading to v16.2.0 build-18760230 from v16 I could use Edit -> Paste, but not Crtl+V to paste into a Centos7 guest. Since upgrading to 16.2.0 I can't even do that. I've made sure that the guest is running open-vm-tools (x86_64 0:11.0.5-3.e17_9.3). It's a feature I use daily so it needs to work. How do I get it to work?

55 Replies
joshiga
Enthusiast
Enthusiast

For Windows as a Guest, can you please make sure if you have installed VMware Tools 11.3.5 and

in VM Guest settings, Guest Isolation -> Enable copy and paste is ticked. 

Like in attached screenshot. 

 

Sadly if you are still at installation screen of Windows, and wants to copy key from host OS to Guest OS but as guest tools are not yet installed

So Copy paste ability is not there. So this is kind of new expected behaviour. I understand it's causing pain to users. 

Let me file a bug and track it internally.

0 Kudos
kylebegle
Contributor
Contributor

Thank you for your reply. I was using VMWare Tools 11.2.5. However, after upgrading my guest to 11.3.5, paste still does not work.

I should also mention that I am connecting to a vSphere server, ESXi, 6.7.0, 17700523.

My main use of the paste feature is to paste in my 30+ character randomized passwords to the Windows login screen. These are all operating VMs, we are not doing any installs at the moment.

joshiga
Enthusiast
Enthusiast

We have filed an internal bug and are tracking this issue.  Apparently the clipboard security fix which we did in 16.2.0 (and acknowledged in Release notes of 16.2.0) is too aggressive and have introduced the regression. 

finsandbub
Contributor
Contributor

That's great, thank you.

I, and I'm sure others, willl be looking forward to the update

pggp
Contributor
Contributor

16.2.1 here running on CentOS 8.5.2111 with RHEL 7.8 client; open-vm-tools in perfect condition.

This should be fixed ASAP. Main reason for VMware over VirtualBox - being able to paste long and complex passwords for the Linux log-in text console (and no, it is not always possible to ssh to the box).

srattee21
Contributor
Contributor

I am glad I found this. Uninstalled 16.2 and installed  16.1.2. Now the paste option is no longer grayed out. That was definitely super inconvenient.  

0 Kudos
kylebegle
Contributor
Contributor

Thank you and your team for looking at this. Is there anywhere we can be notified once a fix is released? Or do we just wait for the notification on Workstation that a new version is available.

0 Kudos
ajgringo619
Hot Shot
Hot Shot

Your version of the open-vm-tools is pretty old (currently on v11.3.5). I wonder if the latest version of VMware WS requires a newer version of the tools.

Have you tried using the tools that come with VMware instead? I know it's not recommended, but it couldn't hurt to try. I guess you could also try to build the latest tools yourself: https://github.com/vmware/open-vm-tools

0 Kudos
walidhammad
Contributor
Contributor

I am having this issue regardless of guest os on workstation pro 16.2.1. I have tested with open-vm-tools and upgrading to latest and on windows guest with also latest but to no joy.

 

This is only impacting console to VMs on remote hosts, esxi, and not VMs local to workstation

0 Kudos
immortalt
Contributor
Contributor

Yes. Every time I see new version above 16.2.0, I will try to upgrade.

I have tried many times in many different computers.

But I was disappointed every time.

I have to degrade to 16.1.2 again and again to restore the copy and paste function.

So, VMware, F.

0 Kudos
immortalt
Contributor
Contributor

This should be fixed ASAP.

0 Kudos
immortalt
Contributor
Contributor

This bug still exist on 16.2.1.18811642

0 Kudos
finsandbub
Contributor
Contributor

Looks like v16.2.2 has fixed the problem! I can't do Ctrl+V, but I can go through the menu Edit->Paste - which was how it was in previous versions.

0 Kudos
joshiga
Enthusiast
Enthusiast

Great. Yep problem is supposed to be solved in v16.2.2. Will go ahead and close this thread. 

Appreciate the Patience! Thanks.

 

0 Kudos
kylebegle
Contributor
Contributor

I still cannot seem to paste on 16.2.2. I updated, restarted, and it still functions the same as the prior update.. Edit > Paste is greyed out.

0 Kudos
joshiga
Enthusiast
Enthusiast

Can you please check

VM Guest settings, Guest Isolation -> Enable copy and paste

is ticked. 

Like in attached screenshot. When Enable Copy Paste is enabled, Menu Edit > Paste will not be grey out 

and Paste should be working.

0 Kudos
kylebegle
Contributor
Contributor

 I do not have that option. I am using Workstation Pro to connect to a vSphere server.

0 Kudos
joshiga
Enthusiast
Enthusiast

Understood, You are connecting to a remote VM. Yeah Guest Isolation Settings are not applicable for Remote VMs.

For Local VMs this problem should be solved with v16.2.2.

Let me check internally what can be done for this. 

Thanks!

0 Kudos
breakstuffmajor
Contributor
Contributor

Unfortunately for those of us on a Linux host, this is not solved yet, as 16.2.2 hasn't been released for Linux. 😞

VMware is running like crap on Ubuntu, too, which never used to happen with older versions.

0 Kudos
immortalt
Contributor
Contributor

"Unfortunately for those of us on a Linux host, this is not solved yet, as 16.2.2 hasn't been released for Linux.

VMware is running like crap on Ubuntu, too, which never used to happen with older versions."

I have the same feeling with you😭.

0 Kudos