wpilgri88
Contributor
Contributor

Workstation 15.5.2: SCSI Driver and Windows Update Issue

I am currently running Windows Windows Insider Build 19569 in a Workstation 15.5.2 VM (just updated today)

In the VM, Windows update says there is a new build, 19582.1001 available.  However when it goes to install I get a error warning me:

These devices aren't compatible in Windows 10.  Contact the manufacturer for more info":

     "LSI Adapter, SAS 3000 Series, 8-port with 1068 (LSI)"

At this point of course the update fails.

Q:  So, how can I fix the driver that my VM is using to be compatible with the latest system build?

This is the first time I've seen a driver error like this and searching online hasn't come up with any Workstation solutions.

Thank You

4 Replies
scott28tt
VMware Employee
VMware Employee

0 Kudos
matsuda0707
Contributor
Contributor

I had the same problem and solved by uninstalling "lsi adapter sas 3000 series 8-port with 1068" from device manager and re-installed Build 19582.

It sucessfully installed without any error, but "lsi adapter sas 3000 series 8-port with 1068" appeared again after Windows update.

(See : Can not update to Build 19582 by "lsi adapter sas 3000 series - Microsoft Community )

0 Kudos
kirm1955
Enthusiast
Enthusiast

Just want to add to this. When you uninstall the sas adapter, if it requests a restart, "Do Not Restart" as it will be installed again. Once the upgrade to 19582 is completed, the adapter will be re-installed. MS is aware of this, hopefully they correct this soon.

arjanhs
Enthusiast
Enthusiast

THat worked for me to and i was able to update again.

0 Kudos