MarkPfeifer
Contributor
Contributor

Workstation 14 - no Logitech mouse wheel in guest

I’m using VMware Workstation Pro 14 on Windows 10 x64 with Windows and Linux guests. 

I installed a Logitech Ergo MX trackball.  The scroll wheel works perfectly on the host OS, but does not work in the guest OS. This works fine with a Microsoft mouse – the scroll wheel works in both the host OS and the guest OS.

Is there a way to make this work in guest instances?  Should this be reported as a defect in Workstation?

Mark

17 Replies
mhampto
VMware Employee
VMware Employee

Please take a look at Keyboard or mouse do not work in a hosted virtual machine (1008443) and see if any of the troubleshooting resolves.

0 Kudos
Wrongay
Contributor
Contributor

I've tried these with no luck.  My work is still using Workstation Pro 12.5.  I've got the Ergo MX connected (wirelessly not Bluetooth) and works fine on the host, but not within the VM.  I've also got the old M570 connected and that scrolls just fine.  Logitech created a new UI to set the preferences for their new mouse and I'm also guessing they've changed the mouse drivers.  I've contacted Logitech and they don't have an answer and informed me to contact VMware.  This is what I'm doing now.

Any other suggestions?

Thanks

W

0 Kudos
hide1978
Contributor
Contributor

If Smooth Scroll is enabled at Logitec Option, please try to turn off it.

Wrongay
Contributor
Contributor

That was it.  Thanks.

Elvaron
Contributor
Contributor

That's right, I confirm. When you turn off "Smooth scrolling" in Logitech Options software, the scroll wheel works.

By the way, did someone manage to make additional buttons work?

0 Kudos
DodgeDeBoulet
Enthusiast
Enthusiast

By the way, did someone manage to make additional buttons work?

Nope. VMWare is aware that it's an issue, but have only received a handful of support incidents related to the problem. They claim to be working on a fix.

0 Kudos
BSchor
Contributor
Contributor

Bless you!  I spent an hour+ "chatting" with a Logitech support person who was singularly unhelpful.  I finally insisted he "escalate" this to Logitech Support, as he clearly understood nothing.  This final process took about 20 minutes (he stopped responding).  Then I decided to "look for myself", and found your solution, which worked for me!

BS

0 Kudos
LoBot
Contributor
Contributor

I have been running VMWare workstation pro since v6 with a logitech M570 with no general problems including Scroll wheel.

While running VMWare v14+ (latest v14 build), I upgraded the Trackball to the New Logitech MX Ergo with Smooth Scroll Enabled.

With Smooth Scroll Enabled, all my VMs worked fine, including the Scroll Wheel.

Today 2-18-2019, I upgraded to VMWare v15 and my New MX Ergo Scroll Wheel Stopped working.

This was not going to fly for a minute as I use the Scroll Wheel almost as much as the Left Click.

After digging around in these forums for only a couple minutes, I ran across this little bit of wisdom, (Disable Smooth Scroll).

This worked great, but leaves this question.

Why did my MX Ergo Scroll Wheel WORK immediately after installation in VMWare for a couple months until I upgraded to the latest VMWare v15???

Looks like a question for the VMWare Devs to me...

Have a great day.

0 Kudos
lajiang
Contributor
Contributor

Turning off Smooth Scroll works, save my day! Thanks!

0 Kudos
caffe1ne
Contributor
Contributor

Update for anyone who comes across this thread.

Today, I found that, in addition to the tips above, I also had to switch back to "Traditional" scroll wheel direction in Logitech Options. As soon as I did this, All my VMs scrolled perfectly.

I still prefer "Inverted" scrolling. I was able to follow the instructions at https://www.windowscentral.com/how-reverse-scrolling-direction-windows-10 to restore that behavior using the registry FlipFlopWheel.

0 Kudos
SaroshM
Contributor
Contributor

Thanks. That was the problem. I struggled for over an hour trying to figure that out. BTW, that is also true for the Logitech K400+ keyboard with touchpad.

munrobasher
Enthusiast
Enthusiast

Hmm, over a year later and still doesn't work. Turning off smooth scroll is acceptable though.

Crasucks
Contributor
Contributor

I had the exact same problem moving from the M570 that worked to the MX Ergo that didn't work using Workstation 14.x and can also confirm that turning off smooth scroll fixed the problem for me as well.  Thank you very much for your help.

swellington
Contributor
Contributor

Turning off Smooth Scrolling in Logitech Options worked! Thank you!

TheCsWiz
Contributor
Contributor

I had to do two things in the Host OS to fix this in Ubuntu 20.04 in VMware 16.1:

  1. Disable smooth scrolling.  Described thoroughly in other posts.
  2. Turn off inverted scrolling.  I like this feature, but if I enable inverted in host, the scroller DOES NOT WORK in VMware 16.1 running Ubuntu 20.04.

With these two settings turned off/disabled in the host, the scroll knob started working.

Once it was working I _was_ able to turn on inverted scrolling INSIDE OF VMware, but no luck turning it on in the host and preserving functionality in VMware.

So I get "regular" scrolling in Windoze (Host), and inverted (aka natural) scrolling in Ubuntu 20.04 inside of VMware.  A bit confusing but livable for now.

boneshark
Contributor
Contributor

worked for me as well thanks

bigred74
Contributor
Contributor

I confirm too the "Smooth Scroll option" workaround. VMware 16.1.1 on Win10 host, with Win2k, WinXp, Win7 32&64, Win10 guests