DSeaman
Enthusiast
Enthusiast

Workstation 14 constant USB connection errors for biometrics device

I just upgraded to Workstation 14, on Win10 1709. When I boot up a Windows 10 VM, in the lower right corner I get constant errors:

The connection for the USB device 'validity sensors (WBF) VSF300' was unsuccessful

I'm NOT mapping this USB device into my VM. It IS listed under removable devices in the menu bar, but nothing is selected. This error message appears every ~5 seconds and lasts for a couple of seconds. Very distracting, but appears to be harmless.

How can I get rid of this message?

Derek Seaman
0 Kudos
4 Replies
voidp
Enthusiast
Enthusiast

You may want to install the latest VMware Tools 10.2.0.  It includes important fixes for Windows 10 1709.  It may not address your particular issue but at least you'll be diagnosing things with the 'latest'.

Announcement:VMware Tools 10.2.0 is released with important fixes for Windows 10 1709

by Mikero (December 15, 2017)

VMware Tools build 10.2.0 is now available and contains important fixes for Windows 10 build 1709 Guest VMs.

This version of VMware Tools is supported by VMware Workstation 14.0 and greater

https://my.vmware.com/group/vmware/details?downloadGroup=VMTOOLS1020&productId=614

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

You can check vmx configuration file and search for the keyword "autoconnect". You might find something similar to this.

usb_xhci.autoConnect.device0 = "path:1/1/1 autoclean:1"

You might see more than one assuming the fingerprint reader is built-in to a laptop with a webcam.

You could try removing the autoConnect settings from the vmx file by putting a # in front of those lines.

If you want to be specific of the device path you can check vmware.log file when it does the autoconnect.

If the goal is to get the fingerprint reader to work inside the Windows 10 VM, you could try changing the virtual USB controller to 2.0 or 1.1 (presumably the failure to connect could be because it is set to USB 3.0 and not compatible with the reader). You might have to download and install the driver from the laptop vendor.

bonnie201110141
VMware Employee
VMware Employee

The comment given by bluefirestorm should work. Or you can just disconnect the validity sensors from guest via menu VM > Removable Devices > Validity Sensors > Disconnect (connect to host). This will automatically remove autoconnect entry in .vmx file. Please let me know if it works for you.

0 Kudos
vDerekS
Contributor
Contributor

Thanks....the VMX trick worked!

0 Kudos