townsbg
Enthusiast
Enthusiast

Workstation 12 won't run

Jump to solution

I am unable to use Workstation 12 on Linux mint cinnamon 12.9. The installer completed successfully and I have the icon but it isn't loading. No error messages. At install time I launched it from the command line and I got a few errors but then I got the workstation installation menu and that completed successfully.

I initially used instructions from here: VMware: How to install? - Linux Mint Forums

I also tried running the first command from here after the install: https://www.linuxtechi.com/install-vmware-workstation-12-on-ubuntu-16-04-linux-mint-18/

That completed successfully but it still won't run. Please advise. I'm including a screenshot of the initial errors. If you need any logs please tell me where they are and I will get them for you.

0 Kudos
1 Solution

Accepted Solutions
townsbg
Enthusiast
Enthusiast

Ultimately the issue was that the processor wasn't compatible with virtualization.

View solution in original post

0 Kudos
6 Replies
townsbg
Enthusiast
Enthusiast

Startup programs doesn't show anything from VMWare. Are there suppose to be entries from VMWare? I found some VMWare packages under the software installer. Am I suppose to install them and if so which ones?

0 Kudos
townsbg
Enthusiast
Enthusiast

I reinstalled Linux and did updates. Then I installed Workstation again and it still isn't working.

0 Kudos
townsbg
Enthusiast
Enthusiast

I tried another install of Linux Mint before attempting to install Workstation. I didn't do anything else and it still isn't running. Does anything have anything?

0 Kudos
townsbg
Enthusiast
Enthusiast

Clearly my installs aren't putting a needed requirement. Does anyone know what that is? I don't know linux very well so I need help. Would ubuntu or another distribution work better? I tried posting on the linux mint forum and one of the other users was able to get the player to work. Is the workstation version too old? I don't have a serial number for a later version.

0 Kudos
townsbg
Enthusiast
Enthusiast

I tried the steps in the last post on this thread: My vmware workstation 12 pro won't start

The restart command threw some errors:

root@***:/usr/lib/vmware/lib# /etc/init.d/vmware restart

Stopping VMware services:

  VMware Authentication Daemon done

  VM communication interface socket family done

  Virtual machine communication interface done

  Virtual machine monitor done

  Blocking file system done

Starting VMware services:

  Virtual machine monitor failed

  Virtual machine communication interface done

  VM communication interface socket family done

  Blocking file system failed

  Virtual ethernet failed

  VMware Authentication Daemon done

Now running vmware from command line doesn't throw any error message but Workstation isn't loading from the icon. I'm not getting any error messages. Please help.

0 Kudos
townsbg
Enthusiast
Enthusiast

Ultimately the issue was that the processor wasn't compatible with virtualization.

0 Kudos