Quentin_Wertz
Contributor
Contributor

Workstation 11 Linux Host, 3D acceleration and Windows 7 guest

Hi!

I'm using Ubuntu 12.04 with Kernel 3.13.0-40-generic 64-bit and a AMD Radeon HD 7450 and default xorg-radeon driver.

While using Workstation 10 with Windows 7 guest anything inclusive 3D acceleration works fine.

After upgrading to Workstation 11 the 3D acceleration stopped working - WS11 says the host system has no 3D functionality, whis is not true.. There was no other change made by me.

A downgrade to WS10 and it works again like a charme.

So how can I get 3D acceleration back working in Workstation 11?

TIA and HAND.

3 Replies
chickgreen
Enthusiast
Enthusiast

I'm running Ubuntu 14.10, and did have some issues with 11 and the xorg drivers.

Chick the file ~/.vmware/preferences - is the line   "mks.gl.allowBlacklistedDrivers = TRUE" present, or set to FALSE?

When I use the stock drivers, my system freezes completely - required a power-button reset.  I switched to the oibaf drivers from launchpad, and the system does work in 3D although it does not seem as smooth as workstation 10

0 Kudos
Quentin_Wertz
Contributor
Contributor

Mh, mks.gl.allowBlacklistedDrivers isn't at all in my preferences files.

I give it a try.

But even if it is, I don't change it when I upgrade to WS11.

Thanks.

skitheo
Enthusiast
Enthusiast

Host:

$ lsb_release -a

No LSB modules are available.

Distributor ID:    LinuxMint

Description:    Linux Mint 17.1 Rebecca

Release:    17.1

Codename:    rebecca

$ uname -a

Linux ewqlovwsrndtb03 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Guest: Windows 7 32 or 64, vmware tools for Windows v 9.9.2 build-2496486

VMware Workstation 11.1.0 build 2496824

Selecting VM Settings > Display > 3D Graphics > Accelerate 3D graphics brings the guest to a crawl and saturates at least one CPU core.

VMware: YOU BROKE SOMETHING!