VMware Communities
Bryce_Stenberg
Enthusiast
Enthusiast
Jump to solution

Workstation 10: ip address conflict problem?

Hi,

For testing purposes, I simulate our production network within workstation as a 'host-only' network. (10.6.6.0/24)

I have several copies of our servers running here as virtual machines.

The host-only network has DHCP turned off, machines get their ip addresses from one of the virtual servers.

PROBLEM: I need to assign address 10.6.6.1  to a server that I have copied, it must be on this address.

When this server boots it errors with an ip address conflict when trying to use that address.

No other vm is using this address. It is not leaking from the real network as still there when I disconnect my pc from physical network.

Even turning off all vm's but one (that has completely different address) and ping 10.6.6.1 it is still found on this host-only network.

So, that maybe only leaves the vmware dhcp server taking up that address, even though I turned dhcp off for this network?

Or another vmware component?

Does anyone know how I might be able to free this address for use?

**Edit:

I turned on vmware dhcp for this network and looked in 'vmnetdhcp.conf' file - the MAC address of this dhcp server (host VMnet2) does match the address that is replying to pings for this address.

I tried modifying the address of this dhcp server in the file under the 'fixed-address' option, but that seems to be ignored, even after a reboot. When I start up a vm that MAC address is still replying to pings for 10.6.6.1.

So turning off DHCP does not remove the address, nor does altering the configuration file.

Any further ideas please anyone?

Thanks,

Bryce Stenberg

1 Solution

Accepted Solutions
Bryce_Stenberg
Enthusiast
Enthusiast
Jump to solution

D'oh!    to answer my own question...

Was in front of me the whole time,  untick 'connect a host virtual adapter to this network' in the virtual network editor. It no longer displays as host-only, just as 'custom', but is is still a host-only network.

So this works for me.  If I really needed to move the ip of the 'host virtual adapter' it looks like that is not possible.

Regards,

Bryce Stenberg.

View solution in original post

2 Replies
Bryce_Stenberg
Enthusiast
Enthusiast
Jump to solution

D'oh!    to answer my own question...

Was in front of me the whole time,  untick 'connect a host virtual adapter to this network' in the virtual network editor. It no longer displays as host-only, just as 'custom', but is is still a host-only network.

So this works for me.  If I really needed to move the ip of the 'host virtual adapter' it looks like that is not possible.

Regards,

Bryce Stenberg.

Dweezle
Contributor
Contributor
Jump to solution

Your post helped me. I have a password recovery application that for some reason kept trying to use the VM IP address

I deactivated the 2 connections and now it works. This is the first time I ever received an applicable answer from a users blog.

I usually avoid at all costs.  Thanks

Reply
0 Kudos