phantommullet
Contributor
Contributor

Workstation 10.0.3 will not install in Centos 7

I installed VMware workstation in Centos 7.  When I try to finish the install by opening Workstation I get an input for my password and then I get an error "

Unable to start services.

See log file /tmp/vmware-root/vmware-modconfig-22950.log for details."

I checked the log and it says "Failed to build vmnet.  Failed to execute the build command."

I disabled selinux and still no success.

9 Replies
Jasiver
Contributor
Contributor

Hello Phantommullet,

Create a patch file named new_vmnet.patch in your home directory with the following content:


# vi new_vmnet.patch


205a206

> #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)

206a208,210

> #else

> VNetFilterHookFn(const struct nf_hook_ops *ops,        // IN:

> #endif

255c259,263

<    transmit = (hooknum == VMW_NF_INET_POST_ROUTING);

---

>    #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)

>       transmit = (hooknum == VMW_NF_INET_POST_ROUTING);

>    #else

>       transmit = (ops->hooknum == VMW_NF_INET_POST_ROUTING);

>    #endif



Save the file and exit the editor.


Next, browse to the Modules folder:

# cd /usr/lib/vmware/modules/source


Untar the vmnet source module

# tar -xvf vmnet.tar
# cd vmnet-only


Run a patch to the file that we created in the earlier steps:

# patch vmnet-only/filter.c < ~/new_vmnet.patch


If you receive no errors during the patching process, then you can move on to the finishing steps:


Re-tar the modules

# tar -uvf vmnet.tar vmnet-only



Clean up the vmnet-only directory. We wont be needing this anymore. Just make sure you delete the

directory only; not the tar that we just created from the earlier step.

# rm -f vmnet-only


You can now give VMware Workstation a go and hopefully, it will start up just fine...


Hope it helps.


Regards,


Jasiver

0 Kudos
phantommullet
Contributor
Contributor

This did not work.  It is running kernel version 3.10.0-123.4.2.el7.x86_64 not anything in the 3.13 kernel family.

0 Kudos
SUShadow
Contributor
Contributor

'm using RHEL 7 and have the same problem. For version 10.0.3 i make next steps:

  1. cd /usr/lib/vmware/modules/source
  2. tar -xvf vmnet.tar
  3. cd vmnet-only
  4. vi filter.c
  5. on line 205 and  235 replace sting

#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)

on

#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 0, 0)

6. cd ..

7. tar -uvf vmnet.tar vmnet-only

8. rm -fr vmnet-only

After this steps i have all working.

JiriN
Contributor
Contributor

Thank you - exactly same is working for Workstation version 10.0.2

0 Kudos
gopinathan
Contributor
Contributor

Hi Jasiver, I tried this method, but still can't start VMware Workstation 10.

VMware Kernel Module Updater Error " Before you can run VMware, several modules must be compiled and loaded into the running kernel".

If I click OK, I get error unable to start services.

0 Kudos
sauronlenoir
Contributor
Contributor

Great job it work without any issue.

if have gedit the file ,  do a replace all  as indicated because the seconde line number was not the same for me.

After doing your manipulation all is working thx a lot man

0 Kudos
JiriN
Contributor
Contributor

Try the much simpler and straighforward description from SUShadow. Find the two lines with KERNEL_VERSION, or simply replace all (3, 13, 0) with (3, 0, 0).

0 Kudos
ktan123
Contributor
Contributor

Addon -- For EFI boot enabled main board, its secue mode should be disabled by setting the BIOS. Otherwise kernel module vmnet.ko & vmmon.ko can not be loaded compiled from command "vmware-modconfig --console --install-all". For my Sabertooth x79 board, the default EFI secure mode is something like "WIndows xxx", It will work after it is changed into "Other OS".

0 Kudos
rajupansare
Contributor
Contributor

This is resolved after installing kernel-devel.

and this is working fine for me now.

0 Kudos