Highlighted
Enthusiast
Enthusiast

Workstation 10.0.3 and Centos 7 Guest Tools

Hi;

   I've been trying to set up a Centos 7 Linux Guest running under a Windows 7 64-Bit Host. I'm having issues trying to install the VMware tools in the guest.

A) I had to uninstall the packages for 'open-vm-tools'. Maybe that's par for the course.

B) I can't install the file shared folder component. I get the compile errors seen below. This is

     with the current kernel 3.10.0-123.4.2.el7.x86_64.

and

C) I get a warning that says:

         "The vmxnet driver is no longer supported on kernels 3.3 and greater. Please

           upgrade to a newer virtual NIC. (e.g., vmxnet3 or e1000e)"

     Looking at the .vmx file it appears that 'e1000' is currently present. I haven't figured out

     how  to 'upgrade' this. I didn't see any obvious options in the GUI, but maybe I just

     missed it.

  Any help would be appreciated.

  The compile error for item B) above is:

"In file included from /tmp/modconfig-ituPdX/vmhgfs-only/inode.c:36:0:

/tmp/modconfig-ituPdX/vmhgfs-only/inode.c: In function ‘HgfsPermission’:

/tmp/modconfig-ituPdX/vmhgfs-only/./shared/compat_dcache.h:57:38: error: ‘struct dentry’ has no member named ‘d_count’

#define compat_d_count(dentry) dentry->d_count

                                      ^

/tmp/modconfig-ituPdX/vmhgfs-only/inode.c:1904:23: note: in expansion of macro ‘compat_d_count’

          int dcount = compat_d_count(dentry);

                       ^

  CC [M]  /tmp/modconfig-ituPdX/vmhgfs-only/cpNameLite.o

make[2]: *** [/tmp/modconfig-ituPdX/vmhgfs-only/inode.o] Error 1

make[2]: *** Waiting for unfinished jobs....

make[1]: *** [_module_/tmp/modconfig-ituPdX/vmhgfs-only] Error 2

make[1]: Leaving directory `/usr/src/kernels/3.10.0-123.4.2.el7.x86_64'

make: *** [vmhgfs.ko] Error 2

make: Leaving directory `/tmp/modconfig-ituPdX/vmhgfs-only'  "

  Thanks;

0 Kudos
6 Replies
Highlighted
Contributor
Contributor

Same thing on VMware Fusion 2014 Preview July

0 Kudos
Highlighted
Enthusiast
Enthusiast

I managed to work-around my "Issue B)" by manually extracting, patching, and rebuilding the vmhgfs.tar archive in the  vmware-tools-distrib/lib/modules/source directory using the change seen in post 22 and 25 in VMware Tools Compile Problem.

"

vmhgfs-only/shared/compat_dcache.h, line 54:

- #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)

+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 10, 0) "

This is apparently a kludge since it doesn't deal with all real kernel levels properly, but seems to work once you've advanced the kernel level to the current one where it's needed.

0 Kudos
Highlighted
Contributor
Contributor

The solution above worked for me:

cd <...>/vmware-tools-distrib/lib/modules/source

tar xf vmhgfs.tar

cd vmhgfs-only/shared

apply change to compat_dcache.h (line 54 change version from 3, 11 to 3, 10)

then tar up the new directory into vmhgfs.tar, and run the install.

Highlighted
Enthusiast
Enthusiast

Hi,

Just installed CentOS 7 x64 on Workstation Preview. I had choosen no EFI, Red Hat 7 as OS instead of Centos, Infraestructure Server as software selection.

So far, NO problems with VMware tools at instalation time for v9.8.2.36217 with the shipped kernel (3.10.0-123.el7.x86_64) using the "--default" flag

- The vmxnet warning could be discarded. It was intented for OLD configurations (perhaps with vHW v4, as far as Workstation 6 or vSphere 4, I don't remeber the exact version) when the AMD nic was available by default for the OS of that time

- Warning about no fuse installed on the OS for the vmblock driver

After reboot, the vmware-tools starts, the thinprint starts but fail.

No source modification at all...

Regards,

Luis.

Luis Soto Campos ---------- La vida siempre da una segunda oportunidad. Solo hay que saberla esperar.
Highlighted
Enthusiast
Enthusiast

> with the shipped kernel (3.10.0-123.el7.x86_64)

...

> No source modification at all...

Before I tried installing the tools I applied the current Software updates, which updated the kernel level.

It sounds like the compile issue arose because of the kernel update (and that I specified to use the shared folders).

Thanks.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi,

It could be, but the trick I think that it could be:

- Put the OS as Red Hat 7, and not CentOS

- Install the drivers with the default options. This way, the VMware Tools distribution don't overwrite own OS distribution drivers, just add new ones. Modern Linux OS already got the drivers built in due the kernel.

- No compiling neccesary, so no error and no patching the sources

- when you update the kernel, the new drivers get into since they are on the kernel distribution. The VMware added ones are not on the kernel tree.

There could be problems with the different versions of the drivers (between the tools provided and the OS provided) but usually it works fine.

Remember to reconfigure the VMware tools each time that you update the kernel always with the "--default" switch

Regards,

Luis.

Luis Soto Campos ---------- La vida siempre da una segunda oportunidad. Solo hay que saberla esperar.
0 Kudos