VMware Communities
WhiteKnight
Hot Shot
Hot Shot

Windows guests run slow in VMware Workstation 16.2.4 build-20089737

I can't help it, but I'm pretty sure my Windows 10 guests are all running extremely slow.

Sure, I have no means to measure it, yet I have a strong feeling that they are all running quite slow and clumsy compared to their performance 1 – 2 years ago.

Currently, I'm running VMware Workstation 16.2.4 build-20089737 on three different machines (all running Windows 10 Enterprise as host OS). Two of these machines I'm running for a number of years, so their performance shouldn't have changed. The third one is a new, top-notch HP notebook.

Is anyone here sharing the same observation?

Does anyone have a clue or remedy for this?



[VMware]: Workstation 17 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
Labels (1)
Tags (1)
Reply
0 Kudos
7 Replies
louyo
Virtuoso
Virtuoso

FWIIW:

I think you are probably correct.

I have 2 Windows 10 virtual systems that are several years old. As time went on, I saw more incidents of the VM "pausing" for a few seconds. Presumably for housekeeping? When I updated my host a while back, I put the VM's on an NVME drive (1tb) and that took care of that. I think the move from 32G to 64G RAM made a difference although I had not seen swapping.

The systems perform well although I have not run benchmarks. I think the VM overhead has increased as the OSes put more and more protection crap in the game, especially Windows. Unavoidable in today's malware environment. It takes some effort to setup AV's to avoid slowdowns.

Apples to oranges. I don't have a Windows host.

That said, here is a comparison of disk read times from a Linux VM running on my Linux host. Same NVME drive:

Guest (sda is on /dev/nvme1n1):

sudo hdparm -t /dev/sda
/dev/sda:
Timing buffered disk reads: 982 MB in 3.00 seconds = 326.90 MB/sec

Host:

sudo hdparm -t /dev/nvme1n1
/dev/nvme1n1:
Timing buffered disk reads: 7522 MB in 3.00 seconds = 2507.08 MB/sec

7:1 seems rather large. I have made no attempt to understand.

We run production stuff on ESXi, I use WS for programming and test. I think I still have WS 4.0 on the shelf around here somewhere. 🙂

Reply
0 Kudos
louyo
Virtuoso
Virtuoso

I should have added that I always turn 3D acceleration off. 

Lou

Reply
0 Kudos
WhiteKnight
Hot Shot
Hot Shot

I recently upgraded my main machine to have 128 GB of RAM in order to improve my guests' performance by granting them more memory. Yet, on the contrary, they seem to run more slowly after the upgrade.

When I launch programs in a VM, I'm often launching them twice under the impression that the program didn't actually launch in the VM. Some applications in the VM take 10 seconds or more to launch (e.g. Microsoft SSMS).

Same for VMware Workstation itself. It's taking up to 10 seconds before the Workstation application window appears. I very often find myself launching it twice because nothing happens for seconds after launching the program.

I configured VMware Workstation to not use swapped memory. This is the only manual config setting I apply:

mainMem.useNamedFile = "FALSE"
devices.hotplug = "FALSE"



[VMware]: Workstation 17 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
Reply
0 Kudos
louyo
Virtuoso
Virtuoso

OK, I don't see anything like that. When I first fire up the W10 VM, things are a little slow as Windows phones home and moogies around with stuff but that goes away in a minute or 3. Easy to see that if I immediately open a command prompt and type in it.

Hard to believe the  Linux versus Windows host would make any difference, but I have no way to compare.

Since I put the host and critical VM's on NVME drives (2), I am very pleased with performance. 

Are you sure your AV isn't slowing you down?

Reply
0 Kudos
wila
Immortal
Immortal

Hi,

As you're on a Windows 10 host, check your vmware.log file.

Look for a line:
"Monitor Mode"

Then check its value.

Most of the time when people complain about things like performance or not nested guest features.. that line says: ULM

(User Level Mode)

which means that your host OS is running as a VM already and all VM's are running using Microsoft Windows hypervisor API.

Only when it returns CPL0 you're using the good old VMware hypervisor.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
WhiteKnight
Hot Shot
Hot Shot

Thank y'all for replying.

@wila: The logs read: "Monitor Mode: CPL0"

Some of my VMs run Hyper-V themselves, of course, as I'm using Docker for Windows and WSL for development in these VMs. But I've configured all my VMs to use all virtualization options there are:

Virtual Machine Settings.png

 

Strange, though, that the most simple VMs I set up (de-de_windows_10_enterprise_ltsc_2021_x64_dvd_71796d33.iso, nothing else installed, just using Microsoft Edge) are slow and cumbersome.



[VMware]: Workstation 17 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
Reply
0 Kudos
JQiTCorp
Contributor
Contributor

I have finally found the resolution, it is VM memory related.
Any of the below settings will bring VM back to performance:
  • Run VMware Workstation as Admin
  • Preferences->Fit all virtual machine memory into reserved host RAM
  • JQiTCorp_0-1685582374176.png
  • VM Settings->Processors->Virtualize IOMMU
  •  
  • JQiTCorp_1-1685582393731.png

     

Reply
0 Kudos