goldens
Contributor
Contributor

Windows 8.1 October rollup KB2995388 and issue with Workstation 10

Just installed this update today, noticed after that I could no longer start any VMs with the error of "Not enough physical memory is available", even though 60gb were free and 47gb was allocated available to VMs.  Rebooted, same issue...uninstalled the patch and everything working fine again.

Anybody else running a 8.1 host install this yet?

75 Replies
dariusd
Leadership
Leadership

If you are still unable to power on VMs with the "Not enough physical memory..." error message, try following the directions here to uninstall the update which has triggered this problem:

Workstation 10 issue with recent Microsoft Windows 8.1 Update | VMware Workstation Zealot - VMware B...

Let us know if that gets you going again...

--

Darius

0 Kudos
JimboC6000
Contributor
Contributor

Glad I found this thread, I was wondering why this issue was occurring all of a sudden. Thanks for posting the workaround.

0 Kudos
Rainer42
Contributor
Contributor

I cant found a file that names config.ini in the vmware PLAYER Folder.

what should the Players users do?

Thank you

Rainer Borchmann

Rainer@Borchmann.de

0 Kudos
pbraren
Hot Shot
Hot Shot

2014-10-20_21-06-22.png

Thank you Steve78!

Your method of adding the line

vmmon.disableHostParameters = "TRUE"

to the config.ini file worked like a champ, even in the VMware Workstation Technology Preview July 2014, described here:

http://www.tinkertry.com/microsoft-kb2919355-may-prevent-your-vmware-workstation-or-player-vms-from-...

TinkerTry.com
pbraren
Hot Shot
Hot Shot

Making the edit to Workstation's config.ini file seems to fix Player as well.

TinkerTry.com
0 Kudos
wonderfulme
Contributor
Contributor

Didn't work on Windows 8.1 x64 w/KB2995388 and 24GB RAM. VMware Player 6.0.3 build-1895310.

Even tried editing C:\Users\%USERNAME%\AppData\Roaming\VMware\preferences.ini

While the KB2995388 doesn't seem to fix any outstanding issues, I'm still hesitant to remove it. I'd much rather VMware folks fix this with an update. I don't get to complain being a non-paying customer, but this here is clearly a major issue warranting a bugfix release.

Thanks.

0 Kudos
dariusd
Leadership
Leadership

We're working on an update.

In the meantime, instead of editing preferences.ini, use Notepad to create a new file named config.ini and put the option in there.

Cheers,

--

Darius

wonderfulme
Contributor
Contributor

Glad to hear!

Did just that to no avail:

C:\Users\hyd\AppData\Roaming\VMware>dir /b

config.ini

preferences.ini

C:\Users\hyd\AppData\Roaming\VMware>cat config.ini

vmmon.disableHostParameters = "TRUE"

0 Kudos
fubvmware
VMware Employee
VMware Employee

You need to put the config.ini file with the option to this path:

C:\ProgramData\VMware\VMware Workstation\config.ini


For Player, it should be,


C:\ProgramData\VMware\VMware Player\config.ini

0 Kudos
dariusd
Leadership
Leadership

Ah, if you had earlier tried launching Player as non-Administrator without the vmmon.disableHostParameters option in place (in config.ini), our driver might be confused.  You might need to reboot your host.  Smiley Sad

--

Darius

wonderfulme
Contributor
Contributor

I did indeed try that earlier, rebooted the host machine a multitude of times, but now with that config.ini entry in my AppData it finally works! Albeit, the VM didn't save its state and is performing a cold start which is okay in my scenario. Thanks a lot, Darius!


fubvmware, I did (and still) have that entry in the ProgramData's config.ini:

C:\ProgramData\VMware\VMware Player>grep vmmon config.ini

vmmon.disableHostParameters = "TRUE"


Unfortunately, that didn't solve anything in this particular case. Reboot or no reboot.

It's not until I created a config.ini my AppData and rebooted as per Darius' suggestion that it actually worked out.

Thanks a lot you guys.

0 Kudos
Phill_Graz
Contributor
Contributor

I also have the same issue after installing the October updates.

14GB Ram available on average.

0 Kudos
Phill_Graz
Contributor
Contributor

It worked for me:

vmmon.disableHostParameters = "TRUE"

Windows 8.1 Pro 16GB Ram

Thank U Steve78

0 Kudos
dariusd
Leadership
Leadership

This issue, affecting VMware Workstation running on Windows 8.1 and Windows Server 2012 hosts, should be resolved in VMware Workstation 10.0.4, released today.

It should no longer be necessary to use the vmmon.disableHostParameters option in order to make use of your host's RAM with the KB2995388 update installed.  Although vmmon.disableHostParameters was temporarily needed to keep things working, I recommend removing that option from your configuration (or setting it to FALSE), since it will cause a moderate (but not catastrophic) reduction in the amount of RAM usable by Workstation compared to when Workstation is working correctly without the option.

Thanks for your patience!

--

Darius

0 Kudos
fubvmware
VMware Employee
VMware Employee

VMware Workstation 10.0.4 has been released with the fix that Dariusd mentioned, you can download it from the link below now.

Download VMware Workstation 10.0

Thanks everyone for your patience!

- Bo

0 Kudos
pbraren
Hot Shot
Hot Shot

As for the July 2014 Tech Preview folks like me, no updates (nor would I expect one), so we just stick with the workaround, until upgrading to Workstation 11 GA version in December.

2014-10-30_22-54-27.png

Thank you for your attention to this matter!

TinkerTry.com
0 Kudos
mmacneill123
Contributor
Contributor

Hi guys, what about the rest of us not running Workstation 10!! Smiley Happy  Surely running 9 warrants a patch!!

0 Kudos
dominicraf
Contributor
Contributor

I can confirm that this fix i.e. creating %APPDATA%\Vmware\config.ini including this line, works for Vmware Player 4. Thank you!

vmmon.disableHostParameters = "TRUE"

0 Kudos
nantaboot
Contributor
Contributor

Hi,i'm using VMWare 6.04 ,and i've the same issue.My problem is that i can't edit the config.ini located at C:\ProgramData\VMware\VMware Player (i'm just using vmware player) ,it says that the is already open by another program;i've shut down every vmware services (VMware vCenter Converter Standalone Worker , VMware vCenter Converter Standalone Server  vmware-converter-agent ,VMware NAT Service ,VMUSBArbService ,VMnetDHCP ).so can anybody help me ?

0 Kudos
dominicraf
Contributor
Contributor

@nantaboot: you don't need to change that file, instead create a file at %APPDATA%\Vmware\config.ini with this one line:

vmmon.disableHostParameters = "TRUE"

0 Kudos