BobbyWong
Contributor
Contributor

Windows 7 on VMWare - screen resolution issue on a ThinkPad with Windows 10

Hello, Hoping someone can point me in the right direction.

I have a ThinkPad with Windows 10 and VMWare 12 Pro running Windows 7. The resolution on the ThinkPad is set to 3840x2160. Everything looks just fine on the host machine. However, when I run my VM with the "Display" setting "Automatically adjust user interface size in the virtual machine" enabled, the display appears to have the same settings but everything looks exceptionally smaller. Can anyone shed some light on what may be causing this? I've adjusted various settings to no avail. If I attempt to set the resolution in the VM, it just reverts back even if I do not have the "Automatically adjust..." setting checked.

Thanks for any help!

0 Kudos
4 Replies
admin
Immortal
Immortal

Could you try to deselect the "Automatically adjust user interface size in the virtual machine" option of VM settings? Just like below:

$17463BA3DB46BC85.jpg

0 Kudos
BobbyWong
Contributor
Contributor

Thanks for the reply. I attempted that as well, but it did not help resolve the issue.

Here are the settings:

Settings.JPG

This is the screen resolution settings in the VM. The 2nd monitor is not enabled because I am on the workstation only, not docked to the dual monitors.

test1.JPG

This is after I change the resolution to 2560x1600. However, after clicking "Keep Changes" and returning to Full Screen Mode in the VM, the resolution switches back.

Test 4.JPG

Could this be a Windows 10 (host machine) vs Windows 7 (VM) issue? Not sure what else to try. Also, the screen shots make it seem like the font size is normal, but it is tiny. This also isn't about increasing the Font as Larger just looks odd. I have "Smaller - 100% (default)"  set.

Any additional suggestions welcome. Thanks!

0 Kudos
TracyHuang
Enthusiast
Enthusiast

You can change the DPI on the guest to make the fonts, icons larger, to do this, you can right click desktop-> Change resolution window opened -> click "Make text and other items larger or smaller" and choose the % as you want.

0 Kudos
BobbyWong
Contributor
Contributor

Found a resolution. In the host machine with Windows 10, changed the resolution to 2048x1152 and the Scale and Layout to 100%. It was originally set to 3840x2160 (recommended) and 250% (recommended). It seems the VM with Windows 7 was not able to handle the higher resolution settings and was not scaling the same way as the host machine. Everything appears the same in the host and VM now. Thanks!

0 Kudos