WhatDoesThisDo
Contributor
Contributor

Windows 11 VM: NAT network interface flaps between "no internet" and "online"

Report of problem and work-around follows:

 

I upgraded my host OS from Ubuntu 20.04 LTS to Ubuntu 22.04 LTS (latest of all packages as of Aug 21, 2022), and then upgraded VMWare Workstation Pro from 15.x latest to 16.x latest (as of writing: 16.2.4 build-20089737)

I have 2 different Windows 11 VM (x86_64) : both upgraded to the same level of updates for Windows 11.

All Windows VM "VMWare Tools" upgraded to the same.

All Windows VM upgraded to support the latest features of the latest VMWare Workstation Pro 16.x.

 

Symptoms follow:

Host-only interface works fine.

Bridged interfaces (to all 3 physical interfaces) work fine when enabled one at a time, disabling the others.

NAT interface (Edit Windows VM: choose the virtual NIC for this VM which is only for NAT, select the checkbox for "Connect at Power On", choose Radio Button for "NAT: Used to share the host's IP address", all bridges virtual NIC disabled (unchecked "Connect at Power On", and finally the "Host-Only" virtual NIC is set to have "Connect at Power On" checked.

Net result: Only 2 NIC powered on and connected on boot of Windows 11 VM: The NAT interface and the "Host Only" interface.

When windows 11 VM is booted, I observed erratic network service. Web pages would take a while to load, an IPSEC VPN would fail to connect, acting like no network, ping would sometimes fail (2/5 worked), and DNS lookups worked maybe 60% of the time.

Eventually, I found I could visit the Windows 11 VM: Control Panel\Network and Internet\Network Connections

I could leave that window open, and the Windows Network interface associated with the virtual NAT interface of VMWare Workstation Pro would "flap":

(1) "No Internet"

(2) "Connected"

(3) go back to (1)

Oscillating between these states.

This is what was causing terrible network service and network reliability problems: flapping NAT network interface

 

If I shutdown the Windows VM, disabled the NAT interface, then enabled any one of the bridged interfaces: No flapping. Network is reliable: no more flapping.

 

More?

I have another Windows VM, also running windows 11, but no flapping of the NAT interface.

The ONLY difference? In the work Windows 11 VM, I had the virtual NIC assignments NOT use the radio buttons for "Bridged" or "NAT" or "Host Only" : Instead for the working Windows 11 VM settings, I specified each of these by their "/dev/vmnet[0-9]* value under the "Custom" radio button.

Using the "Virtual Network Editor" I could identify which named device-based interface was set for which purpose, and then used the "Custom" radio button, and then chose a drop-down for the device-name interface to match the purpose for each: "bridged" or "NAT" or "Host-Only"

THAT worked.

I applied the same logic to the Windows 11 VM with the flapping NAT based network interface? No more flapping.

 

I hope the details describing this problem, and a work-around (don't use the "NAT" radio button, use the "Custom" radio button and then choose the drop-down device named interface for NAT NIC on your install then save and start your VM) help you work-around this issue if you ware seeing it and maybe this can help the VMWare devs to be able to replicate this issue in the SVT processing.

 

Good luck!

 

Labels (5)
0 Kudos
0 Replies