TiranDagan
Contributor
Contributor

White text on white bg in Chrome under Workstation 15 Pro

Looks like the hardware acceleration driver within VMware is faulty. If you have been seeing white text (or very light color) on white background dialogues in Chrome such as this:

white on white dialog.png

The latest update to the screen driver in Vmware seems to be bugger. By disabling hardware acceleration you will get your black on white text back:

In chrome enter the following URL:

chrome://settings/system

Then turn off the "Use hardware acceleration when available" - which you can see in the same screenshot above.

Tags (1)
24 Replies
sjesse
Leadership
Leadership

Is this the latest version of chrome, if not there was a problem with an earlier version of chrome that did something similar for people using Horizon View virtual desktops.

0 Kudos
level420
Enthusiast
Enthusiast

It started with chrome 73 afaik.

Having the same problem with Workstation Pro 15.0.4 build-12990004 and vmware tools 10.3.2 build-9923505 running windows 10 guest and chrome 74.0.3729.131.

See also Re: Problem with Google Chrome popup windows

0 Kudos
hahakiki2010
VMware Employee
VMware Employee

May I know your guest OS version? I tried to repro this issue with win101809 and win101903 with the same chrome version 74.0.3729.131, however it can't be reproduced in my local env.

BTW have you tried the chrome on the host OS ? If same issue exists, it may not be caused by the guest.

0 Kudos
TiranDagan
Contributor
Contributor

I solved this by turning off graphics acceleration. 

0 Kudos
hahakiki2010
VMware Employee
VMware Employee

Do you mean to disable the graphics acceleration in chrome setting ? But it works in my test env with this option enabled.

I guess it may have some difference between your test env and mine. Do you mind to share the gpu info and vmware.log for further analysis?

0 Kudos
level420
Enthusiast
Enthusiast

hahakiki2010

It occurs in the following setup using chrome version 74.0.3729.157 (64-Bit):

host OS:

     Windows 7 Ultimate x64 SP1 latest patches 05.2019

     nvidia graphics Gforce GTX 670 nvidia driver version 425.31

     vmware workstation 15.1.0 build-13591040

guest OSes:

     Windows 10 Pro 1809, build 17763.503 - vmware tools 10.3.10, build 12406962

     Windows 10 Enterprise LTSC 1809, build 17763.503 - vmware tools 10.3.10, build 12406962

the issue does NOT occur with chrome when run directly on the host and does NOT occur on the following guest OS:

     Windows 7 Ultimate x64 SP1 latest patches 05.2019 - vmware tools 10.3.10, buils 12406962

0 Kudos
jdh2n
Contributor
Contributor

I fixed by disabling "Use hardware acceleration when available" in the Chrome settings.

ChromeSetting.jpg

Proud2BProud
Contributor
Contributor

Thanks for this - been trying to fix this for a while now

0 Kudos
parziman
Contributor
Contributor

Thank you so much! Was really annoying bug.

0 Kudos
level420
Enthusiast
Enthusiast

Hi all!

 

This bug is still present for VMware Workstation 16.1.0 with VMware Tools 11.2.5 running Windows LTSC 2019 as both, host and guest and Chrome 88 in 3 monitor setup.

 

I know that I'm able to switch off hardware acceleration in Chrome, but its not a solution to cut off software features because of bugs in WMware Workstation.

 

It's like buying a fast car only to get the information that the engine will break when driving faster than 80 mph.

 

This should be solved wherever it comes from VMware Workstation or VMware Tools or both!

 

datalifenyc
Contributor
Contributor

Dropbox in the Windows notification section of the taskbar has the same issue.

0 Kudos
treer
Contributor
Contributor

It can be worked around without disabling hardware acceleration:

go to: chrome://flags
search for: Choose ANGLE graphics backend
and change the setting from Default to OpenGL

Some users have narrowed down the graphics driver calls that break VMWare rendering.

level420
Enthusiast
Enthusiast

This bug is still present in Workstation 16.2.0 Pro and VMware tools 11.3.5-18557794

It is not present when installing/downgrading to VMware tools 11.1.5-16724464.

Please note! It is NOT a solution to disable hardware graphics acceleration in chrome because I want and need hardware graphics acceleration.

And the bug shows up in standalone clients like nextcloud client for windows, which seems to be based on the chromium rendering engine.

Harry55
Contributor
Contributor

- Shut down the VM guest system (not just suspend).
- Go to settings, select Hardware, Display
- Uncheck Accelerate 3D graphics

That should solve the problem.

no transparency.png

Harry55
Contributor
Contributor

Level420's criticism remains justified.

0 Kudos
level420
Enthusiast
Enthusiast

@Harry55 

thank you for your answer.

And this way I can use 3D graphics acceleration in the virtual machine? Not really!

But I want and need to use 3D graphics acceleration!

So any suggestion to disable hardware acceleration is not a solution to this problem.

The solution would be that WMware fixes this bug in the graphics driver or the graphics virtualization layer of vmware workstation.

_PS_
Contributor
Contributor

Thank you, I was looking for a solution to this for quite a while. 🙂

0 Kudos
AH40
Contributor
Contributor

I had the same problem with firefox and the solution was also the same.

0 Kudos
lindros2
Contributor
Contributor

this issue is now occurring in EDGE. 

Geezus Vmware and Microsoft... it's 2022.

I reinstalled Win10 over this - and am INFURIATED.

lindros2_0-1647473910347.png

 

0 Kudos