cristianmadriga
Contributor
Contributor

Vmware Workstation 8.0.2 on Ubuntu 12.04 not Working recompile error

After upgrade to Ubuntu 12.04 modules recompile for the running kernel fails on Virtual Network device

Ubuntu 12.04 x86_64

Vmware Workstation 8.0.2 build-591240

Kernel 3.2.0-24-generic

2012-05-02T11:41:15.110-06:00| vthread-3| I120: Log for VMware Workstation pid=11920 version=8.0.2 build=build-591240 option=Release
2012-05-02T11:41:15.110-06:00| vthread-3| I120: The process is 64-bit.
2012-05-02T11:41:15.110-06:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
2012-05-02T11:41:15.110-06:00| vthread-3| I120: Host is Linux 3.2.0-24-generic Ubuntu 12.04 LTS
2012-05-02T11:41:15.109-06:00| vthread-3| I120: Msg_Reset:
2012-05-02T11:41:15.109-06:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
2012-05-02T11:41:15.109-06:00| vthread-3| I120: ----------------------------------------
2012-05-02T11:41:15.109-06:00| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2012-05-02T11:41:15.109-06:00| vthread-3| I120: Msg_Reset:
2012-05-02T11:41:15.109-06:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
2012-05-02T11:41:15.109-06:00| vthread-3| I120: ----------------------------------------
2012-05-02T11:41:15.109-06:00| vthread-3| I120: PREF Failed to load user preferences.
2012-05-02T11:41:15.110-06:00| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-11920.log
2012-05-02T11:41:15.219-06:00| vthread-3| I120: modconf query interface initialized
2012-05-02T11:41:15.219-06:00| vthread-3| I120: modconf library initialized
2012-05-02T11:41:15.271-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.277-06:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.277-06:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2012-05-02T11:41:15.277-06:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2012-05-02T11:41:15.277-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.280-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.298-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.324-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:15.325-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.327-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.344-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.383-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:15.423-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.429-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.432-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.434-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.435-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.456-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.458-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.459-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.461-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.463-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.465-06:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.465-06:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2012-05-02T11:41:15.465-06:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2012-05-02T11:41:15.465-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.466-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.473-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.494-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:15.530-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.532-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.533-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.535-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.537-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.539-06:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.539-06:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2012-05-02T11:41:15.539-06:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2012-05-02T11:41:15.539-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:15.541-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.549-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:15.571-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:15.633-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.635-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.637-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.639-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:15.640-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:16.081-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:16.081-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:16.086-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:16.106-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:16.142-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:16.142-06:00| vthread-3| I120: Building module vmmon.
2012-05-02T11:41:16.142-06:00| vthread-3| I120: Extracting the sources of the vmmon module.
2012-05-02T11:41:16.184-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:19.531-06:00| vthread-3| I120: Installing module vmmon from /tmp/vmware-root/modules/vmmon.o to /lib/modules/3.2.0-24-generic/misc.
2012-05-02T11:41:19.552-06:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/3.2.0-24-generic/misc/vmmon.ko
2012-05-02T11:41:28.927-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:28.927-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:28.929-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:28.937-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:28.966-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:28.966-06:00| vthread-3| I120: Building module vmnet.
2012-05-02T11:41:28.966-06:00| vthread-3| I120: Extracting the sources of the vmnet module.
2012-05-02T11:41:29.003-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmnet-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:31.259-06:00| vthread-3| I120: Failed to compile module vmnet!
2012-05-02T11:41:31.263-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:31.263-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:31.265-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:31.276-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:31.298-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:31.298-06:00| vthread-3| I120: Building module vmblock.
2012-05-02T11:41:31.299-06:00| vthread-3| I120: Extracting the sources of the vmblock module.
2012-05-02T11:41:31.362-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:33.943-06:00| vthread-3| I120: Installing module vmblock from /tmp/vmware-root/modules/vmblock.o to /lib/modules/3.2.0-24-generic/misc.
2012-05-02T11:41:33.944-06:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/3.2.0-24-generic/misc/vmblock.ko
2012-05-02T11:41:34.934-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:34.934-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:34.938-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:34.954-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:34.984-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:34.984-06:00| vthread-3| I120: Building module vmci.
2012-05-02T11:41:34.984-06:00| vthread-3| I120: Extracting the sources of the vmci module.
2012-05-02T11:41:35.017-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:37.389-06:00| vthread-3| I120: Installing module vmci from /tmp/vmware-root/modules/vmci.o to /lib/modules/3.2.0-24-generic/misc.
2012-05-02T11:41:37.389-06:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/3.2.0-24-generic/misc/vmci.ko
2012-05-02T11:41:38.416-06:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-24-generic.
2012-05-02T11:41:38.417-06:00| vthread-3| I120: Validating path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic
2012-05-02T11:41:38.420-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:38.431-06:00| vthread-3| I120: Your GCC version: 4.6
2012-05-02T11:41:38.461-06:00| vthread-3| I120: Header path /lib/modules/3.2.0-24-generic/build/include for kernel release 3.2.0-24-generic is valid.
2012-05-02T11:41:38.461-06:00| vthread-3| I120: Building module vmci.
2012-05-02T11:41:38.461-06:00| vthread-3| I120: Extracting the sources of the vmci module.
2012-05-02T11:41:38.485-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:39.497-06:00| vthread-3| I120: Building module vsock.
2012-05-02T11:41:39.497-06:00| vthread-3| I120: Extracting the sources of the vsock module.
2012-05-02T11:41:39.575-06:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vsock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-24-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2012-05-02T11:41:41.917-06:00| vthread-3| I120: Installing module vsock from /tmp/vmware-root/modules/vsock.o to /lib/modules/3.2.0-24-generic/misc.
2012-05-02T11:41:41.917-06:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/3.2.0-24-generic/misc/vsock.ko
0 Kudos
3 Replies
lucasmv
Enthusiast
Enthusiast

hi,

you have to install a patch in ubuntu 12

you can see my post in this link:

http://communities.vmware.com/message/2030083#2030083

thanks

Lucas

cristianmadriga
Contributor
Contributor

Sweet as honey, the patch work perfectly, my VMs are up and running over Ubuntu 12.04.

Thank you,

Cristian

0 Kudos
cristianmadriga
Contributor
Contributor

So, I upgrade to 8.0.3, the installation were clear but the same problem appear before it.

When I retry to patch it wasn't possibly because the patch is for 8.0.2 and was applied previously,

It is necesary to change the version validation to 8.0.3 and delete the previous patch,

All the process is here:

http://communities.vmware.com/message/2038212#2038212

Summary:

I fixed mine by modifying the patch script (patch-modules_3.2.0.sh)

From:

fpatch=vmware3.2.0.patch
vmreqver=8.0.2
plreqver=4.0.2

To:

fpatch=vmware3.2.0.patch
vmreqver=8.0.3
plreqver=4.0.2

and delete the old patch flag:

sudo rm /usr/lib/vmware/modules/source/.patched

Then run the patch as usual:

sudo ./patch-modules_3.2.0.sh vmware3.2.0.patch

0 Kudos