marcb2
Contributor
Contributor

Visual Studio / cl.exe in guest OS bad performance

Hello everybody,

I did already search the forum extensively, but could not resolve the problem.

Here are the spec's:

Compiler performance is terrible. It takes about 3 - 6 times longer to compile the same sources inside the VM.

\- VMWare 6.0

\- Host OS: XP 64 bit SP1

\- Guest OS: tried both XP 32 and XP 64 bits (SP2/SP1).

(64 seems even worse)

\- Host RAM: 3 GB

\- Guest RAM: tried 1 - 2 GB

\- CPU: AMD Sempron64, 2.1 GhZ

\- VM configuration: everything standard. hdd expandable, IDE, 30 GB,

in 2GB slices. No USB, no floppy, tried with and without CDROM

Compiled xxx.cpp in Host: 10 seconds.

Compiled xxx.cpp in Guest: 50 seconds.

I want to remark, the Software configs in Host and Guest are very much

the same.

Has anyone experiences with VS2005 performance issues inside the VM ?

0 Kudos
3 Replies
ksc
VMware Employee
VMware Employee

Where are the files - is this over shared folders?

Shared folders are not particularly fast, networked filesystems will go faster, or keep a local copy of files that isn't accessed over shared folders.

My suspicion is that it's the filesystem access time, not cl.exe itself.

0 Kudos
marcb2
Contributor
Contributor

Thanks a lot. I think this could be the problem.

The sources are local, but a ton of #includes reside in a shared folder.

I will try to make this available locally.

Thank you again.

0 Kudos
marcb2
Contributor
Contributor

\

    • solved **

0 Kudos