defect
Contributor
Contributor

Vista "Unidentified Network" Issue

There is an issue with VMware Workstation's network adapters in that they are placed in the 'unidentified network' location which by default is a 'public location'. If any network location in Vista is public then the public location firewall rules apply (currently for me that means non discoverable etc).

The unidentified network location can be manually changed to private but this setting does not persist between host reboots (I believe this is by-design).

I would think that the Vmware adapters should be placed in a different location to prevent this problem but I'm not sure why Vista is identifying (or should I say failing to identify) the adapters. I'm attempted to set the IP addresses manually for both adapters as well as adding a gateway (the same IP) as I've heard this might help in getting identification to work but the settings get forced by (presumably by VMware) each time (strangely enough the forced IPv4 properties for both adapters is blank).

Can someone shed some light on this issue - I'm surprised there aren't any other posts there about this as it's a bit frustratiing (being forced to run in public location mode).

0 Kudos
74 Replies
defect
Contributor
Contributor

I've managed to trick the adapters to get a default gateway address to stick. The networks are now identified and set to 'private location' in the network and sharing manager. Gateway address is the same as the interface IP address. It doesn't appear to have affected networking (I got a warning about multiple default gateways) as far as I can tell.

The trick is to set the IPv4 properties of the adapter (in sharing and network manager click 'view details' for an adapter then click 'properties'). Set the IP address to what it currently is, plus add a gateway IP address (the same IP). Close the properties page then go to 'Manage virtual networks' in Workstation and disable the network adapter, apply and then re-enable it and apply.

Still would prefer a better solution of course or another way to get vista to 'identify' a network

0 Kudos
dmurillo
Contributor
Contributor

That's a nice trick.

But, is this workaround the only solution?

I would prefer to not have to mess with network settings so that when I go to a public network, I wouldn't be exposed in any way.

Sorry if I'm being "a bit" paranoïd.

DM

0 Kudos
jrichards
Contributor
Contributor

Defect,

Thanks for the work around, I was having this issue two and it was really getting frustrating. your tip made reboots livable again.

0 Kudos
Roel_Bessems
Contributor
Contributor

I'm sorry for asking but does tis solution last till leasetime of the DHCP is expired?

or is is indeed a permanent solution?

0 Kudos
jrichards
Contributor
Contributor

I'm sorry for asking but does tis solution last till

leasetime of the DHCP is expired?

or is is indeed a permanent solution?

Well; I'm not sure if it is working anymore. After I patched the Vista host with windows update, the gateway isn't staying set. I could have other problems though, I had to run windows recovery from the boot CD after trying to install motherboard drivers. I might have to do a full re-install and try again.

0 Kudos
continuum
Immortal
Immortal

>>> I had to run windows recovery from the boot CD after trying to install motherboard drivers. I might have to do a full re-install and try again.

DO NOT TRY AGAIN

VMs do not need any motherboard-drivers - and installing motherboard-drivers for your host may result in an unusable guest

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
jrichards
Contributor
Contributor

it wasn't the VM I was trying to install MB drivers on, it was the host; I am having major performance issues with disk access (known Vista issue) and was hoping that the latest patches and MB drivers would help.

0 Kudos
continuum
Immortal
Immortal

Only known fix for performance issues with Vista is upgrading to XP or 2003 Smiley Wink

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
PierreDeblaere
Contributor
Contributor

For some reason the workaround of defect didn't work for me.

I had the problem that with any guest, with any host, i had no network connectivity and therefor also no internet.

This worked for me:

My network card has 2 connections.

In Device Manager, they are named as Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller (LAN1) and Marvell Yukon 88E8052 PCI-E ASF Gigabit Ethernet Controller (LAN2).

The network cable is attached to LAN1.

In VMWare, Edit, Virtual Network Settings, Automatic Bridging

i had to uncheck Automatic bridging

and under tab Host Virtual Network Mapping

i had to choose the right LAN

for VMnet0.

Now network & internet is OK.

0 Kudos
jrichards
Contributor
Contributor

My network card has 2 connections.

In Device Manager, they are named as Marvell Yukon

88E8001/8003/8010 PCI Gigabit Ethernet Controller

(LAN1) and Marvell Yukon 88E8052 PCI-E ASF Gigabit

Ethernet Controller (LAN2).

The network cable is attached to LAN1.

In VMWare, Edit, Virtual Network Settings, Automatic

Bridging

i had to uncheck Automatic bridging

and under tab Host Virtual Network Mapping

i had to choose the right LAN

for VMnet0.

Now network & internet is OK.

I'll give this a try, i'm up for any workaround as long as i can reboot my host remotely!!

Thanks for the info!

0 Kudos
jrichards
Contributor
Contributor

Only known fix for performance issues with Vista is

upgrading to XP or 2003 Smiley Wink

This could be an interesting conversation though off target for the thread (and it borders on 'beating a dead horse' already because everyone has jumped on the vista bashing bandwagon). I'm not going to revert to a older version of windows that doesn't have the features I want (media center and 64bit to utilize my 8 GB of ram specifically). My preferred host OS would be Solaris, but it doesn't have media center, or VMWare... while the slow disk access is very annoying, i can live with it, because i have to, until the fix is released.

0 Kudos
spyordie007
Contributor
Contributor

I had been able to get this working by setting the default gateway addresses however after installing SP1 (RC1) neither of these workarounds seem to take care of the problem.

For lack of a better solution I ended up disabling the virtual interfaces (I rarely use them anyways, and even if I need them I can re-enable).

I'm having this problem on my laptop and desktop after installing SP1, can anyone else confirm?

Erik

0 Kudos
ejobrien
Contributor
Contributor

Yes, I can confirm this. The same thing has happened to me after installing SP1. It seems to have resolved some of Vista's performance issues, but I'm no longer able to get the default gateway to stick for the virtual adaptors.

0 Kudos
upanisad
Contributor
Contributor

First of all, I'm using VM Ware Player and Windows Server 2008 RC (which is based on Vista).

Setting the IP and the gateway to be the same didn't work for me. I have copied the VMWare IP (192.168.230.1 in my case) to the gateway setting, but I've set the IP to a free address on my private network (192.168.2.x) and I've enabled the VMWare Bridge Protocol. I restarted the interface (disabled and enabled it) and everything worked fine. The VMWare virtual adapater is a "Network", I can rename it and set it to Private. Internet works both for the host and the virtual machine.

0 Kudos
richv
Contributor
Contributor

Hey jrichards...

Just an fyi... If your performance issue is between the Vista host and the VM machines, try setting up a host only adapter and referring from the VM machine to the host using the gateway of the host only adapter.

That worked great for me and I was able to quickly access files on the host's hard drives...

That was with VMWare Server 1.0.4. Now I'm messing around with VMWare Workstation 6.0 (and having problems with network issues).

0 Kudos
defect
Contributor
Contributor

Confirmed, this no longer works under Vista SP1.

I'm surprised this hasn't received more attention from VMware as it's a problem that has security implications.

For example, Vista is forced to always run under the 'public' network firewall rules. In order for someone to get their application to work they allow network connections (when prompted by Vista) which affect the 'public' firewall ruleset. These ports are then -always- exposed even in 'real' public areas like wireless hotspots etc.

Is there some way to escalate this or bring it to VMware's attention so that it can be addressed?

0 Kudos
richv
Contributor
Contributor

Amen... This issue has been around for a long time! What gives VMWare?

0 Kudos
noetus
Contributor
Contributor

Yes, I am also waiting for a fix to this issue. Come on, VMware!

0 Kudos
ejobrien
Contributor
Contributor

It seems as though VMWare may be moving their focus entirely away from Workstation, towards their high-end server products. This issue was raised almost a year ago, and as far as I can see has been completely ignored by VMWare. Is anyone from VMWare watching these forums?

This issue impedes the functioning of the sofware, and certainly makes my life at least just that little bit more difficult. It really should be a simple fix. If someone from VMWare could at least acknowledge that they're aware of the problem and are working to resolve it, that would be a great start.

The potential workarounds for me are...

  1. Simply leave as is, and allow Vista to set the network to "Unidentified Network". This however means that file sharing etc. stop working because of public network firewall rules.

  2. Change firewall rules to allow file sharing etc. for public networks... This isn't going to happen, as it's a serious security issue.

  3. Change to bridged networking. This allows me to communicate with the VM's without having to enable the VM host-only and NAT interfaces, thereby removing the "Unidentified Network". This however creates problems when I swap between different physical networks, and often leads to IP conflicts when I've paused VM's.

None of these options are really satisfactory.

As far as I can tell, all that should be required would be for VMWare to change the virtual adapters to automatically include self-referencing gateway IP addresses. This will allow Vista to correctly identify the virtual networks, and all the issues will be resolved.

Eugene

0 Kudos