oaklodge
Enthusiast
Enthusiast

Virtual monitors not working

I have VMWare 15.1 and running Windows 10 [Version 10.0.18362.295] as both a Host and Guest.

My host has one physical monitor

I have configure the guest the have 2 monitors.

I start the guest and press win+P to detect and extend onto the second virtual monitor.

Windows detects a second monitor, however VMWare is not showing anything on the monitor - its black, nada, nothing.

Windows display settings is showing two monitor and I can move the location of 1 & 2 around.

If I press Identify, "1" only shows up, The second virtual monitor remains black.

How do I get this to work or is it broken?

0 Kudos
3 Replies
banackmatt
VMware Employee
VMware Employee

Hi oaklodge,

The easiest way to get this to work is to use the VMwareResolutionSet.exe app bundled with VMTools.  You should supply the screen positions and dimensions.  For two monitors that will look like:

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 2 32 , 0 0 1024 768 , 1024 0 1024 768

Note that the commas and spaces should be formatted exactly as shown.  The screens are in the format <position_X> <position_Y> <width> <height>.  This puts two 1024x768 monitors side by side (the second one at +1024+0).

If you don't have VMTools installed, you will have to install it first.  You should also make sure that your setting of View > Autosize is set to "Center Guest" to prevent Autofit.

If this doesn't work, please post what version of Tools you have installed, or try the most recent released version.

0 Kudos
oaklodge
Enthusiast
Enthusiast

Thanks - I didn't get a notifications that a reply was waiting...

I presume I still need to configure the gues in the host as having 2 monitors?

0 Kudos
banackmatt
VMware Employee
VMware Employee

Yes, you should still configure the VM to have at least 2 displays.

0 Kudos