Enthusiast
Enthusiast

Very Slow suspend speeds - Workstation 8.0.2

Jump to solution

I don't know if it something that I have done, or the recent Workstation update, but it is now taking forever to suspend my (quite large) guests. A Vista guest is by far the worst performer, although a fairly small Windows 8 guest is also very slow.

All my guests are split into 2GB sizes and all have recently been 'shrunk' --- (mistake?). All are running under a Windows 7 host.

Does anyone have any tips to try to improve performance short of going back to Workstation 7?

1 Solution

Accepted Solutions
Immortal
Immortal

> Has anything you've tried so far worked?
Hi Dave
I had the same problems with suspend times in WS 8 and 9.
Only thing that really worked was changing my habbit to use suspend rather than power off when done with a VM.

With WS 9 I expected that suspending one of my typical VMs may mean that the host can do nothing else than just suspending that one VM for a time upto 30 minutes (often) or even a full hour (often enough to notice it ! )
I tried all that I could think off but nothing really helped - I never used WS so rarely as that version 9.

I run 10 now and the suspend times are close to what we were used to with 6.5 or 7

So those problems seem to be fixed in WS 10 - at least for me.
But before you change - check carefully as WS 10 has different problems

Do you need support with a recovery problem ? - call me via skype "sanbarrow"

View solution in original post

5 Replies
Contributor
Contributor

I am facing this problem with Ver 9 too. Desperate to find resolution.

0 Kudos
Expert
Expert

--Has anything you've tried so far worked? If you have the disk space, I would highly recommend converting your 2GB split disks to single-growable disks and then defragging the host disk.  Also, for performance it's a good idea to have separate physical disks for C: and D:, with vmware stuff on 😧

./. If you have appreciated my response, please remember to apply Helpful/Correct points. TIA
0 Kudos
Immortal
Immortal

> Has anything you've tried so far worked?
Hi Dave
I had the same problems with suspend times in WS 8 and 9.
Only thing that really worked was changing my habbit to use suspend rather than power off when done with a VM.

With WS 9 I expected that suspending one of my typical VMs may mean that the host can do nothing else than just suspending that one VM for a time upto 30 minutes (often) or even a full hour (often enough to notice it ! )
I tried all that I could think off but nothing really helped - I never used WS so rarely as that version 9.

I run 10 now and the suspend times are close to what we were used to with 6.5 or 7

So those problems seem to be fixed in WS 10 - at least for me.
But before you change - check carefully as WS 10 has different problems

Do you need support with a recovery problem ? - call me via skype "sanbarrow"

View solution in original post

Expert
Expert

--Ulli my friend, I have already plunked down $$$ to upgrade to WS10 for Linux - but thanks for the warning Smiley Happy

--At least on my system (I use JFS filesystem) I turn off Background snapshots/suspends, and a typical VM writes at nearly disk-speed when suspending. I suspect part of the wait could be alleviated if one used a fast RAID10 or SSD or the like.

./. If you have appreciated my response, please remember to apply Helpful/Correct points. TIA
0 Kudos
Enthusiast
Enthusiast

I agree, this seems to have been a bug introduced in Vmware 9 that was addressed in 10. Also addressed in 10 is the ability to handle the addition of tools to the later editions of Linux.

0 Kudos