Highlighted
Contributor
Contributor

VMware showing this error "Your host does not meet minimum requirements to run VMware Player with Hyper-V or Device/Credential Guard enabled."

Jump to solution

Hello, I installed VMware 15.5.6 build-16341506 on win 10 Home (ver 1909) after setting up Ubuntu OS image, I started the guest OS and this error popped up "Your host does not meet minimum requirements to run VMware Player with Hyper-V or Device/Credential Guard enabled. Refer to VMware KB article 76918 at https://kb.vmware.com/kb/76918 for more details."Untitled.jpg

Then after clicking "OK", another dialog box appeared,

Untitled1.jpg

Actually, this is not the first time I am running a Vmware application, I used it before but I had to make a clean installation of win 10 via USB, after that clean install I'm not able to run VMware but before the system reset it worked fine I used to run Ubuntu very smoothly on my system.

1 Solution

Accepted Solutions
Highlighted
Hot Shot
Hot Shot

If I understood well the KB article, in order to have Workstation/Player run concurrently with Hyper-V you need to upgrade to at least Windows 10 build 19041.264 (aka Windows 2004). The latest Win10 build is 19041.329.

If you need to stay on Win10 1909, you should disable Hyper-V. See MS article https://support.microsoft.com/en-us/help/3204980/virtualization-applications-do-not-work-together-wi...

___________________________________________________________________________

Did you find this helpful? Let us know by completing this survey (takes just 1 minute!)

View solution in original post

0 Kudos
5 Replies
Highlighted
Hot Shot
Hot Shot

If I understood well the KB article, in order to have Workstation/Player run concurrently with Hyper-V you need to upgrade to at least Windows 10 build 19041.264 (aka Windows 2004). The latest Win10 build is 19041.329.

If you need to stay on Win10 1909, you should disable Hyper-V. See MS article https://support.microsoft.com/en-us/help/3204980/virtualization-applications-do-not-work-together-wi...

___________________________________________________________________________

Did you find this helpful? Let us know by completing this survey (takes just 1 minute!)

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

Hello, I still didn't get win 10 2004 update but I want VMware to run even if I update, without getting these annoying error messages, and the link which u gave to disable hyper-v is available for win 10 pro.I've already mentioned that mine is windows 10 home so that option to disable hyper-v is not there in "Turn Windows features on or off". Method 2 of executing the command in PowerShell is also not working for which I guess because i have win 10 Home.

Please tell me how to fix this issue in Win 10 Home.

0 Kudos
Highlighted
Hot Shot
Hot Shot

I know that you run Win10 Home.  It seems that for some reason Player detects Hyper-V as running, so we had to check. Perhaps this is a Player only problem and does not appear in Workstation.

An immediate workaround would be to uninstall Player 15.5.6 and revert temporarily to 15.5.2 (a version before Player started looking for Hyper-V). Somebody more experienced may have more ideas.

Please mark this thread as "not answered" (I guess you marked it by mistake) - the issue is still "Player 15.5.6 misidentifies Windows 1809 Home as running Hyper-V"

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi,

Thank you for posting your query in community.  you can disable hyper-V if  you are using windows 10 1909 home by windows cmd line with administrator privileges and reboot:

bcdedit /set hypervisorlaunchtype off

If u want use hyper-v in win10 2004 update (19041.264)

bcdedit /set hypervisorlaunchtype auto

Thanks.

Highlighted
Contributor
Contributor

I faced the same issue, I'm guessing the root cause of this issue,

It happened to me after my Pc has force shutdown and the VMware was running.

my Hyper-V is already disabled, the Device Guard is not configured, I tried to changed it to disabled with no luck.

run Copple of commands in PowerShell to disable the Hyper-V and device guard. restart many times and nothing happened.

Uninstall the VMware, reinstall it with same error.

update and install the very latest windows update with no luck.

my Windows 10 Pro is original but I guess the failure is coming from the VMware side.

any way to solve it?

0 Kudos