ppan7
Contributor
Contributor

VMware Workstation does not support nested virtualization on this host.

Jump to solution

Screenshot_2.jpg

After Windows update 2020 may build 2004, vmvare doesnt support Virtualize intel Vt-x/EPT. How fix this problem. I update vmvare to 15.5.5, But it didn`t help

Tags (1)
68 Replies
aurebus_kd
Contributor
Contributor

"disable virtualization checkboxes" is the final solution that worked fine in our case.

we did:

1) bcdedit /set hypervisorlaunchtype off

2) uncheck checkboxes

Thanks!

0 Kudos
TiagoNasciment1
Contributor
Contributor

Hi,

This is not solve at all...

You are just disabling  the nested (VT-X), i can't do that because i need it.


It happen after windows update 2004.

pastedImage_0.png

pastedImage_1.png

pastedImage_2.png

0 Kudos
m_savazzi
Contributor
Contributor

VMWare 1 6 Pro still get tehhe same error on Virtualization Counters. Only way to have it work is to disable Virtualization options.

Very bad

0 Kudos
clonliffe
Contributor
Contributor

Your screenshot just helped me fix both of my Linux distros!! I unchecked all three and I'm in!

 

0 Kudos
otaktay
Contributor
Contributor

You can run vmware and hyper-v together now since 15.5. I had to make sure that "Virtualize Intel VT-x/EPT or AMD-V/RVI" was NOT CHECKED. It's a beautiful thing 🙂

0 Kudos
charlielewis
Enthusiast
Enthusiast

Any update on this? As it stands now (February 16, 2021), the following setup is NOT possible

* Host: Intel XEON 

* Host: Windows 10 20H2 

* Host: Windows Subsystem for Linux (a.k.a WSL2) enabled

 

* VM: Windows 10 20H2

* VM Run something that needs virtualization (like Docker). 

---

The only way to restore the VM's ability to run docker is to completely disable WSL on the host. This is not an acceptable compromise. A developer should not have to choose between WSL and VMware

 

Can anyone here confirm if Parallels or VirtualBox is capable of nested virtualization when the host has either Hyper-V or WSL enabled?

 

0 Kudos
darksidemaze
Contributor
Contributor

Highlight the guest, Edit Virtual Machine Settings, Device: Processors, untick Virtualise Intel VT-x/EPT or AMD-V/RVI should also do the trick.

0 Kudos
charlielewis
Enthusiast
Enthusiast

As per my message: I'm not interested in a "simple" VM. I need one that can run a virtualization layer (like Docker) inside of it. In other words, that is not a viable solution for a lot of developers

0 Kudos
darksidemaze
Contributor
Contributor

Last time I could run nested was back around 6.5 which was a long time ago.

0 Kudos
tom42
Contributor
Contributor

"You can run vmware and hyper-v together now since 15.5. I had to make sure that "Virtualize Intel VT-x/EPT or AMD-V/RVI" was NOT CHECKED. It's a beautiful thing"

 

 

Yeah, but without  "Virtualize Intel VT-x/EPT or AMD-V/RVI" It is slow AF on my 3900x


 

tom42
Contributor
Contributor

You take a noticeable performance hit without Virtualize Intel VT-x/EPT or AMD-V/RVI

0 Kudos
milindng
Enthusiast
Enthusiast

it works now

0 Kudos
milindng
Enthusiast
Enthusiast

Yes , its slow . This might be due to 32 bit support

0 Kudos
Anurag0072
Contributor
Contributor

Thanks man for that command, u saved the day

0 Kudos
Cyber40014
Contributor
Contributor

Exactly this: Happend after WSL installation. I forgot about HyperV being installed when doing that, and so I ran into that problem. 
This solved it. Thanks.
When I just clicked agreed to not using VT-X when it prompted me, during startup of the machin, it threw an HV error. 
"VMware Workstation does not support nested virtualization on this host."

0 Kudos
Naaim-assaf
Contributor
Contributor
I have a problem with vmware, I did everything that required to install the tools and the program, then this message appeared to me, then i restarted and directly to the BIOS to enable enable virtualization technology. Can you help me?
 
 
 
 
 
But I did not find it
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
0 Kudos
milindng
Enthusiast
Enthusiast

Try to replace Workstation versions, I hope this will work.

Making setting under option tab -Virtualization engine in existing workstation will make you VM working slow

0 Kudos
aamer_akram
Contributor
Contributor

You must remove Hyper-V from (Control panel) ----> (Program and features) ---->(Turn windows features on or off) then remove click on (Hyper-V).

0 Kudos
CharlesL1
Contributor
Contributor

  

0 Kudos
CharlesL1
Contributor
Contributor

Thank you so much @sachira! I unchecked all three virtualization engines and it worked for me! Now I can finally get back to my virtual machine after months of searching for solutions! 

0 Kudos