Highlighted
Contributor
Contributor

VMware Workstation does not support nested virtualization on this host.

Jump to solution

Screenshot_2.jpg

After Windows update 2020 may build 2004, vmvare doesnt support Virtualize intel Vt-x/EPT. How fix this problem. I update vmvare to 15.5.5, But it didn`t help

1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

I found only this solution :

If u want use vmware : use this command in powershell and reboot system:

bcdedit /set hypervisorlaunchtype off

If u want use hyper-v:

bcdedit /set hypervisorlaunchtype auto

Hyper-v and Vmvare still don't work together

----------------------------------------------------------------

Did you find this helpful? Let us know by completing this survey (takes just 1 minute!)

View solution in original post

22 Replies
Highlighted
VMware Employee
VMware Employee

Hi ppan7,

Thank you for posting your query in community.

Could u please help to check your Win10 2004 Hyper-V status or provide more information about vmware.log?

Also there is a section 5 about Running Workstation on a Hyper-V Enabled Host per https://docs.vmware.com/en/VMware-Workstation-Pro/15.0/workstation-pro-15-user-guide.pdf for your reference.

Thanks.

0 Kudos
Highlighted
Contributor
Contributor

Same issue here.  So the problem is if your Windows 10 gets VBS enabled or you try any Hyper-V functionality on Windows 10, it breaks any and all nested virtualization for VMware Workstation.  What we need is information on the minimum steps to turn off, delete, change, whatever is necessary on Windows 10 to re-allow the nested virtualization features, as that is for some of us the most essential function we need.  So thank you for pointing us to a document that shows in the details that "by the way this disables your nested virtualization", but what we also need desperately is the information to regain that function of nested virtualization.

Michael Fryman Solutions Architect Ciber, Inc. www.ciber.com
Highlighted
Contributor
Contributor

I found only this solution :

If u want use vmware : use this command in powershell and reboot system:

bcdedit /set hypervisorlaunchtype off

If u want use hyper-v:

bcdedit /set hypervisorlaunchtype auto

Hyper-v and Vmvare still don't work together

----------------------------------------------------------------

Did you find this helpful? Let us know by completing this survey (takes just 1 minute!)

View solution in original post

Highlighted
Community Manager
Community Manager

https://vinfrastructure.it/2018/06/vmware-workstation-and-windows-10-security/

To disable Device Guard or Credential Guard the first step is the following:

  1. Disable the group policy setting that was used to enable Credential Guard.
    1. On the host operating system, click Start > Run, type gpedit.msc, and click Ok. The Local group Policy Editor opens.
    2. Go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security.
    3. Select Disabled.

We have a KB but, NGL, it's complete trash and I'm having it rewritten.

The reason that nested virtualization doesn't work is because our virtual machine monitor ("vmm", the 'hypervisor' part of the hypervisor) code was designed and optimized to do this, but Hyper-V monitor code is not. We actually test ESXi in Workstation (for linux) VMs in monster CI pipelines.

Our stack is obviously more mature, so when using the Hyper-V API's we had to make some compromises. We're working with MS to address the use-case, but we don't have a solid delivery date to communicate just yet.

- Michael Roy - Product Line Manager: Fusion & Workstation
Highlighted
Contributor
Contributor

Those bcdedit commands worked great!  Thank you!! Smiley Happy

Michael Fryman Solutions Architect Ciber, Inc. www.ciber.com
0 Kudos
Highlighted
Contributor
Contributor

Team the BcdEdit solution is a workaround.

Before the upgrade to 2004 everything was fine.

Without any change in configuration I've updated to 2004 and then VMWare is not working anymore.

Highlighted
Contributor
Contributor

Totally agree its a workaround, I am in the situation where VMWare and Hyper-V cannot coexist.

0 Kudos
Highlighted
Contributor
Contributor

I also got the same issue. I was able to get the VM working by disabling Virtualize Intel VT-x/EPT or AMD-V-RI and Virtualize CPU performance counters under VM Settings -> Processors -> Virtualization Engine. This is still a big upset for me because I was using VMs inside VMs sometimes. But since I want to try WSL2, I'm going to live with it for now.

Highlighted
Contributor
Contributor

My VMs worked fine with Hyper-V enabled under 15.5.5. However, since upgrading to 15.5.6, I find that VMs created by 15.5.5 will not start: getting the same error as this ticket. VMs created earlier than that are working without problem.

0 Kudos
Highlighted
Contributor
Contributor

...or is it because they are linked clones of other VMs?

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi,

Thank you for posting your query in community. Actually there is no change in this area between ws15.5.5 and ws15.5.6.

BTW, could you please share  some information about your steps/vmware.log and vm-support bundle for investigation.

Thanks.

0 Kudos
Highlighted
Contributor
Contributor
Highlighted
Contributor
Contributor

Hi,

The chain of events, as I remember it, was that after installing 15.5.5, I enabled the Hyper-V features and rebooted. At that time, I had no problems running VMs. I created two new VMs, which were linked clones of an existing VM (Windows Server 2019) and had no problems with them that day.

Last Thursday, I installed 15.5.6, but did not reboot. I was still able to run all VMs without problem.

On Friday, after a reboot Thursday night, I could run older VMs, but neither of the VMs I had recently created would start: I got the error mentioned previously. Disabling Hyper-V features allowed me to run them as before. Since I rarely use Hyper-V, it's not a big issue, but it would be nice if I could do so without having to reboot.

I didn't check the logs at the time, but these seem to be the relevant lines:

2020-06-12T09:08:47.230+01:00| vmx| I005: Module 'MonitorMode' power on failed.

2020-06-12T09:08:47.230+01:00| vmx| I005: VMX_PowerOn: ModuleTable_PowerOn = 0

2020-06-12T09:08:47.230+01:00| vmx| I005: Vix: [mainDispatch.c:4200]: VMAutomation_ReportPowerOpFinished: statevar=1, newAppState=1873, success=1 additionalError=0

2020-06-12T09:08:47.230+01:00| vmx| I005:

2020-06-12T09:08:47.230+01:00| vmx| I005+ Power on failure messages: VMware Workstation does not support nested virtualization on this host.

2020-06-12T09:08:47.230+01:00| vmx| I005+ Module 'MonitorMode' power on failed.

2020-06-12T09:08:47.230+01:00| vmx| I005+ Failed to start the virtual machine.

2020-06-12T09:08:47.230+01:00| vmx| I005+

2020-06-12T09:08:47.230+01:00| vmx| I005: Vix: [mainDispatch.c:4200]: VMAutomation_ReportPowerOpFinished: statevar=0, newAppState=1870, success=1 additionalError=0

2020-06-12T09:08:47.230+01:00| vmx| I005: Transitioned vmx/execState/val to poweredOff

2020-06-12T09:08:47.231+01:00| vmx| I005: Vix: [mainDispatch.c:4200]: VMAutomation_ReportPowerOpFinished: statevar=0, newAppState=1870, success=0 additionalError=0

2020-06-12T09:08:47.231+01:00| vmx| I005: Vix: [mainDispatch.c:4238]: Error VIX_E_FAIL in VMAutomation_ReportPowerOpFinished(): Unknown error

0 Kudos
Highlighted
Contributor
Contributor

I had the same errors with 15.5.6 (just got the 2020H1 update) and found that I had to edit a setting. One that works is edit the processor setting and turn the virtualisation options on, then edit again and turn off, but any change to the settings seems to help. Then the VMS started fine for me.

Highlighted
Enthusiast
Enthusiast

Same as here e.e

Tsuki o miru tabi omoi da se(Remember me when you look at the moon) XD
0 Kudos
Highlighted
Enthusiast
Enthusiast

I solved it enabling Hyper-V on additional Windows resources e.e

Tsuki o miru tabi omoi da se(Remember me when you look at the moon) XD
0 Kudos
Highlighted
Contributor
Contributor

It works. You must just disable virtualization checkboxes. It is also explained here:
VMware Workstation 15.5 Now Supports Host Hyper-V Mode - VMware Workstation Zealot - VMware Blogs
pastedImage_0.png
Don't know how much performance drop is without those checkboxes (BTW, those were never enabled by default when creating new VM).

Anyway VMWARE should at least mention this in some info dialog (instead of ugly and nonsense dialog about nested virtualization) or just disable those checkboxes when running with HYPER-V.

0 Kudos
Highlighted
Enthusiast
Enthusiast

But it's still keeps the virtualization on the VM as disabled,VMware needs to solve it fast as possible e.e

Tsuki o miru tabi omoi da se(Remember me when you look at the moon) XD
0 Kudos
Highlighted
Contributor
Contributor

But it works concurrently with hyper-v and it is the main point. I don't know how much slower it is. I tried just superpi and it is +- the same speed in VM and host system. I may try other benchmarks.

0 Kudos