Mathimino
Contributor
Contributor

VMware Workstation cannot connect to the virtual machine. Vmware Workstation Pro 16

Hello, this is my first time using vmware workstation on this pc. I launched my first vm in order to install ubuntu 20.04 64bit, but the software remains in "not responding" for a while (photo 1) then displays the following error: "VMware Workstation cannot connect to the virtual machine. Make sure that you have the necessary rights to run the program, access all directories used by the program, and access all directories for temporary files. "(photo 2).I have already tried restarting the vmware services but it did not work.
Any idea to help me?
The translation may be incorrect because I used google translate

0 Kudos
10 Replies
wila
Immortal
Immortal

Hi,

First thing to try, with Workstation shut down, remove any .lck folders in the VM and try again.

If that doesn't help, then please have a look and check if VMware workstation creates and updates the vmware.log file in the VM's folder?
If so then try to attach that to a reply here.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Wei--Ning
Contributor
Contributor

Hi,

I just encountered the same error.

Attached are my log files for you.

This completely blocks my work. Please take a look.

0 Kudos
Wei--Ning
Contributor
Contributor

adding some info:

- I'm on Ubuntu 20 LTS and a 4y old Dell XPS 15 (7th gen intel i7 CPU); VMware has never been an issue in the past year until recently (upgraded to 16)

- I have tried uninstalled `vmware-uninstall` and re-install using the official installer bundle; the issue remains

- I also have a test PC with AMD Ryzen 7 running 20 LTS - I don't have such issues there. I believe the workstation versions are the same (the latest 16 patch version).

- just before this issue happened on the XPS, I got an update from VMware saying it needs to reinstall some kernel modules: `vmnet, vmmod` and something else

Tags (1)
0 Kudos
bluefirestorm
Champion
Champion

Wei-Ning,

Even the error message might be similar/same, your situation might be different from the original post. From the screenshot of the OP, the host is Windows while you have Ubuntu 20.04 LTS.

With 16.2.x the renderer for Linux hosts now uses Vulkan by default instead of OpenGL.

From the vmware.log
2022-03-18T23:50:38.566Z Wa(03) svga The vmx lost its connection to the mksSandbox.
2022-03-18T23:50:38.566Z Wa(03) svga The mksSandbox process may have crashed or hung.
2022-03-18T23:50:38.566Z Wa(03) svga Check the mksSandbox.log and vmware.log for more details.
2022-03-18T23:50:38.566Z Cr(01) svga PANIC: ISBRendererComm: Lost connection to mksSandbox (2713)

From the mksSandbox.log
It looks you have a GTX 1050 mobile GPU but the renderer switched to using the integrated Intel GPU. The Vulkan renderer right now looks for Turing or newer generation for Nvidia GPUs.

2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Available Vulkan devices:
2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Vulkan Device 0:
2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Name= 'NVIDIA GeForce GTX 1050'
2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Vulkan Device 2:
2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Name: 'Intel(R) HD Graphics 630 (KBL GT2)'
2022-03-18T23:48:47.890Z In(05) mks Vulkan Renderer: Using device 2 of 3

You can try one of two things. Both options require editing of vmx configuration file of the VM. Shut down the VM and before editing the VM vmx configuration file.
(1) switch to OpenGL
(2) force the Vulkan renderer to use the Pascal-based GTX 1050

For option (1), add the following lines
mks.enableVulkanRenderer = "FALSE"
mks.enableGLRenderer = "TRUE"

For option (2), add the following line
mks.vk.allowUnsupportedDevices = "TRUE"

Options (1) and (2) are mutually exclusive. So you have to the remove the lines of option (1) when you want to try (2) and vice-versa. Instead of deleting the lines you can add a # in front to comment out the dictionary entry.

For both (1) and (2) you could also add
mks.forceDiscreteGPU = "TRUE"

to ensure that the GTX1050 is used instead of the Intel iGPU as the rendering device.

Wei--Ning
Contributor
Contributor

Thanks, @bluefirestorm . I ended up taking option 2) force the Vulkan renderer to use the Pascal-based GTX 1050, and confirmed that I was able to connect to the VM. I recall having similar issues with this old XPS where certain software was given the embedded graphic card instead of the discrete one.

Your explanation is so valuable - I will have to read it closely again.

Also, wondering if it's possible to permanently disable the 3D-acceleration feature for all the VMs? (so I don't have to edit the config file for each VM provisioned) - I will search around but reckon you might know the answer.

Thanks again for your timely help!

0 Kudos
bluefirestorm
Champion
Champion

Wei-ning,

There are two places to set default vmx dictionary values for Linux hosts

/etc/vmware/config for host machine scope
/home/$USER/.vmware/config for user scope

So you could add the lines

mks.vk.allowUnsupportedDevices = "TRUE"
mks.forceDiscreteGPU = "TRUE"

in either config file without having to add it to every VM vmx file. If there is a contradiction at the vmx configuration, continuing with the example above, if you add

mks.forceDiscreteGPU = "FALSE"

The vmx configuration takes precedence; so in this case it won't force using dGPU and will fall back to default behaviour which is to use the first render device it finds (which may or may not be a dGPU).

So with regards to disabling the 3D acceleration

mks.enable3D = "FALSE"

It looks tricky as the Create VM wizard appears to set the 3D acceleration as "ON" (at least for Windows 10 VM custom install) which will set into the vmx file and therefore take precedence over the /etc/vmware/config; unless the wizard will pick up the config file settings (I don't know if it does). But there is another preferences setting (aside from config) but I don't know how or whether it can affect vmx power up defaults and/or VM creation wizard.

Wei--Ning
Contributor
Contributor

So good! Much appreciated!

0 Kudos
Makban
Contributor
Contributor

The same error with me.

I bought a new laptop Lenovo AMD Ryzen 7 5800H and installed Ubuntu first. However, the bridge connection did not work at all.
Now I switched to Windows 11 and the error is the same. 

"VMware Workstation cannot connect to the virtual machine. Make sure you have rights to run the program, access all directories the program uses, and access all directories for temporary files.

Failed to connect pipe to virtual machine: The system cannot find the file specified."

I wanted to try one of the solutions here. It is about switching from Vulkan. But I could not find changeable content.

Hardware: Lenovo Ryzen 7 AMD 5800H

OS: Windows 11 Pro N for Workstation

Hypervisor: Vmware Workstation 16 Pro

 

Please Help me !!!

0 Kudos
bluefirestorm
Champion
Champion

Makban,

Your situation is different from the OP as the OP has a Linux host while you have a Windows 11 Pro N. Windows hosts does not use Vulkan at the moment for rendering.

Anyway, there is a problem with N editions of Windows because of missing multimedia files (I think these files were excluded as part of the settlement between EU antitrust commission and Microsoft removing multimedia functions from Windows hence the N edition for EU users). Have a look at this thread

https://communities.vmware.com/t5/VMware-Workstation-Pro/Workstation-Pro-doesn-t-work-on-Windows-10-...

 

Makban
Contributor
Contributor

Thank you so much for attention. I appreciate

0 Kudos