geob
Enthusiast
Enthusiast

VMware Workstation and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMware Workstation.

Jump to solution

Recently, I migrated a Windows 10 Virtual Machine, to a host laptop also running Windows 10, and VMware Workstation 12.   When I attempt to power on the VM, I get an error popup that states:  VMware Workstation and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMware Workstation.

At one point I must have turned on Hyper-V within the Windows 10 Virtual Machine.  But I am unable to remove the role, because I must power on to do so, and VMware Workstation is not allowing the VM to power up. 

Anyone know how I may resolve this issue?

Thanks,

GeoB

1 Solution

Accepted Solutions
xspartacusx
Contributor
Contributor

HERES THE SOLUTION:





The only way I can think of that you had Hyper-V installed and running without you doing it is either

1.) Someone else did it

2.) You did it (or someone else) in windows 8.1 (if you had upgraded from that)

How it got installed doesn't matter.

Now, assuming you still need to know what to do to fix this here a simple step by step guide to fix it.

1.) Right click the start button in windows 10 (This solution will NOT touch VMWARE at all), and click "Control Panel"

2.) Make sure it has the icons listed instead of the groups.  Click on "Programs and Features"

3.) On the left side of the window, click on "Turn Windows features on or off"

4.) When the next window opens, locate the check box labeled as "Hyper-V" ans make sure it isnt filled, and that it isnt checked. 

5.) Then click on "Ok" button on the bottom of the window.  It will refresh and apply the change to the computer. It will probably ask you to reboot. If it does, hit the "reboot now" button.

6.) After the computer restarts, try to launch VMWare again.  If it still wont allow you to run a virtual machine, make sure your computer has virtualization enabled. (If you dont know, google it. Lots of tutorials out there). If it is enabled, uninstall Vmware and install it again.




I hope this helped you if you still needed help!!

If you still need help, i can provide a video tutorial if needed. Smiley Happy

View solution in original post

0 Kudos
4 Replies
continuum
Immortal
Immortal

The message does not relate to anything inside the VM - it speaks about the HyperV role on the host.


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
xspartacusx
Contributor
Contributor

HERES THE SOLUTION:





The only way I can think of that you had Hyper-V installed and running without you doing it is either

1.) Someone else did it

2.) You did it (or someone else) in windows 8.1 (if you had upgraded from that)

How it got installed doesn't matter.

Now, assuming you still need to know what to do to fix this here a simple step by step guide to fix it.

1.) Right click the start button in windows 10 (This solution will NOT touch VMWARE at all), and click "Control Panel"

2.) Make sure it has the icons listed instead of the groups.  Click on "Programs and Features"

3.) On the left side of the window, click on "Turn Windows features on or off"

4.) When the next window opens, locate the check box labeled as "Hyper-V" ans make sure it isnt filled, and that it isnt checked. 

5.) Then click on "Ok" button on the bottom of the window.  It will refresh and apply the change to the computer. It will probably ask you to reboot. If it does, hit the "reboot now" button.

6.) After the computer restarts, try to launch VMWare again.  If it still wont allow you to run a virtual machine, make sure your computer has virtualization enabled. (If you dont know, google it. Lots of tutorials out there). If it is enabled, uninstall Vmware and install it again.




I hope this helped you if you still needed help!!

If you still need help, i can provide a video tutorial if needed. Smiley Happy

0 Kudos
Alexyus
Contributor
Contributor

I just had the same issue. I have fixed it following the below link:

http://www.ivobeerens.nl/2013/12/16/running-hyper-v-and-vmware-workstation-on-windows-8-x/

Hope this helps.

nd570
Contributor
Contributor

If this does not solve your problem, download DG_readiness Tool from Microsoft:

Download Device Guard and Credential Guard hardware readiness tool from Official Microsoft Download ...

Extract to a local folder open an administrative powershell in this folder

execute: .\DG_Readiness_Tool_v3.6.ps1 -enable

Reboot

open again an administrative powershell in this folder

execute .\DG_Readiness_Tool_v3.6.ps1 -disable

execute bcdedit /deletevalue hypervisorlaunchtype

(ignore all error messages from DG_Readiness_Tool_v3.6.ps1​)

If this also does not help, reinstall your VMware product after these steps.

Reboot once between deinstallation and installation!

0 Kudos