Contributor
Contributor

VMware Workstation and Device/Credential Guard are not compatible

I have been running VMware for the last year no problems, today I opened it up to start one of my VM and get an error message, see screen shot.

1.PNG

Have referred to the VMware KB as mentioned in the error message but did not help:

https://kb.vmware.com/s/article/76918

Any help will be very helpful.

1 Reply
Contributor
Contributor

Referred to VMware KB:VMware Knowledge Base

Did not help.

After doing a lot of research found the below solution very helpful to resolve the issue:

---------------------------------------------------------------

Fixed error in VMware Workstation on Windows 10 host

Transport (VMDB) error -14: Pipe connection has been broken.

---------------------------------------------------------------

Today we will be fixing VMWare error on a windows 10 computer.

---------------------------------------------------------------

1. In RUN box type "gpedit" then Goto 

- Computer Configuration

- Administrative Templates

- System - Device Guard

- Turn on Virtualization Based Security.

Now Double click that and "Disable"

2. Open Command Prompt as Administrator and type the following

gpupdate /force

3. Open Registry Editor, now Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\DeviceGuard. Add a new DWORD value named EnableVirtualizationBasedSecurity and set it to 0 to disable it.

Next Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA.  Add a new DWORD value named LsaCfgFlags and set it to 0 to disable it.

---------------------------------------------------------------

4. In RUN box, type Turn Windows features on or off, now uncheck Hyper-V and restart system.

---------------------------------------------------------------

5. Open command prompt as a administrator and type the following commands 

bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"

bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS

bcdedit /set hypervisorlaunchtype off

Now, Restart your system

---------------------------------------------------------------

Manage Windows Defender Credential Guard : https://docs.microsoft.com/en-us/windows/security/identity-protection/credential-guard/credential-gu...