Simon22
Contributor
Contributor

VMware Workstation 16 Pro Problems

I have a problem with my VMware Workstation Pro 16 installation. When working with a VM, the screen of the VM randomly and briefly goes black. The longer the VM is on, the more often the screen goes black and sometimes the VM is then in the Windows login screen and all programs have been closed. The problem exists with many different VMs and is therefore probably a general problem with my PC or the VMWare installation. My laptop is a LENOVO ThinkPad L15 G1 i5 with 32GB RAM. Host OS Version is: Windows 10 Enterprise, 64-bit (Build 19043.2006) 10.0.19043 and VMware Workstation Version is: VMware® Workstation 16 Pro 16.2.4 build-20089737.

Does anybody know this problem and have a possible solution for it?

6 Replies
Hovep
Contributor
Contributor

I haven't found the solution for this, but I'm fazing the same issue on my Lenovo Thinkpad X1 extreme i7 with 64Gb.
Host OS is Windows 11 Pro Version 10.0.22000 Build 22000 With multiple WM's running Windows 10 Pro

Sometimes it goes black and the application I was running restarts and sometimes the hole OS restarts. Very frustrating issue.

 

0 Kudos
Hovep
Contributor
Contributor

I was looking what I did before this was showing. I did an update for Workstation to the latest build and then I received the notification at the start of my VM's that the side channel was not disabled for Hyper-V enabled host. after I disabled the option as mentioned in the KB article https://kb.vmware.com/s/article/79832 after that the VM's has the problem with going black or resetting. When I disable this option again the problem seems to be gone. Only the performance is a little less.

0 Kudos
Hovep
Contributor
Contributor

I was a little to optimistic. The problem is less but still there.

0 Kudos
zandokan
Enthusiast
Enthusiast

I don't exactly understand what you're saying. You mention that problems arise "after [you] disabled the option as mentioned in the KB article". But then they are gone when you "disable this option again". So you disable the option twice? How do you do that?

Or do you mean that you ENabled it again after initially disabling it?

Does the 'Application' section in the Windows Logs in event viewer also mention a problem with dwm as described here?: https://communities.vmware.com/t5/VMware-Workstation-Player/Black-screens-two-or-more-loop-times-whi...

 

 

 

0 Kudos
johncouzins1
Contributor
Contributor

I have been having this issue for about 4-week now, total rebuild of my machine, VMware Workstation, different drivers and still have the issue. 

0 Kudos
Hovep
Contributor
Contributor

@zandokan Before the problem started I never have any thing done to the option 'Disable side chanenel migrations for Hyper-V enabled hosts' and one day at starting the VM It complained that I had to check the option because other wise it could have performance issues. From that time on I have the problem with the screen going to black. No mather if I enable or disable the option.

And Yes I see the same problems with the Dwminit

Faulting application name: dwm.exe, version: 10.0.19041.746, time stamp: 0x6be51595
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1949, time stamp: 0xcb12e58e
Exception code: 0x8898009b
Fault offset: 0x000000000010fb62
Faulting process ID: 0x1f70
Faulting application start time: 0x01d8dcbf6969c780
Faulting application path: C:\WINDOWS\system32\dwm.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: 9b893833-0058-4b6c-b0a7-56466e4182c1
Faulting package full name:
Faulting package-relative application ID: