Contributor
Contributor

VMware Workstation 15.1 mouse issue with RDP and Windows 10 1903 host

I have a computer that I RDP into that runs the latest version of VMware Workstation (15.1). I just upgraded it from Windows 10 1809 to Windows 10 1903.

There is a defect where anytime the mouse changes inside a VM (like from a pointer to a hand) the mouse jumps slightly, making it very annoying to actually do anything in the VM with a mouse. The guest OS can be anything, Windows OR Linux. I'm also running the latest VMware tools in the guest.

This problem only occurs if the host is running Windows 10 1903 AND you are RDPing into that host. This is guest agnostic.

When I reverted the host back to 1809 the problem went away. The mouse jumping problem seems to be associated with a Windows 10 1903 host running VMware Workstation.

I'm not sure where to report this bug. I tried to buy a support contract for VMware Workstation but you can't buy one if you only hold one license.

Is there a place where I can report this bug? Does anyone have a workaround for it?

57 Replies
Contributor
Contributor

I would like to make a public service announcement regarding this issue and the proposed workaround:

Many people have found that disabling WDDM will effectively make Windows use XDDM. Doing this fixes the mouse problem. This is only going to be a short term fix. In Windows 10 1903, Microsoft replaced XDDM with WDDM and is no longer developing XDDM [1]. In an upcoming version of Windows 10, the option to not use WDDM will no longer be available. I would highly recommend either complaining to Microsoft, complaining to VMware, or finding another solution since this workaround is soon to no longer be available in a future version of Windows 10.

References:

[1] Windows 10 features we’re no longer developing | Microsoft Docs

0 Kudos
Enthusiast
Enthusiast

Great... In my case the mouse problem is not just annoying, it makes the session unusable...

0 Kudos
Contributor
Contributor

gpedit fix did not work for me for a windows 1903 vm. i installed a windows 1909 vm hoping it might be fixed in the later build but the problem is still there.

0 Kudos
Contributor
Contributor

You need to do this in the VMWare Workstation host, not the VM.

0 Kudos
Contributor
Contributor

did it on the host which is a Windows 10 1909 build. didnt work.

0 Kudos
Contributor
Contributor

Hmmm... bummer. My host OS is Win 10 1903. (VMware Workstation 15.5.1 build-15018445) I will let you know if it stays fixed when 1909 shows up for me.

0 Kudos
Contributor
Contributor

my situation seems a lil different tho, when the desktop is shown, my mouse isnt jumpy. but when firefox or edge is upfront and center or when i drag on a window to move it, that's when its jumpy.

0 Kudos
Contributor
Contributor

I just started experiencing this on 1909 and found this thread.  The GPEDIT.msc WDDM graphics suggestion fixed the problem for me on 1909.  Thanks!

0 Kudos
Contributor
Contributor

The Group Policy modification worked for me as well.  Hooray!

No reboot required.  I did do a "gpupdate /force" just to be sure, but I don't know if that was required.  After doing the gpupdate, I disconnected my RDP and reconnected, and the VM mouse is normal now.

0 Kudos
Contributor
Contributor

I experience the same issue while working on VMware Worstation 15 running on Windows 10.

Sadly the registry / group policy change did not help in my case.

But after some day i found some other reason why my mouse in the virtual machine was going do move alone.

I had to disable "Smart sizing" for the RDP Connection and then the problem was gone.

This option of RDP is nice and helpfull if you run the RDP in window and not full screen mode but was causing this problem for me.

The option can be activated / deactivated on a open RDP session in window mode by open the context menu with the right mouse click to the title bar.

0 Kudos
Contributor
Contributor

Ok, i had this exact problem and finally I realized that i had mouse pointer trails enabled in the client pc i was RDP'ing from and also in the client vm within the host I was RDP'ing to

The host had no mouse trails enabled.

Once i removed the mouse trails from the client vm.

The mouse behaviour went back to normal.

0 Kudos
Contributor
Contributor

Good evening,

I had the same problem and did exactly as you did, i.e., turned off "Smart Size" in my remote desktop setting and the mouse has stopped moving on its own.  Therefore, I can concur that this solution does work, and hopefully it works for other individuals as well.

0 Kudos
Contributor
Contributor

OK here is a solution - to install VMware Tools 10.3.0:

List installed versions
[root@rhel7u6 ~]# rpm -qa|grep open-vm-tools
open-vm-tools-desktop-10.2.5-3.el7.x86_64
open-vm-tools-10.2.5-3.el7.x86_64

0 Kudos
Enthusiast
Enthusiast

Many people have found that disabling WDDM will effectively make Windows use XDDM. Doing this fixes the mouse problem. This is only going to be a short term fix. In Windows 10 1903, Microsoft replaced XDDM with WDDM and is no longer developing XDDM [1]. In an upcoming version of Windows 10, the option to not use WDDM will no longer be available. I would highly recommend either complaining to Microsoft, complaining to VMware, or finding another solution since this workaround is soon to no longer be available in a future version of Windows 10.

We can only hope Microsoft will resolve it by then.  This is not a VMware issue at all, except maybe that VMware causes enough delay that it shows up.  If you remote into a hardware system halfway across the country the problem shows up as well.  Looks like it's a case where the new WDDM implementation has a basic design problem having to do with which system, controlling or controlled, has control over the cursor positioning.  When the delay is tiny it doesn't matter as they both converge.

Or maybe our experience will just get worse using Windows.  That's a strategy Microsoft has been employing since end of the Vista era.  Nothing at Microsoft says it has to actually work right.

-Noel

0 Kudos
VMware Employee
VMware Employee

TL;DR SOLVED via Windows 10 1903 Remote Desktop cursor stutters with multiple displays at URL https://answers.microsoft.com/en-us/windows/forum/all/windows-10-1903-remote-desktop-cursor-stutters...

Relevant excerpt:

Workaround: Set "Use WDDM graphics display driver for Remote Desktop Connections" to Disabled in group policy.

(found at Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment)

0 Kudos
Contributor
Contributor

Did you set it on target machine or source where you ran RDC?

0 Kudos
Contributor
Contributor

Hey all,

This issue appears to be resolved with the Windows 10 20H2 update (https://blogs.windows.com/windowsexperience/2020/10/20/how-to-get-the-windows-10-october-2020-update...)

No workaround required anymore.

0 Kudos
Contributor
Contributor

Facing this problem when i do RDP into my new laptop with a red hat linux vm in the latest version of VMware Workstation, the mouse is shaky, cant even work.

But the problem is limited to RDP connection, locally on laptop it works fine where this VMware workstation is. I tried using anydesk to connect to my laptop and found anydesk session doesnt have this mouse shaky issues inside the guest VM

0 Kudos