pb79
Contributor
Contributor

VMware Pro 16 - mouse stutter on W10 H2 when set 4K resolution.

VMware Pro 16 - mouse stutter on W10 H2 when set 4K resolution (work via Remote Desktop). I set 8GB RAM for graphics but it did not change anything. VMware drivers reinstalled. Any ideas?

22 Replies
WhiteKnight
Hot Shot
Hot Shot

What kind of stutter is it you're facing?

I may have a similar issue:

Many of my mouse clicks don't reach through to the VM (Windows 10x64, Workstation 16 hardware). Many times I have to click/double click twice or three times to finally see an effect in the VM.



[VMware]: Workstation 16 Pro; --
[host]: Windows 10x64 host; --
[guests]: Windows 10x64, Windows 8x64.
0 Kudos
pb79
Contributor
Contributor

Mouse cursor is jumping. VM is extremely slow compared to FHD setting when there is no such problem at all.

0 Kudos
ender_
Hot Shot
Hot Shot

Try this: Preferences → Input → Cursor → Optimize mouse for games → Never (I've had problems when this was set to anything else).

0 Kudos
hahakiki2010
VMware Employee
VMware Employee

 

I can not reproduce the described issue on my test machine. My host is Win10 H2 with WS 16.1 installed, and my guest is Win10 H2 also . I tried setting the host to 4K resolution and hold the mouse to move around on host and in guest, however neither see the mouse stutter on Win10 H2.

We need more information to figure out what happened. Could you record a video and provide more information about your test environment? like Guest OS, Host OS, Graphic card, host machine model, Hyperv status, and etc.

If you're saying it work via Remote desktop, you can try to disable 3D and see if the issue is gone. 

 

 

 

 

0 Kudos
pb79
Contributor
Contributor

Mouse cursor is slowing down (choppy) when "Free Stretch" option is turned on. Please also note that I am using 4K display.

0 Kudos
andylamp
Contributor
Contributor

Hello hahakiki2010,

I think my setup exhibits the same problem as the initial user suggested, I think I captured a video of it. To do so, I used my phone to showcase it but it's starkly evident; you can view the video here. Let me know if you have any other clarifications or need any hardware info...

The vmware workstation version I am currently using and exhibits this behaviour is the latest one available to download: 16.1.0 build-17198959. I am also using a G-Sync monitor (enabled) along with an nvidia gpu (if that helps at all). Further, in Windows I have enabled Hardware-accelerated GPU scheduling and VRR.

Hope this helps to get to the bottom of this as it can be extremely annoying 🙂

Cheers

0 Kudos
andylamp
Contributor
Contributor

@hahakiki2010 aha,I found a way to tag you - sorry not familiar with the forum functionality yet. Please look into the reply I had above as it has a video showcasing the issue.

0 Kudos
chaossysten
Contributor
Contributor

Also experiencing this issue the same as in the video and it affects Guests as well.

0 Kudos
andylamp
Contributor
Contributor

Any official response from VMware? This is a serious (and insanely annoying) issue!

0 Kudos
spaceballs3000
Contributor
Contributor

I'm also seeing this problem!

I used "bcdedit /set hypervisorlaunchtype off" VMs now more responsive so far.

got it from here https://communities.vmware.com/t5/VMware-Workstation-Pro/Workstation-15-5-5-performance-hit/td-p/186...

0 Kudos
chaossysten
Contributor
Contributor

I use Docker with Hyper-V so that's a no no for me 😞

0 Kudos
andylamp
Contributor
Contributor

is vmware really aware of the issue? no official replies have been provided and clearly it is widespread enough that people are here commenting... tagging few other vmware employees that I could find @bonnie201110141 @Mikero 

 

PS: happy x-mas 🙂

0 Kudos
flrvt
Contributor
Contributor

Hi,

I was having the same issue, driving me nuts, and I couldn't find the cause either.

However, I managed to fix it by setting the scaling of the Guest display to 125%.
Strangely my monitor is set to 100% in the Host so I don't know why that fixes it. 

I prefer 100% over 125% but since the flickering is now gone I will get used to that.

0 Kudos
andylamp
Contributor
Contributor

I am not using scaling nor any of these things; actually I am using a ultra widescreen monitor with G-Sync (AW3420DW) if that helps.

 

@hahakiki2010 you suggestion didn't help so the issue is still present am afraid.

0 Kudos
flrvt
Contributor
Contributor

I was not using scaling as well. But by default operating systems apply some sort of scaling. 

Well, you could say if both Host and Guest are set to 100% there is no scaling indeed.

However, setting the scaling in my Ubuntu Guest to 125%, therefore enabling scaling, fixed this issue for me.

YMMV.

0 Kudos
VMUser6
Contributor
Contributor

Can reproduce the exact same problem @andylamp is facing.

 

Windows 10, 2004 19041.804
Dual NVIDIA 3090, Driver 461.72

Bug makes VMs unusable as the constant cursor flicker/change seems to halt the VM Video Output.

 

Its not related to the guest in any way as its already happening before booting any guest. The player/workstation itself seems to be bugged.

VMWare please fix this.

andylamp
Contributor
Contributor

Guys - this is an Nvidia driver issue from the looks of it; I have downgraded to version 457.09 and the problem goes away.

 

I have also created an issue with Nvidia support for two months however, they have yet to do anything about this.

 

Perhaps VMware can push them a bit more as a company?

Tags (1)
0 Kudos
VMUser6
Contributor
Contributor

Sadly downgrading the driver doesnt seem to work for everyone, 457.09 just bluescreens when I start a VM.

Its very sad that such problems are not fixed within days.

Edit: I was able to downgrade to "456.71-desktop-win10-64bit-international-whql.exe" (SHA256: 570FD1DD03FCA65644CA555B0A988752E1A71E5EDB8502E80DEDC925637EA6DF), and VMs seem to run without problems now. Also VMWare Player seems like it was not as badly affected as VMWare Workstation Pro.

0 Kudos
CharlesGilley
Enthusiast
Enthusiast

Andy -

  What NVidia card do you have?  I must respectfully disagree with your conclusion.  Using your post, I grabbed the version you suggested, one before it,, and two after it including the latest.  In my case - VMs running on my base laptop (i7 with 64GB of ram and a 1070) suffer from mouse stutter (so I am a little different from the OP who is using RDP).  The VMs are Xp, Windows 7 and Windows 10.  Oddly, the stutter is worse when mousing over menus and what not.

  Changing the mouse input mode only makes matters worse.

This issue comes and goes for me.  I had been running 15.5.5 happily, and I gave in to the nagging of 15.5.7.  As soon as I applied 15.5.7, this mouse issue started.  I've gone back to 15.5.6, and it's still stuttering.  Based on my notes, people using versions of 14.x have seen this as well.

regards,

0 Kudos