VMware Communities
Ben24
Contributor
Contributor

VMWare workstation 17 works slow and laggy - Win10

Hey Guys, attached is VMSupport file of my VM Machine which works extremely slow. new computer. any ideas?  

Reply
0 Kudos
14 Replies
wila
Immortal
Immortal

Hi,

Your vmware.log file has this line:

2023-04-12T17:43:00.864Z In(05) vmx Monitor Mode: ULM

There can be reasons to keep it like that (see the KB article below), but it is also known for causing issues.

monitor mode ULM

means that you are running in User Level Mode and thus Workstation cannot use VMware's hypervisor, but instead it has to go through the Hypervisor API that Microsoft provides.

Only when Monitor mode returns CPL0 it is running in ring 0, a.k.a. no hypervisor.

Monitor mode CPL0 (Current Privilege Level 0) is required for VMware Workstation to be able to use their own hypervisor.

See also:

https://communities.vmware.com/t5/VMware-Workstation-Pro/MikroTik-RouterOS-boot-speed-is-drastically...

In order to turn off ULM/Hyper-V mode, run the following command at the host in windows command-line with Administrator privileges:

bcdedit /set hypervisorlaunchtype off

Reboot the system to activate your changes.

If you want to go back to Hyper-V mode again, then you can enable it like this:

bcdedit /set hypervisorlaunchtype auto


See also:

Note that you also might have to disable Memory Integrity.

Windows Security -> Device Security -> Core Isolation details

Don't forget to reboot the host after making any of these changes.

good luck!
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

Thank you for your suggestions. However, despite following them, the performance is still slow.
How can I debug it further? 

Reply
0 Kudos
wila
Immortal
Immortal

Hi,

It's pretty difficult to turn off the Hyper-V mode nowadays.
Does monitor mode in the vmware.log file now report CPL0 or is it still ULM?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

Hey, I checked. it seems to be the same - 
2023-04-12T23:17:51.470Z In(05) vmx Monitor Mode: ULM

how to turn if off in Windows 10?

Reply
0 Kudos
wila
Immortal
Immortal

Maybe this other thread helps:

https://communities.vmware.com/t5/VMware-Workstation-Pro/Vmware-17-Pro-very-slow-on-Windows-11-22H2/...

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

I have implemented the suggestions they provided, but the issue of vmx Monitor Mode remaining in ULM instead of transitioning to CPL0 still persists.

Reply
0 Kudos
wila
Immortal
Immortal

Hi,

There was a workaround of changing power settings for the VMware process that appeared to help some.
Perhaps you have VBS enabled? That would also cause the monitor mode to be ULM. Note that the KB article in my first reply has a list of things that require ULM.

If that still doesn't help then try searching the forums here for ULM. Having trouble getting that disabled is a common issue and it's difficult for me to guess what is keeping that being a problem as I don't have the issue myself.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

If you are referring to the command - 
"powercfg /powerthrottling disable /path "C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe"",
I have executed it as instructed. However, the performance issue persists and the system remains slow.

Regarding VBS, I tried to disable it, but in MSINFO it seems that virtualization-based security is still running. 

Reply
0 Kudos
wila
Immortal
Immortal

Having VBS enabled would explain it.

Does this help?

https://www.tomshardware.com/how-to/disable-vbs-windows-11

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

Although I'm using Windows 10, I have followed the instructions provided, and the issue still persists.
Additionally, I find it strange that disabling DMA protection via the BIOS did not solve the problem.

MSINFO

Ben24_0-1681383936389.png

 

Windows Security - 

Ben24_1-1681384030589.png

 

 

Registry - 

Ben24_2-1681384089973.png

 

Windows Features - 

  • Hyper-v unticked. 
  • Virtual machine platform unticked. 
  • Microsoft Defender application guard unticked. 

 

Any ideas?

 

Reply
0 Kudos
Ben24
Contributor
Contributor

Could disable VBS using https://www.microsoft.com/en-us/download/details.aspx?id=53337

However, it seems the performance yet is not as expected, VMSupport LOG file is attached, could you please take a look? 

Thanks!

 

Reply
0 Kudos
wila
Immortal
Immortal

Hi,

Ok, monitor mode now indicates that it is using VMware's hypervisor, so Hyper-V is out of the picture.

In the VM configuration I notice that the network card is an "e1000".. those are known to be slow, change to either "e1000e" or "vmxnet3" .. now that isn't your current issue either.

However I also notice that vhv.enable is set to "true" which means that you are indicating that you want to run a VM in your VM. If you're not doing that then it makes no sense to have that checked.

eg. I suggest the following CPU settings:

wila_0-1681388653959.png

For the rest I'm not seeing much out of the ordinary.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Ben24
Contributor
Contributor

Thanks, I'm using nested virtualization so I can't disable VHV. 

How can I change this?
"In the VM configuration I notice that the network card is an "e1000".. those are known to be slow, change to either "e1000e" or "vmxnet3" .. now that isn't your current issue either."

Reply
0 Kudos
Ben24
Contributor
Contributor

Is there any reason I'm not getting a DHCP address via Wifi but if I'm connected with RJ45 it works like magic? 

Reply
0 Kudos