GDeanBlakely
Contributor
Contributor

VMWare can't see my eSata drive

I'm using Workstation 7.1. Both my host and my image are Windows 7 Ultimate 64bit.  Is there a way I can configure VMWare to see my eSata drive?  I've tried scanning for new hardware in device manager to no avail.  The host can see it just fine.  The image is able to see all of the USB drives.

Thanks,

Gary Blakely

0 Kudos
5 Replies
continuum
Immortal
Immortal

Yes
you must use diskpart and set the disk offline.
Then add a virtual disk and select the "advanced - use physical disk" option.

Sometimes setting the disk offline is not enough - then read
http://communities.vmware.com/thread/283469?tstart=0

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
GDeanBlakely
Contributor
Contributor

I'm wondering if you could elaborate a little...

I know that diskpart is a command line utility that I can download.  When you say "set the disk offline" do you mean on the host or on the Image?  When I "add a virtual disk" is this in the virtual machine?  Do I do that using VMWare tools?  Using diskpart on the image?

This sounds like a multi-step procedure.  does it have to be done everytime I bring up the virtual machine?  What has to be done when I want to again use the eSata drive on my host machine?

Why can't VMWare deal with eSata disks?

Thanks, Dean.

0 Kudos
continuum
Immortal
Immortal

eSata can not be directly used in a VM as a VM has no SATA-controller.
Thats why you must use it as a "physical disk"
To do that you open the Virtual hardware Editor and  click add "disk"
it will give you three options - you want the last one " advanced - use physical disk"
Then you select the correct disk by checking the disknumber. Compare with the disknumber in diskmanagement of the host.
Picking the correct number is very important.

When you now start the VM Workstation will fail after a few seconds or minutes.
That is why you must use diskpart.exe on the host first - and set the disk in question to status "offline"
In case that is not enough use the tool from the post I already mentioned above.

When all that is done you can start the VM - it will not see the disk as eSATA but as an IDE or SCSI-disk - thats normal.
As I mentioned before virtual machines have neither eSATA nor SATA.

When you want to use the disk with the host again you must power off the VM.
Open diskpart and set the disk to online status again.

VERY IMPORTANT : NEVER AND I MEAN NEVER TAKE SNAPSHOTS OF THIS VM OR USE SUSPEND OR SLEEP OR HIBERNATE INSIDE THIS VM


> does it have to be done everytime I bring up the virtual machine?

Yes - no  way around that

... diskpart ... no need to download it - you already have it.

Forgot to mention - you must start Workstation as administrator if you doo this

Take care - this is flagged as "advanced" for good reasons - don't be careless if you use disks like this - it is very easy to mess up the disks

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
GDeanBlakely
Contributor
Contributor

Well, this looks like a major pain.  Do you think the future versions of vmware workstation will support eSata?

Dean

0 Kudos
WoodyZ
Immortal
Immortal

Do you think the future versions of vmware workstation will support eSata?

The typical reply from VMware to a question like that is something like... It's against company policy to discusses unannounced features, time-lines, etc.

0 Kudos