jbwiv
Contributor
Contributor

VMWare Workstation won't run on Ubuntu 17.10

I just installed 17.10 this morning. VMWare 12.5.5, 12.5.6 and 12.5.7 all fail to work.


The first issue is that the regular GUI won't work.

The symptom was in journalctl:

vmware-modconfi[9120]: segfault at 2240 ip 0000000000002240 sp 00007ffe6a87f0a8 error 14 in appLoader[5556b3807000+ad000]

This was solved by

# cd /usr/lib/vmware/lib/libz.so.1

# mv libz.so.1 libz.so.1.old

# ln -s /lib/x86_64-linux-gnu/libz.so.1

Now, launching vmware will open the gui, but complain about missing gcc (even though gcc is indeed installed, as is all build-essential). Also, from the command line:

# vmware-modconfig --console --install-all

Failed to get gcc information

I then followed some instructions from the Arch community and manually compiled the vmnet and vmmon modules:

# cd /usr/lib/vmware/modules/source

# tar xf vmmon.tar

# tar xf vmnet.tar

# cd vmmon-only

# make

# mkdir /lib/modules/<mykernversion>/misc

# cp vmmon.o /lib/modules/<mykernversion>/misc

# cd ../vmnet-only

# make

# cp vmnet.ol /lib/modules/<mykernversion>/misc

# depmod -a

Now run vmware directly, bypassing the gcc check:

# /usr/lib/vmware/bin/vmware

But same error.

I tried to insmod the modules directly as:

# insmod /lib/modules/<mykernversion>/misc/vmmon.o

However, it would state "Invalid format".


Help please!?!

Thanks.

3 Replies
wila
Leadership
Leadership

Hi,

Ubuntu 17.10 is not released yet as you know.

You'll probably have  more luck using the beta/preview Workstation Pro Tech Preview

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
AndreD
Contributor
Contributor

any luck using the tech preview ?

0 Kudos
Navix201110141
Contributor
Contributor

It works, but only on Unity.

Ubuntu 17.10 final version

0 Kudos