thomas_datapola
Contributor
Contributor

VMWare Workstation on kernel 2.6.19 does not work

Jump to solution

Can not install Workstation on a PC with Fedora 6 and kernel 2.6.19Building the vmmon module.

here is th final rows when I run vmware-config.pl

Building for VMware Player 1.0.2 or 1.0.3 or VMware Workstation 5.5.2 or 5.5.3.

Using 2.6.x kernel build system.

make: Entering directory `/tmp/vmware-config6/vmmon-only'

make -C /lib/modules/2.6.19-1.2911.fc6/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

CC /tmp/vmware-config6/vmmon-only/linux/driver.o

CC /tmp/vmware-config6/vmmon-only/linux/hostif.o

CC /tmp/vmware-config6/vmmon-only/common/cpuid.o

CC /tmp/vmware-config6/vmmon-only/common/hash.o

CC /tmp/vmware-config6/vmmon-only/common/memtrack.o

CC /tmp/vmware-config6/vmmon-only/common/phystrack.o

CC /tmp/vmware-config6/vmmon-only/common/task.o

gcc: error trying to exec 'cc1plus': execvp: No such file or directory

make[2]: *** Error 1

make[1]: *** \[_module_/tmp/vmware-config6/vmmon-only] Error 2

make[1]: Leaving directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

make: *** \[vmmon.ko] Error 2

make: Leaving directory `/tmp/vmware-config6/vmmon-only'

Unable to build the vmmon module.

What shall I do?? Really want to run VMWare ...

0 Kudos
1 Solution

Accepted Solutions
KevinG
Immortal
Immortal

You are missing the gcc-c++ package from your Fedora Core install.

You may also need to apply Petr's patch to be able to use that kernel version. Please install gcc-c++ package first and post new output from vmware-config.pl script

Petr's unofficial vmware-any-any-update108.tar.gz can be found here

http://knihovny.cvut.cz/ftp/pub/vmware/

View solution in original post

0 Kudos
3 Replies
KevinG
Immortal
Immortal

You are missing the gcc-c++ package from your Fedora Core install.

You may also need to apply Petr's patch to be able to use that kernel version. Please install gcc-c++ package first and post new output from vmware-config.pl script

Petr's unofficial vmware-any-any-update108.tar.gz can be found here

http://knihovny.cvut.cz/ftp/pub/vmware/

0 Kudos
thomas_datapola
Contributor
Contributor

Building the vmnet module.

Building for VMware Player 1.0.x or VMware Workstation 5.5.x.

Using 2.6.x kernel build system.

make: Entering directory `/tmp/vmware-config7/vmnet-only'

make -C /lib/modules/2.6.19-1.2911.fc6/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

make[1]: Entering directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

CC /tmp/vmware-config7/vmnet-only/driver.o

CC /tmp/vmware-config7/vmnet-only/hub.o

CC /tmp/vmware-config7/vmnet-only/userif.o

/tmp/vmware-config7/vmnet-only/userif.c: In function ‘VNetCopyDatagramToUser’:

/tmp/vmware-config7/vmnet-only/userif.c:632: error: ‘CHECKSUM_HW’ undeclared (first use in this function)

/tmp/vmware-config7/vmnet-only/userif.c:632: error: (Each undeclared identifier is reported only once

/tmp/vmware-config7/vmnet-only/userif.c:632: error: for each function it appears in.)

make[2]: *** Error 1

make[1]: *** \[_module_/tmp/vmware-config7/vmnet-only] Error 2

make[1]: Leaving directory `/usr/src/kernels/2.6.19-1.2911.fc6-i686'

make: *** \[vmnet.ko] Error 2

make: Leaving directory `/tmp/vmware-config7/vmnet-only'

Unable to build the vmnet module.

0 Kudos
KevinG
Immortal
Immortal

Ok, you will need Petr's unofficial vmware-any-any-update108.tar.gz can be found here

http://knihovny.cvut.cz/ftp/pub/vmware/